]> git.pld-linux.org Git - packages/libinput.git/blob - libinput.spec
- updated to 0.7.0
[packages/libinput.git] / libinput.spec
1 #
2 # Conditional build:
3 %bcond_with     gui             # event-gui (noinst as of 0.4.0)
4 %bcond_with     static_libs     # static library
5 #
6 Summary:        Input device library
7 Summary(pl.UTF-8):      Biblioteka urządzeń wejściowych
8 Name:           libinput
9 Version:        0.7.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
14 # Source0-md5:  381b61396de28c12716ef7a5475fea50
15 URL:            http://www.freedesktop.org/wiki/Software/libinput/
16 %{?with_gui:BuildRequires:      cairo-devel}
17 BuildRequires:  check-devel >= 0.9.10
18 BuildRequires:  doxygen
19 %{?with_gui:BuildRequires:      glib2-devel >= 2.0}
20 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.0}
21 BuildRequires:  libevdev-devel >= 0.4
22 BuildRequires:  mtdev-devel >= 1.1.0
23 BuildRequires:  pkgconfig
24 BuildRequires:  udev-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 libinput is a library that handles input devices for display servers
29 and other applications that need to directly deal with input devices.
30
31 It provides device detection, device handling, input device event
32 processing and abstraction so minimize the amount of custom input code
33 the user of libinput need to provide the common set of functionality
34 that users expect.
35
36 %description -l pl.UTF-8
37 libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
38 grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
39 wejściowych.
40
41 Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
42 przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
43 minimalizując ilość własnego kodu, który musi napisać użytkownik
44 biblioteki, aby zapewnić oczekiwaną funkcjonalność.
45
46 %package devel
47 Summary:        Development files for libinput
48 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libinput
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       udev-devel
52
53 %description devel
54 This package contains the header files for developing applications
55 that use libinput.
56
57 %description devel -l pl.UTF-8
58 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
59 wykorzystujących bibliotekę libinput.
60
61 %package static
62 Summary:        Static libinput library
63 Summary(pl.UTF-8):      Statyczna biblioteka libinput
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static libinput library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka libinput.
72
73 %package apidocs
74 Summary:        API documentation for libinput library
75 Summary(pl.UTF-8):      Dokumentacja API biblioteki libinput
76 Group:          Documentation
77
78 %description apidocs
79 API documentation for libinput library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki libinput.
83
84 %prep
85 %setup -q
86
87 %build
88 %configure \
89         --disable-silent-rules \
90         %{?with_static_libs:--enable-static}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 # obsoleted by pkg-config
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc COPYING README
112 %attr(755,root,root) %{_libdir}/libinput.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libinput.so.5
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libinput.so
118 %{_includedir}/libinput.h
119 %{_pkgconfigdir}/libinput.pc
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libinput.a
125 %endif
126
127 %files apidocs
128 %defattr(644,root,root,755)
129 %doc doc/html/*
This page took 0.044445 seconds and 4 git commands to generate.