]> git.pld-linux.org Git - packages/libinput.git/blob - libinput.spec
- use __true_false macro
[packages/libinput.git] / libinput.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # libinput-debug-gui
4 %bcond_without  libunwind       # libunwind debugging support
5 %bcond_with     static_libs     # static library
6 %bcond_without  doc             # documentation
7 %bcond_without  tests           # tests
8
9 %ifnarch %{ix86} %{x8664} %{arm} hppa ia64 mips ppc ppc64 sh
10 %undefine       with_libunwind
11 %endif
12 Summary:        Input device library
13 Summary(pl.UTF-8):      Biblioteka urządzeń wejściowych
14 Name:           libinput
15 Version:        1.9.0
16 Release:        1
17 License:        MIT
18 Group:          Libraries
19 Source0:        https://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
20 # Source0-md5:  b33b5505f639bf01a6e2e3a01892e91f
21 URL:            https://www.freedesktop.org/wiki/Software/libinput/
22 BuildRequires:  check-devel >= 0.9.10
23 %if %{with gui}
24 BuildRequires:  cairo-devel
25 BuildRequires:  glib2-devel >= 2.0
26 BuildRequires:  gtk+3-devel >= 3.0
27 %endif
28 %if %{with apidocs}
29 BuildRequires:  doxygen >= 1.6.0
30 BuildRequires:  graphviz >= 2.26.0
31 %endif
32 BuildRequires:  libevdev-devel >= 1.3
33 %{?with_libunwind:BuildRequires:        libunwind-devel}
34 BuildRequires:  libwacom-devel >= 0.20
35 BuildRequires:  meson
36 BuildRequires:  mtdev-devel >= 1.1.0
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(macros) >= 1.728
39 BuildRequires:  udev-devel
40 Requires:       libevdev >= 1.3
41 Requires:       libwacom >= 0.20
42 Requires:       mtdev >= 1.1.0
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 libinput is a library that handles input devices for display servers
47 and other applications that need to directly deal with input devices.
48
49 It provides device detection, device handling, input device event
50 processing and abstraction so minimize the amount of custom input code
51 the user of libinput need to provide the common set of functionality
52 that users expect.
53
54 %description -l pl.UTF-8
55 libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
56 grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
57 wejściowych.
58
59 Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
60 przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
61 minimalizując ilość własnego kodu, który musi napisać użytkownik
62 biblioteki, aby zapewnić oczekiwaną funkcjonalność.
63
64 %package gui
65 Summary:        Debugging GUI for libinput
66 Summary(pl.UTF-8):      Graficzny interfejs diagnostyczny do libinput
67 Group:          X11/Applications
68 Requires:       %{name} = %{version}-%{release}
69
70 %description gui
71 Debugging GUI for libinput.
72
73 %description gui -l pl.UTF-8
74 Graficzny interfejs diagnostyczny do libinput.
75
76 %package devel
77 Summary:        Development files for libinput
78 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libinput
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       udev-devel
82
83 %description devel
84 This package contains the header files for developing applications
85 that use libinput.
86
87 %description devel -l pl.UTF-8
88 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
89 wykorzystujących bibliotekę libinput.
90
91 %package static
92 Summary:        Static libinput library
93 Summary(pl.UTF-8):      Statyczna biblioteka libinput
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static libinput library.
99
100 %description static -l pl.UTF-8
101 Statyczna biblioteka libinput.
102
103 %package apidocs
104 Summary:        API documentation for libinput library
105 Summary(pl.UTF-8):      Dokumentacja API biblioteki libinput
106 Group:          Documentation
107 %if "%{_rpmversion}" >= "5"
108 BuildArch:      noarch
109 %endif
110
111 %description apidocs
112 API documentation for libinput library.
113
114 %description apidocs -l pl.UTF-8
115 Dokumentacja API biblioteki libinput.
116
117 %prep
118 %setup -q
119
120 %build
121 %meson build \
122         -Ddebug-gui=%{__true_false gui} \
123         -Ddocumentation=%{__true_false doc} \
124         -Dudev-dir=/lib/udev
125 %meson_build -C build
126
127 %{?with_tests:%meson_test -C build}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %meson_install -C build
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc COPYING README.md
143 %attr(755,root,root) %{_bindir}/libinput
144 %attr(755,root,root) %{_bindir}/libinput-debug-events
145 %attr(755,root,root) %{_bindir}/libinput-list-devices
146 %attr(755,root,root) %{_libdir}/libinput.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libinput.so.10
148 %dir %{_libexecdir}/libinput
149 %attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-events
150 %attr(755,root,root) %{_libexecdir}/libinput/libinput-list-devices
151 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure
152 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-pressure
153 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-tap
154 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touch-size
155 %attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-trackpoint-range
156 %attr(755,root,root) /lib/udev/libinput-device-group
157 %attr(755,root,root) /lib/udev/libinput-model-quirks
158 /lib/udev/rules.d/80-libinput-device-groups.rules
159 /lib/udev/hwdb.d/90-libinput-model-quirks.hwdb
160 /lib/udev/rules.d/90-libinput-model-quirks.rules
161 %{_mandir}/man1/libinput.1*
162 %{_mandir}/man1/libinput-debug-events.1*
163 %{_mandir}/man1/libinput-list-devices.1*
164 %{_mandir}/man1/libinput-measure.1*
165 %{_mandir}/man1/libinput-measure-touchpad-pressure.1*
166 %{_mandir}/man1/libinput-measure-touchpad-tap.1*
167 %{_mandir}/man1/libinput-measure-touch-size.1*
168 %{_mandir}/man1/libinput-measure-trackpoint-range.1*
169
170 %if %{with gui}
171 %files gui
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-gui
174 %{_mandir}/man1/libinput-debug-gui.1*
175 %endif
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libinput.so
180 %{_includedir}/libinput.h
181 %{_pkgconfigdir}/libinput.pc
182
183 %if %{with static_libs}
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libinput.a
187 %endif
188
189 %files apidocs
190 %defattr(644,root,root,755)
191 %doc build/html/*
This page took 0.06509 seconds and 4 git commands to generate.