]> git.pld-linux.org Git - packages/libinput.git/blame_incremental - libinput.spec
- added doc bcond to allow building without generating docs
[packages/libinput.git] / libinput.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with gui # event-gui (noinst as of 0.4.0)
4%bcond_with static_libs # static library
5%bcond_without doc # documentation
6
7Summary: Input device library
8Summary(pl.UTF-8): Biblioteka urządzeń wejściowych
9Name: libinput
10Version: 1.6.3
11Release: 1
12License: MIT
13Group: Libraries
14Source0: https://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
15# Source0-md5: 62f4a283925ac7ebe6cc59884801aa69
16URL: https://www.freedesktop.org/wiki/Software/libinput/
17BuildRequires: check-devel >= 0.9.10
18%if %{with gui}
19BuildRequires: cairo-devel
20BuildRequires: glib2-devel >= 2.0
21BuildRequires: gtk+3-devel >= 3.0
22%endif
23%if %{with apidocs}
24BuildRequires: doxygen >= 1.6.0
25BuildRequires: graphviz >= 2.26.0
26%endif
27BuildRequires: libevdev-devel >= 0.4
28BuildRequires: libwacom-devel >= 0.20
29BuildRequires: mtdev-devel >= 1.1.0
30BuildRequires: pkgconfig
31BuildRequires: udev-devel
32Requires: libevdev >= 0.4
33Requires: libwacom >= 0.20
34Requires: mtdev >= 1.1.0
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38libinput is a library that handles input devices for display servers
39and other applications that need to directly deal with input devices.
40
41It provides device detection, device handling, input device event
42processing and abstraction so minimize the amount of custom input code
43the user of libinput need to provide the common set of functionality
44that users expect.
45
46%description -l pl.UTF-8
47libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
48grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
49wejściowych.
50
51Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
52przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
53minimalizując ilość własnego kodu, który musi napisać użytkownik
54biblioteki, aby zapewnić oczekiwaną funkcjonalność.
55
56%package devel
57Summary: Development files for libinput
58Summary(pl.UTF-8): Pliki programistyczne biblioteki libinput
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61Requires: udev-devel
62
63%description devel
64This package contains the header files for developing applications
65that use libinput.
66
67%description devel -l pl.UTF-8
68Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
69wykorzystujących bibliotekę libinput.
70
71%package static
72Summary: Static libinput library
73Summary(pl.UTF-8): Statyczna biblioteka libinput
74Group: Development/Libraries
75Requires: %{name}-devel = %{version}-%{release}
76
77%description static
78Static libinput library.
79
80%description static -l pl.UTF-8
81Statyczna biblioteka libinput.
82
83%package apidocs
84Summary: API documentation for libinput library
85Summary(pl.UTF-8): Dokumentacja API biblioteki libinput
86Group: Documentation
87%if "%{_rpmversion}" >= "5"
88BuildArch: noarch
89%endif
90
91%description apidocs
92API documentation for libinput library.
93
94%description apidocs -l pl.UTF-8
95Dokumentacja API biblioteki libinput.
96
97%prep
98%setup -q
99
100%build
101%configure \
102 --disable-silent-rules \
103 %{?with_static_libs:--enable-static} \
104 --%{?with_doc:en}%{!?with_doc:dis}able-documentation \
105 --with-udev-dir=/lib/udev
106
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
115# obsoleted by pkg-config
116%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(644,root,root,755)
126%doc COPYING README.txt
127%attr(755,root,root) %{_bindir}/libinput-debug-events
128%attr(755,root,root) %{_bindir}/libinput-list-devices
129%attr(755,root,root) %{_libdir}/libinput.so.*.*.*
130%attr(755,root,root) %ghost %{_libdir}/libinput.so.10
131%attr(755,root,root) /lib/udev/libinput-device-group
132%attr(755,root,root) /lib/udev/libinput-model-quirks
133/lib/udev/rules.d/80-libinput-device-groups.rules
134/lib/udev/hwdb.d/90-libinput-model-quirks.hwdb
135/lib/udev/rules.d/90-libinput-model-quirks.rules
136%{_mandir}/man1/libinput-debug-events.1*
137%{_mandir}/man1/libinput-list-devices.1*
138
139%files devel
140%defattr(644,root,root,755)
141%attr(755,root,root) %{_libdir}/libinput.so
142%{_includedir}/libinput.h
143%{_pkgconfigdir}/libinput.pc
144
145%if %{with static_libs}
146%files static
147%defattr(644,root,root,755)
148%{_libdir}/libinput.a
149%endif
150
151%files apidocs
152%defattr(644,root,root,755)
153%doc doc/html/*
This page took 0.027589 seconds and 4 git commands to generate.