]> git.pld-linux.org Git - packages/libinput.git/blame_incremental - libinput.spec
up to 1.17.0
[packages/libinput.git] / libinput.spec
... / ...
CommitLineData
1# TODO:
2# - package user docs from build/Documentation
3#
4# Conditional build:
5%bcond_without gui # libinput-debug-gui
6%bcond_without libunwind # libunwind debugging support
7%bcond_without doc # documentation
8%bcond_without tests # tests
9
10%ifnarch %{ix86} %{x8664} %{arm} hppa ia64 mips ppc ppc64 sh
11%undefine with_libunwind
12%endif
13Summary: Input device library
14Summary(pl.UTF-8): Biblioteka urządzeń wejściowych
15Name: libinput
16Version: 1.17.0
17Release: 1
18License: MIT
19Group: Libraries
20Source0: https://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
21# Source0-md5: 9d25bc0618a9abfaee1807358ed468b3
22URL: https://www.freedesktop.org/wiki/Software/libinput/
23BuildRequires: check-devel >= 0.9.10
24BuildRequires: libevdev-devel >= 1.3
25%{?with_libunwind:BuildRequires: libunwind-devel}
26BuildRequires: libwacom-devel >= 0.20
27BuildRequires: meson >= 0.45.0
28BuildRequires: mtdev-devel >= 1.1.0
29BuildRequires: ninja >= 1.5
30BuildRequires: pkgconfig
31BuildRequires: rpmbuild(macros) >= 1.736
32BuildRequires: udev-devel
33BuildRequires: valgrind
34%if %{with gui}
35BuildRequires: cairo-devel
36BuildRequires: glib2-devel >= 2.0
37BuildRequires: gtk+3-devel >= 3.20
38%endif
39%if %{with doc}
40BuildRequires: doxygen >= 1.8.3
41BuildRequires: graphviz >= 2.26.0
42BuildRequires: python3-recommonmark
43BuildRequires: python3-sphinx_rtd_theme
44BuildRequires: sphinx-pdg-3
45%endif
46Requires: libevdev >= 1.3
47Requires: libwacom >= 0.20
48Requires: mtdev >= 1.1.0
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52libinput is a library that handles input devices for display servers
53and other applications that need to directly deal with input devices.
54
55It provides device detection, device handling, input device event
56processing and abstraction so minimize the amount of custom input code
57the user of libinput need to provide the common set of functionality
58that users expect.
59
60%description -l pl.UTF-8
61libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
62grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
63wejściowych.
64
65Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
66przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
67minimalizując ilość własnego kodu, który musi napisać użytkownik
68biblioteki, aby zapewnić oczekiwaną funkcjonalność.
69
70%package gui
71Summary: Debugging GUI for libinput
72Summary(pl.UTF-8): Graficzny interfejs diagnostyczny do libinput
73Group: X11/Applications
74Requires: %{name} = %{version}-%{release}
75Requires: gtk+3 >= 3.20
76
77%description gui
78Debugging GUI for libinput.
79
80%description gui -l pl.UTF-8
81Graficzny interfejs diagnostyczny do libinput.
82
83%package devel
84Summary: Development files for libinput
85Summary(pl.UTF-8): Pliki programistyczne biblioteki libinput
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: udev-devel
89
90%description devel
91This package contains the header files for developing applications
92that use libinput.
93
94%description devel -l pl.UTF-8
95Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
96wykorzystujących bibliotekę libinput.
97
98%package apidocs
99Summary: API documentation for libinput library
100Summary(pl.UTF-8): Dokumentacja API biblioteki libinput
101Group: Documentation
102%if "%{_rpmversion}" >= "4.6"
103BuildArch: noarch
104%endif
105
106%description apidocs
107API documentation for libinput library.
108
109%description apidocs -l pl.UTF-8
110Dokumentacja API biblioteki libinput.
111
112%package -n zsh-completion-%{name}
113Summary: Zsh completion for libinput command
114Summary(pl.UTF-8): Dopełnianie parametrów w zsh dla polecenia libinput
115Group: Applications/Shells
116Requires: %{name} = %{epoch}:%{version}-%{release}
117Requires: zsh
118
119%description -n zsh-completion-%{name}
120Zsh completion for libinput command.
121
122%description -n zsh-completion-%{name} -l pl.UTF-8
123Dopełnianie parametrów w zsh dla polecenia libinput.
124
125%prep
126%setup -q
127
128%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
129 tools/libinput-analyze-{per-slot-delta,recording,touch-down-state}.py \
130 tools/libinput-measure-{fuzz,touchpad-pressure,touch-size,touchpad-tap}.py \
131 tools/libinput-{replay,measure-touchpad-size}.py
132
133%build
134%meson build \
135 -Ddebug-gui=%{__true_false gui} \
136 -Ddocumentation=%{__true_false doc} \
137 -Dudev-dir=/lib/udev \
138 -Dzshcompletiondir=%{zsh_compdir}
139
140%ninja_build -C build
141
142%{?with_tests:%ninja_test -C build}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147%ninja_install -C build
148
149%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/libinput-test-suite.1
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%post -p /sbin/ldconfig
155%postun -p /sbin/ldconfig
156
157%files
158%defattr(644,root,root,755)
159%doc COPYING README.md
160%attr(755,root,root) %{_bindir}/libinput
161%attr(755,root,root) %{_libdir}/libinput.so.*.*.*
162%attr(755,root,root) %ghost %{_libdir}/libinput.so.10
163%dir %{_libexecdir}/libinput
164%attr(755,root,root) %{_libexecdir}/libinput/libinput-analyze
165%attr(755,root,root) %{_libexecdir}/libinput/libinput-analyze-per-slot-delta
166%attr(755,root,root) %{_libexecdir}/libinput/libinput-analyze-recording
167%attr(755,root,root) %{_libexecdir}/libinput/libinput-analyze-touch-down-state
168%attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-events
169%attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-tablet
170%attr(755,root,root) %{_libexecdir}/libinput/libinput-list-devices
171%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure
172%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-fuzz
173%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-pressure
174%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-size
175%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-tap
176%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touch-size
177%attr(755,root,root) %{_libexecdir}/libinput/libinput-quirks
178%attr(755,root,root) %{_libexecdir}/libinput/libinput-record
179%attr(755,root,root) %{_libexecdir}/libinput/libinput-replay
180%attr(755,root,root) /lib/udev/libinput-device-group
181%attr(755,root,root) /lib/udev/libinput-fuzz-extract
182%attr(755,root,root) /lib/udev/libinput-fuzz-to-zero
183/lib/udev/rules.d/80-libinput-device-groups.rules
184/lib/udev/rules.d/90-libinput-fuzz-override.rules
185%dir %{_datadir}/libinput
186%{_datadir}/libinput/*.quirks
187%{_mandir}/man1/libinput.1*
188%{_mandir}/man1/libinput-analyze.1*
189%{_mandir}/man1/libinput-analyze-per-slot-delta.1*
190%{_mandir}/man1/libinput-analyze-recording.1*
191%{_mandir}/man1/libinput-analyze-touch-down-state.1*
192%{_mandir}/man1/libinput-debug-events.1*
193%{_mandir}/man1/libinput-debug-tablet.1*
194%{_mandir}/man1/libinput-list-devices.1*
195%{_mandir}/man1/libinput-measure.1*
196%{_mandir}/man1/libinput-measure-fuzz.1*
197%{_mandir}/man1/libinput-measure-touchpad-pressure.1*
198%{_mandir}/man1/libinput-measure-touchpad-size.1*
199%{_mandir}/man1/libinput-measure-touchpad-tap.1*
200%{_mandir}/man1/libinput-measure-touch-size.1*
201%{_mandir}/man1/libinput-quirks.1*
202%{_mandir}/man1/libinput-quirks-list.1*
203%{_mandir}/man1/libinput-quirks-validate.1*
204%{_mandir}/man1/libinput-record.1*
205%{_mandir}/man1/libinput-replay.1*
206
207%if %{with gui}
208%files gui
209%defattr(644,root,root,755)
210%attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-gui
211%{_mandir}/man1/libinput-debug-gui.1*
212%endif
213
214%files devel
215%defattr(644,root,root,755)
216%attr(755,root,root) %{_libdir}/libinput.so
217%{_includedir}/libinput.h
218%{_pkgconfigdir}/libinput.pc
219
220%if %{with doc}
221%files apidocs
222%defattr(644,root,root,755)
223%doc build/api/*
224%endif
225
226%files -n zsh-completion-%{name}
227%defattr(644,root,root,755)
228%{zsh_compdir}/_libinput
This page took 0.023463 seconds and 4 git commands to generate.