]> git.pld-linux.org Git - packages/libinput.git/blame - libinput.spec
up to 1.13.4
[packages/libinput.git] / libinput.spec
CommitLineData
578a3803
JP
1# TODO:
2# - package user docs from build/Documentation
11e9e5bb
JB
3#
4# Conditional build:
ef04d99c 5%bcond_without gui # libinput-debug-gui
f6d0d702 6%bcond_without libunwind # libunwind debugging support
a370658f 7%bcond_without doc # documentation
d254b872 8%bcond_without tests # tests
13fc90c9 9
f6d0d702
JB
10%ifnarch %{ix86} %{x8664} %{arm} hppa ia64 mips ppc ppc64 sh
11%undefine with_libunwind
12%endif
b1a834ff 13Summary: Input device library
66c98b1b 14Summary(pl.UTF-8): Biblioteka urządzeń wejściowych
b1a834ff 15Name: libinput
899ec8d8 16Version: 1.13.4
a2359d3f 17Release: 1
b1a834ff 18License: MIT
66c98b1b 19Group: Libraries
c29a2c14 20Source0: https://www.freedesktop.org/software/libinput/%{name}-%{version}.tar.xz
899ec8d8 21# Source0-md5: 9ef817774bb5b4006cba95e34103e82c
c29a2c14 22URL: https://www.freedesktop.org/wiki/Software/libinput/
332a61be 23BuildRequires: check-devel >= 0.9.10
6258de66
JB
24BuildRequires: libevdev-devel >= 1.3
25%{?with_libunwind:BuildRequires: libunwind-devel}
26BuildRequires: libwacom-devel >= 0.20
27BuildRequires: meson >= 0.41.0
28BuildRequires: mtdev-devel >= 1.1.0
29BuildRequires: ninja >= 1.5
30BuildRequires: pkgconfig
31BuildRequires: rpmbuild(macros) >= 1.728
32BuildRequires: udev-devel
33BuildRequires: valgrind
a370658f
MK
34%if %{with gui}
35BuildRequires: cairo-devel
36BuildRequires: glib2-devel >= 2.0
407ae804 37BuildRequires: gtk+3-devel >= 3.20
a370658f 38%endif
aed38082 39%if %{with doc}
407ae804 40BuildRequires: doxygen >= 1.8.3
bb392f52 41BuildRequires: graphviz >= 2.26.0
578a3803
JP
42BuildRequires: python3-recommonmark
43BuildRequires: python3-sphinx_rtd_theme
44BuildRequires: sphinx-pdg-3
a370658f 45%endif
ef04d99c 46Requires: libevdev >= 1.3
725df436
JB
47Requires: libwacom >= 0.20
48Requires: mtdev >= 1.1.0
66c98b1b 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
b1a834ff
AM
50
51%description
52libinput is a library that handles input devices for display servers
53and other applications that need to directly deal with input devices.
54
55It provides device detection, device handling, input device event
56processing and abstraction so minimize the amount of custom input code
57the user of libinput need to provide the common set of functionality
58that users expect.
59
66c98b1b
JB
60%description -l pl.UTF-8
61libinput to biblioteka obsługująca urządzenia wejściowe dla serwerów
62grafiki i innych aplikacji wymagających bezpośredniej obsługi urządzeń
63wejściowych.
64
65Biblioteka zapewnia wykrywanie urządzeń, obsługę urządzeń,
66przetwarzanie zdarzeń urządzeń wejściowych oraz abstrakcję,
67minimalizując ilość własnego kodu, który musi napisać użytkownik
68biblioteki, aby zapewnić oczekiwaną funkcjonalność.
69
ef04d99c
JB
70%package gui
71Summary: Debugging GUI for libinput
72Summary(pl.UTF-8): Graficzny interfejs diagnostyczny do libinput
73Group: X11/Applications
74Requires: %{name} = %{version}-%{release}
407ae804 75Requires: gtk+3 >= 3.20
ef04d99c
JB
76
77%description gui
78Debugging GUI for libinput.
79
80%description gui -l pl.UTF-8
81Graficzny interfejs diagnostyczny do libinput.
82
66c98b1b
JB
83%package devel
84Summary: Development files for libinput
85Summary(pl.UTF-8): Pliki programistyczne biblioteki libinput
86Group: Development/Libraries
b1a834ff 87Requires: %{name} = %{version}-%{release}
66c98b1b
JB
88Requires: udev-devel
89
90%description devel
91This package contains the header files for developing applications
92that use libinput.
93
94%description devel -l pl.UTF-8
95Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji
96wykorzystujących bibliotekę libinput.
97
98%package static
99Summary: Static libinput library
100Summary(pl.UTF-8): Statyczna biblioteka libinput
101Group: Development/Libraries
102Requires: %{name}-devel = %{version}-%{release}
103
104%description static
105Static libinput library.
b1a834ff 106
66c98b1b
JB
107%description static -l pl.UTF-8
108Statyczna biblioteka libinput.
109
110%package apidocs
111Summary: API documentation for libinput library
112Summary(pl.UTF-8): Dokumentacja API biblioteki libinput
113Group: Documentation
13fc90c9
ER
114%if "%{_rpmversion}" >= "5"
115BuildArch: noarch
116%endif
66c98b1b
JB
117
118%description apidocs
119API documentation for libinput library.
120
121%description apidocs -l pl.UTF-8
122Dokumentacja API biblioteki libinput.
b1a834ff
AM
123
124%prep
125%setup -q
126
6258de66
JB
127%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
128 tools/libinput-measure-{fuzz,touchpad-pressure,touch-size,touchpad-tap}.py \
129 tools/libinput-replay
bc749beb 130
b1a834ff 131%build
11306b0c 132%meson build \
2de91326
AM
133 -Ddebug-gui=%{__true_false gui} \
134 -Ddocumentation=%{__true_false doc} \
11306b0c 135 -Dudev-dir=/lib/udev
d254b872 136%meson_build -C build
b1a834ff 137
d254b872 138%{?with_tests:%meson_test -C build}
b1a834ff
AM
139
140%install
141rm -rf $RPM_BUILD_ROOT
142
d254b872 143%meson_install -C build
66c98b1b 144
a3a0a290
JB
145%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/libinput-test-suite.1
146
b1a834ff
AM
147%clean
148rm -rf $RPM_BUILD_ROOT
149
66c98b1b
JB
150%post -p /sbin/ldconfig
151%postun -p /sbin/ldconfig
b1a834ff
AM
152
153%files
154%defattr(644,root,root,755)
ef04d99c
JB
155%doc COPYING README.md
156%attr(755,root,root) %{_bindir}/libinput
66c98b1b 157%attr(755,root,root) %{_libdir}/libinput.so.*.*.*
3bf5286f 158%attr(755,root,root) %ghost %{_libdir}/libinput.so.10
ef04d99c
JB
159%dir %{_libexecdir}/libinput
160%attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-events
161%attr(755,root,root) %{_libexecdir}/libinput/libinput-list-devices
162%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure
9a19d5af 163%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-fuzz
d254b872 164%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-pressure
ef04d99c 165%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touchpad-tap
d254b872 166%attr(755,root,root) %{_libexecdir}/libinput/libinput-measure-touch-size
578a3803 167%attr(755,root,root) %{_libexecdir}/libinput/libinput-quirks
9a19d5af
JP
168%attr(755,root,root) %{_libexecdir}/libinput/libinput-record
169%attr(755,root,root) %{_libexecdir}/libinput/libinput-replay
76cc7e64 170%attr(755,root,root) /lib/udev/libinput-device-group
33de6229 171%attr(755,root,root) /lib/udev/libinput-model-quirks
76cc7e64 172/lib/udev/rules.d/80-libinput-device-groups.rules
cf0d28df 173/lib/udev/rules.d/90-libinput-model-quirks.rules
578a3803
JP
174%dir %{_datadir}/libinput
175%{_datadir}/libinput/*.quirks
ef04d99c 176%{_mandir}/man1/libinput.1*
cf0d28df 177%{_mandir}/man1/libinput-debug-events.1*
1573a790 178%{_mandir}/man1/libinput-list-devices.1*
ef04d99c 179%{_mandir}/man1/libinput-measure.1*
9a19d5af 180%{_mandir}/man1/libinput-measure-fuzz.1*
d254b872 181%{_mandir}/man1/libinput-measure-touchpad-pressure.1*
ef04d99c 182%{_mandir}/man1/libinput-measure-touchpad-tap.1*
d254b872 183%{_mandir}/man1/libinput-measure-touch-size.1*
578a3803
JP
184%{_mandir}/man1/libinput-quirks.1*
185%{_mandir}/man1/libinput-quirks-list.1*
186%{_mandir}/man1/libinput-quirks-validate.1*
9a19d5af
JP
187%{_mandir}/man1/libinput-record.1*
188%{_mandir}/man1/libinput-replay.1*
ef04d99c
JB
189
190%if %{with gui}
191%files gui
192%defattr(644,root,root,755)
193%attr(755,root,root) %{_libexecdir}/libinput/libinput-debug-gui
194%{_mandir}/man1/libinput-debug-gui.1*
195%endif
b1a834ff
AM
196
197%files devel
198%defattr(644,root,root,755)
b1a834ff 199%attr(755,root,root) %{_libdir}/libinput.so
66c98b1b 200%{_includedir}/libinput.h
b1a834ff 201%{_pkgconfigdir}/libinput.pc
66c98b1b 202
aed38082 203%if %{with doc}
66c98b1b
JB
204%files apidocs
205%defattr(644,root,root,755)
578a3803 206%doc build/api/*
aed38082 207%endif
This page took 0.056672 seconds and 4 git commands to generate.