]> git.pld-linux.org Git - packages/libhubbub.git/commitdiff
pass our CC, cleanup bad copy paste
authorElan Ruusamäe <glen@delfi.ee>
Sat, 27 Apr 2013 14:01:24 +0000 (17:01 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 27 Apr 2013 14:01:24 +0000 (17:01 +0300)
libhubbub.spec

index c2f9abd6dffd5ae9d6d29f7cb8bc1f9509946c63..0554aa454688b56894f8c828327048913e9ca050 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Conditional build:
 %bcond_without static_libs     # don't build static library
-#
+
 Summary:       HTML5 compliant parsing library
 Name:          libhubbub
 Version:       0.2.0
@@ -29,7 +29,6 @@ If you are looking for an HTML5 parser in Python or Ruby, you may wish
 to look at html5lib.
 
 Features:
-
 - Parses HTML, good and bad
 - Simple C API
 - Fast
@@ -68,33 +67,32 @@ Statyczna biblioteka libhubbub.
 %setup -q
 
 %build
-CFLAGS="%{rpmcflags}"
-LDFLAGS="%{rpmldflags}"
-export CFLAGS
-export LDFLAGS
+export CC="%{__cc}"
+export CFLAGS="%{rpmcflags}"
+export LDFLAGS="%{rpmldflags}"
+
+%{__make} Q= \
+       PREFIX=%{_prefix} \
+       COMPONENT_TYPE=lib-shared
 
-%{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
-       -Iinclude -Isrc"
 %if %{with static_libs}
-%{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
-       -Iinclude -Isrc"
+%{__make} Q= \
+       PREFIX=%{_prefix} \
+       COMPONENT_TYPE=lib-static
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
+%{__make} install Q= \
        PREFIX=%{_prefix} \
        COMPONENT_TYPE=lib-shared \
-       Q=''
+       DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with static_libs}
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
+%{__make} install Q= \
        PREFIX=%{_prefix} \
        COMPONENT_TYPE=lib-static \
-       Q=''
+       DESTDIR=$RPM_BUILD_ROOT
 %endif
 
 %clean
This page took 0.170235 seconds and 4 git commands to generate.