]> git.pld-linux.org Git - packages/libhubbub.git/blame - libhubbub.spec
- updated to 0.3.4
[packages/libhubbub.git] / libhubbub.spec
CommitLineData
9cb06394 1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
da5c947e 4
9cb06394 5Summary: HTML5 compliant parsing library
a0409436 6Summary(pl.UTF-8): Biblioteka analizująca HTML5
9cb06394 7Name: libhubbub
14769dbe 8Version: 0.3.4
05c129a0 9Release: 1
9cb06394 10License: MIT
11Group: Libraries
12Source0: http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
14769dbe 13# Source0-md5: 89e72cf7baa5ff86c0cc78731f29aaa7
9cb06394 14URL: http://www.netsurf-browser.org/projects/libhubbub/
db4167e8 15BuildRequires: libparserutils-devel >= 0.2.3
14769dbe 16BuildRequires: netsurf-buildsystem >= 1.6
db4167e8 17Requires: libparserutils >= 0.2.3
9cb06394 18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Hubbub is an HTML5 compliant parsing library, written in C. It was
22developed as part of the NetSurf project and is available for use by
23other software under the MIT licence.
24
25The HTML5 specification defines a parsing algorithm, based on the
26behaviour of mainstream browsers, which provides instructions for how
27to parse all markup, both valid and invalid. As a result, Hubbub
28parses web content well.
29
30If you are looking for an HTML5 parser in Python or Ruby, you may wish
31to look at html5lib.
32
33Features:
9cb06394 34- Parses HTML, good and bad
35- Simple C API
36- Fast
37- Character encoding detection
38- Well-tested (~90% test coverage)
39- Portable
40- Shared library
41
a0409436
JB
42%description -l pl.UTF-8
43Hubbub to napisana w C biblioteka analizująca HTML5. Powstała jako
44część projektu NetSurf i można jej używać w innych programach na
45licencji MIT.
46
47Specyfikacja HTML definiuje algorytm analizy w oparciu o zachowanie
48głównych przeglądarek, które dostarczają instrukcje, jak analizować
49znaczniki, zarówno poprawne, jak i niepoprawne. W efekcie Hubbub
50dobrze analizuje treści WWW.
51
52W razie potrzeby analizowania HTML5 w języku Python lub Ruby, można
53rozważyć użycie html5lib.
54
55Cechy biblioteki:
56- analizuje HTML, dobry i wadliwy
57- proste API dla języka C
58- szybka
59- wykrywanie kodowania znaków
60- dobrze przetestowana (~90% pokrycia testami)
61- przenośna
62- współdzielona
63
9cb06394 64%package devel
65Summary: libhubbub library headers
66Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libhubbub
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
6f214426 69Requires: libparserutils-devel >= 0.2.1
9cb06394 70
71%description devel
a0409436
JB
72This package contains the include files and other resources you can
73use to incorporate libhubbub into applications.
9cb06394 74
75%description devel -l pl.UTF-8
76Pliki nagłówkowe pozwalające na używanie biblioteki libhubbub w swoich
77programach.
78
79%package static
a0409436
JB
80Summary: libhubbub static library
81Summary(pl.UTF-8): Statyczna biblioteka libhubbub
9cb06394 82Group: Development/Libraries
83Requires: %{name}-devel = %{version}-%{release}
84
85%description static
a0409436 86This is package with static libhubbub library.
9cb06394 87
88%description static -l pl.UTF-8
89Statyczna biblioteka libhubbub.
90
91%prep
92%setup -q
93
94%build
db4167e8 95export AR="%{__ar}"
da5c947e 96export CC="%{__cc}"
c5c8b2dc 97export CFLAGS="%{rpmcflags} %{rpmcppflags}"
da5c947e
ER
98export LDFLAGS="%{rpmldflags}"
99
a0409436
JB
100%{__make} \
101 Q= \
da5c947e 102 PREFIX=%{_prefix} \
a0409436 103 LIBDIR=%{_lib} \
da5c947e 104 COMPONENT_TYPE=lib-shared
9cb06394 105
9cb06394 106%if %{with static_libs}
a0409436
JB
107%{__make} \
108 Q= \
da5c947e 109 PREFIX=%{_prefix} \
a0409436 110 LIBDIR=%{_lib} \
da5c947e 111 COMPONENT_TYPE=lib-static
9cb06394 112%endif
113
114%install
e4bd4314
JB
115rm -rf $RPM_BUILD_ROOT
116
db4167e8
WF
117export AR="%{__ar}"
118export CC="%{__cc}"
119export CFLAGS="%{rpmcflags} %{rpmcppflags}"
120export LDFLAGS="%{rpmldflags}"
121
a0409436
JB
122%{__make} install \
123 Q= \
9cb06394 124 PREFIX=%{_prefix} \
a0409436 125 LIBDIR=%{_lib} \
9cb06394 126 COMPONENT_TYPE=lib-shared \
da5c947e 127 DESTDIR=$RPM_BUILD_ROOT
9cb06394 128
129%if %{with static_libs}
a0409436
JB
130%{__make} install \
131 Q= \
9cb06394 132 PREFIX=%{_prefix} \
a0409436 133 LIBDIR=%{_lib} \
9cb06394 134 COMPONENT_TYPE=lib-static \
da5c947e 135 DESTDIR=$RPM_BUILD_ROOT
9cb06394 136%endif
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
143
144%files
145%defattr(644,root,root,755)
a0409436 146%doc COPYING README
6204307b 147%attr(755,root,root) %{_libdir}/libhubbub.so.*.*.*
a0409436 148%attr(755,root,root) %ghost %{_libdir}/libhubbub.so.0
9cb06394 149
150%files devel
151%defattr(644,root,root,755)
a0409436 152%attr(755,root,root) %{_libdir}/libhubbub.so
9cb06394 153%{_includedir}/hubbub
6204307b 154%{_pkgconfigdir}/libhubbub.pc
9cb06394 155
156%if %{with static_libs}
157%files static
158%defattr(644,root,root,755)
6204307b 159%{_libdir}/libhubbub.a
9cb06394 160%endif
This page took 0.158404 seconds and 4 git commands to generate.