]> git.pld-linux.org Git - packages/libgweather.git/blobdiff - libgweather.spec
- updated to 3.20.1
[packages/libgweather.git] / libgweather.spec
index 6c3e19e000e22cd5a197f11bdb98670d39735632..77bb97d67d991c06fb9c69a6b027db7390606948 100644 (file)
@@ -1,25 +1,43 @@
+#
+# Conditional build:
+%bcond_without glade   # Glade catalog
+%bcond_without vala    # do not build Vala API
+
 Summary:       Library to access weather information from online services for numerous locations
 Summary(pl.UTF-8):     Biblioteka dostępu do informacji pogodowych z serwisów internetowych dla różnych miejsc
 Name:          libgweather
-Version:       2.22.1.2
+Version:       3.20.1
 Release:       1
 License:       GPL v2+
 Group:         X11/Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/libgweather/2.22/%{name}-%{version}.tar.bz2
-# Source0-md5: 6283f775434066e0183ee0c6cb789ac5
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/libgweather/3.20/%{name}-%{version}.tar.xz
+# Source0-md5: 1a5562f956cb5eb86dad4eb9be7c90f3
 URL:           http://www.gnome.org/
-BuildRequires: GConf2-devel >= 2.22.0
-BuildRequires: autoconf >= 2.59
-BuildRequires: automake >= 1:1.9
-BuildRequires: gettext-devel
+BuildRequires: autoconf >= 2.64
+BuildRequires: automake >= 1:1.11
+BuildRequires: geocode-glib-devel
+BuildRequires: gettext-tools >= 0.18
+%{?with_glade:BuildRequires:   glade-devel >= 2.0}
+BuildRequires: glib2-devel >= 1:2.35.1
 BuildRequires: gnome-common >= 2.20.0
-BuildRequires: gnome-vfs2-devel >= 2.22.0
-BuildRequires: gtk+2-devel >= 2:2.12.8
-BuildRequires: intltool >= 0.37.0
-BuildRequires: libtool
+BuildRequires: gobject-introspection-devel >= 0.10.0
+BuildRequires: gtk+3-devel >= 3.14.0
+BuildRequires: gtk-doc >= 1.11
+BuildRequires: intltool >= 0.50.0
+BuildRequires: libsoup-devel >= 2.44.0
+BuildRequires: libtool >= 2:2.2.6
+BuildRequires: libxml2-devel >= 1:2.6.30
 BuildRequires: pkgconfig >= 1:0.19
-BuildRequires: sed >= 4.0
-Requires(post,preun):  GConf2
+BuildRequires: rpmbuild(macros) >= 1.592
+BuildRequires: tar >= 1:1.22
+%{?with_vala:BuildRequires:    vala >= 2:0.18.0}
+BuildRequires: xz
+Requires(post,postun): /sbin/ldconfig
+Requires(post,postun): glib2 >= 1:2.35.1
+Requires:      glib2 >= 1:2.35.1
+Requires:      gtk+3 >= 3.14.0
+Requires:      libsoup >= 2.44.0
+Requires:      libxml2 >= 1:2.6.30
 # sr@Latn vs. sr@latin
 Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -37,8 +55,9 @@ Summary:      Header files for libgweather
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libgweather
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      gnome-vfs2-devel >= 2.22.0
-Requires:      gtk+2-devel >= 2:2.12.8
+Requires:      gtk+3-devel >= 3.14.0
+Requires:      libsoup-devel >= 2.44.0
+Requires:      libxml2-devel >= 1:2.6.30
 Obsoletes:     gnome-applets-devel <= 2.21.4
 
 %description devel
@@ -59,22 +78,72 @@ Static libgweather library.
 %description static -l pl.UTF-8
 Statyczna biblioteka libgweather.
 
+%package apidocs
+Summary:       libgweather API documentation
+Summary(pl.UTF-8):     Dokumentacja API biblioteki libgweather
+Group:         Documentation
+Requires:      gtk-doc-common
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description apidocs
+libgweather API documentation.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki libgweather.
+
+%package glade
+Summary:       libgweather catalog file for Glade
+Summary(pl.UTF-8):     Plik katalogu libgweather dla Glade
+Group:         X11/Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      glade >= 2.0
+
+%description glade
+libgweather catalog file for Glade.
+
+%description glade -l pl.UTF-8
+Plik katalogu libgweather dla Glade.
+
+%package -n vala-libgweather
+Summary:       libgweather API for Vala language
+Summary(pl.UTF-8):     API biblioteki libgweather dla języka Vala
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      vala >= 2:0.18.0
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description -n vala-libgweather
+libgweather API for Vala language.
+
+%description -n vala-libgweather -l pl.UTF-8
+API biblioteki libgweather dla języka Vala.
+
 %prep
 %setup -q
 
-sed -i -e 's#sr@Latn#sr@latin#' po/LINGUAS
-mv po/sr@{Latn,latin}.po
-mv po-locations/sr@{Latn,latin}.po
-
 %build
+%{__gtkdocize}
 %{__intltoolize}
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
-%{__make} -j1
+%configure \
+       %{!?with_glade:--disable-glade-catalog} \
+       --enable-gtk-doc \
+       --disable-silent-rules \
+       --enable-static \
+       %{__enable_disable vala} \
+       --with-html-dir=%{_gtkdocdir} \
+       --with-zoneinfo-dir=%{_datadir}/zoneinfo
+
+%{__make} -j1 -C data
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -82,37 +151,57 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/es_ES
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/es_ES
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
 
-%find_lang libgweather
+%find_lang libgweather-3.0 --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/ldconfig
-%gconf_schema_install gweather.schemas
+%glib_compile_schemas
 
-%preun
-%gconf_schema_uninstall gweather.schemas
-
-%postun        -p /sbin/ldconfig
+%postun
+/sbin/ldconfig
+%glib_compile_schemas
 
-%files -f libgweather.lang
+%files -f libgweather-3.0.lang
 %defattr(644,root,root,755)
-%doc ChangeLog README
-%attr(755,root,root) %{_libdir}/libgweather.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgweather.so.1
-%{_sysconfdir}/gconf/schemas/gweather.schemas
-%{_datadir}/libgweather
+%doc AUTHORS HACKING NEWS README
+%attr(755,root,root) %{_libdir}/libgweather-3.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgweather-3.so.6
+%{_datadir}/glib-2.0/schemas/org.gnome.GWeather.enums.xml
+%{_datadir}/glib-2.0/schemas/org.gnome.GWeather.gschema.xml
+%dir %{_datadir}/libgweather
+%{_datadir}/libgweather/Locations.xml
+%{_datadir}/libgweather/locations.dtd
+%{_libdir}/girepository-1.0/GWeather-3.0.typelib
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgweather.so
-%{_libdir}/libgweather.la
-%{_includedir}/libgweather
-%{_pkgconfigdir}/gweather.pc
+%attr(755,root,root) %{_libdir}/libgweather-3.so
+%{_includedir}/libgweather-3.0
+%{_pkgconfigdir}/gweather-3.0.pc
+%{_datadir}/gir-1.0/GWeather-3.0.gir
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libgweather.a
+%{_libdir}/libgweather-3.a
+
+%files apidocs
+%defattr(644,root,root,755)
+%{_gtkdocdir}/libgweather-3.0
+
+%if %{with glade}
+%files glade
+%defattr(644,root,root,755)
+%{_datadir}/glade/catalogs/libgweather.xml
+%endif
+
+%if %{with vala}
+%files -n vala-libgweather
+%defattr(644,root,root,755)
+%{_datadir}/vala/vapi/gweather-3.0.vapi
+%endif
This page took 0.064318 seconds and 4 git commands to generate.