]> git.pld-linux.org Git - packages/libgweather.git/blob - libgweather.spec
- BR: macros for glib_compile_schemas, R: ldconfig
[packages/libgweather.git] / libgweather.spec
1 #
2 # Conditional build:
3 %bcond_without  glade   # Glade catalog
4 %bcond_without  vala    # do not build Vala API
5 #
6 Summary:        Library to access weather information from online services for numerous locations
7 Summary(pl.UTF-8):      Biblioteka dostępu do informacji pogodowych z serwisów internetowych dla różnych miejsc
8 Name:           libgweather
9 Version:        3.18.0
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgweather/3.18/%{name}-%{version}.tar.xz
14 # Source0-md5:  631c9a36be0314163d0b801c97736581
15 URL:            http://www.gnome.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  geocode-glib-devel
19 BuildRequires:  gettext-tools >= 0.18
20 %{?with_glade:BuildRequires:    glade-devel >= 2.0}
21 BuildRequires:  glib2-devel >= 1:2.35.1
22 BuildRequires:  gnome-common >= 2.20.0
23 BuildRequires:  gobject-introspection-devel >= 0.10.0
24 BuildRequires:  gtk+3-devel >= 3.14.0
25 BuildRequires:  gtk-doc >= 1.11
26 BuildRequires:  intltool >= 0.50.0
27 BuildRequires:  libsoup-devel >= 2.34.0
28 BuildRequires:  libtool >= 2:2.2.6
29 BuildRequires:  libxml2-devel >= 1:2.6.30
30 BuildRequires:  pkgconfig >= 1:0.19
31 BuildRequires:  rpmbuild(macros) >= 1.592
32 BuildRequires:  tar >= 1:1.22
33 %{?with_vala:BuildRequires:     vala >= 2:0.18.0}
34 BuildRequires:  xz
35 Requires(post,postun):  /sbin/ldconfig
36 Requires(post,postun):  glib2 >= 1:2.35.1
37 Requires:       glib2 >= 1:2.35.1
38 Requires:       gtk+3 >= 3.14.0
39 Requires:       libsoup >= 2.34.0
40 Requires:       libxml2 >= 1:2.6.30
41 # sr@Latn vs. sr@latin
42 Conflicts:      glibc-misc < 6:2.7
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 libgweather is a library to access weather information from online
47 services for numerous locations.
48
49 %description -l pl.UTF-8
50 libgweather to biblioteka pozwalająca na dostęp do informacji
51 pogodowych z serwisów internetowych dla różnych miejsc.
52
53 %package devel
54 Summary:        Header files for libgweather
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgweather
56 Group:          X11/Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       gtk+3-devel >= 3.14.0
59 Requires:       libsoup-devel >= 2.34.0
60 Requires:       libxml2-devel >= 1:2.6.30
61 Obsoletes:      gnome-applets-devel <= 2.21.4
62
63 %description devel
64 Header files for libgweather.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki libgweather.
68
69 %package static
70 Summary:        Static libgweather library
71 Summary(pl.UTF-8):      Statyczna biblioteka libgweather
72 Group:          X11/Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static libgweather library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka libgweather.
80
81 %package apidocs
82 Summary:        libgweather API documentation
83 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgweather
84 Group:          Documentation
85 Requires:       gtk-doc-common
86
87 %description apidocs
88 libgweather API documentation.
89
90 %description apidocs -l pl.UTF-8
91 Dokumentacja API biblioteki libgweather.
92
93 %package glade
94 Summary:        libgweather catalog file for Glade
95 Summary(pl.UTF-8):      Plik katalogu libgweather dla Glade
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Requires:       glade >= 2.0
99
100 %description glade
101 libgweather catalog file for Glade.
102
103 %description glade -l pl.UTF-8
104 Plik katalogu libgweather dla Glade.
105
106 %package -n vala-libgweather
107 Summary:        libgweather API for Vala language
108 Summary(pl.UTF-8):      API biblioteki libgweather dla języka Vala
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111 Requires:       vala >= 2:0.18.0
112
113 %description -n vala-libgweather
114 libgweather API for Vala language.
115
116 %description -n vala-libgweather -l pl.UTF-8
117 API biblioteki libgweather dla języka Vala.
118
119 %prep
120 %setup -q
121
122 %build
123 %{__gtkdocize}
124 %{__intltoolize}
125 %{__libtoolize}
126 %{__aclocal} -I m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         %{!?with_glade:--disable-glade-catalog} \
132         --enable-gtk-doc \
133         --disable-silent-rules \
134         --enable-static \
135         %{__enable_disable vala} \
136         --with-html-dir=%{_gtkdocdir} \
137         --with-zoneinfo-dir=%{_datadir}/zoneinfo
138
139 %{__make} -j1 -C data
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/es_ES
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
150
151 %find_lang libgweather-3.0 --all-name
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post
157 /sbin/ldconfig
158 %glib_compile_schemas
159
160 %postun
161 /sbin/ldconfig
162 %glib_compile_schemas
163
164 %files -f libgweather-3.0.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS HACKING NEWS README
167 %attr(755,root,root) %{_libdir}/libgweather-3.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libgweather-3.so.6
169 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.enums.xml
170 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.gschema.xml
171 %dir %{_datadir}/libgweather
172 %{_datadir}/libgweather/Locations.xml
173 %{_datadir}/libgweather/locations.dtd
174 %{_libdir}/girepository-1.0/GWeather-3.0.typelib
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libgweather-3.so
179 %{_includedir}/libgweather-3.0
180 %{_pkgconfigdir}/gweather-3.0.pc
181 %{_datadir}/gir-1.0/GWeather-3.0.gir
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/libgweather-3.a
186
187 %files apidocs
188 %defattr(644,root,root,755)
189 %{_gtkdocdir}/libgweather-3.0
190
191 %if %{with glade}
192 %files glade
193 %defattr(644,root,root,755)
194 %{_datadir}/glade/catalogs/libgweather.xml
195 %endif
196
197 %if %{with vala}
198 %files -n vala-libgweather
199 %defattr(644,root,root,755)
200 %{_datadir}/vala/vapi/gweather-3.0.vapi
201 %endif
This page took 0.037948 seconds and 4 git commands to generate.