]> git.pld-linux.org Git - packages/libgweather.git/blob - libgweather.spec
- updated to 3.14.1
[packages/libgweather.git] / libgweather.spec
1 #
2 # Conditional build:
3 %bcond_without  vala            # do not build Vala API
4 #
5 Summary:        Library to access weather information from online services for numerous locations
6 Summary(pl.UTF-8):      Biblioteka dostępu do informacji pogodowych z serwisów internetowych dla różnych miejsc
7 Name:           libgweather
8 Version:        3.14.1
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgweather/3.14/%{name}-%{version}.tar.xz
13 # Source0-md5:  15341d049e5b503ae91795f046b00e95
14 URL:            http://www.gnome.org/
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  gettext-devel >= 0.18
18 BuildRequires:  geocode-glib-devel
19 BuildRequires:  glib2-devel >= 1:2.35.1
20 BuildRequires:  gnome-common >= 2.20.0
21 BuildRequires:  gobject-introspection-devel >= 0.10.0
22 BuildRequires:  gtk+3-devel >= 3.14.0
23 BuildRequires:  gtk-doc >= 1.11
24 BuildRequires:  intltool >= 0.50.0
25 BuildRequires:  libsoup-devel >= 2.34.0
26 BuildRequires:  libtool >= 2:2.2.6
27 BuildRequires:  libxml2-devel >= 1:2.6.30
28 BuildRequires:  pkgconfig >= 1:0.19
29 BuildRequires:  tar >= 1:1.22
30 %{?with_vala:BuildRequires:     vala >= 2:0.18.0}
31 BuildRequires:  xz
32 Requires(post,postun):  glib2 >= 1:2.35.1
33 Requires:       glib2 >= 1:2.35.1
34 Requires:       gtk+3 >= 3.14.0
35 Requires:       libsoup >= 2.34.0
36 Requires:       libxml2 >= 1:2.6.30
37 # sr@Latn vs. sr@latin
38 Conflicts:      glibc-misc < 6:2.7
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 libgweather is a library to access weather information from online
43 services for numerous locations.
44
45 %description -l pl.UTF-8
46 libgweather to biblioteka pozwalająca na dostęp do informacji
47 pogodowych z serwisów internetowych dla różnych miejsc.
48
49 %package devel
50 Summary:        Header files for libgweather
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgweather
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       gtk+3-devel >= 3.14.0
55 Requires:       libsoup-devel >= 2.34.0
56 Requires:       libxml2-devel >= 1:2.6.30
57 Obsoletes:      gnome-applets-devel <= 2.21.4
58
59 %description devel
60 Header files for libgweather.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki libgweather.
64
65 %package static
66 Summary:        Static libgweather library
67 Summary(pl.UTF-8):      Statyczna biblioteka libgweather
68 Group:          X11/Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static libgweather library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka libgweather.
76
77 %package apidocs
78 Summary:        libgweather API documentation
79 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgweather
80 Group:          Documentation
81 Requires:       gtk-doc-common
82
83 %description apidocs
84 libgweather API documentation.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API biblioteki libgweather.
88
89 %package -n vala-libgweather
90 Summary:        libgweather API for Vala language
91 Summary(pl.UTF-8):      API biblioteki libgweather dla języka Vala
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94 Requires:       vala >= 2:0.18.0
95
96 %description -n vala-libgweather
97 libgweather API for Vala language.
98
99 %description -n vala-libgweather -l pl.UTF-8
100 API biblioteki libgweather dla języka Vala.
101
102 %prep
103 %setup -q
104
105 %build
106 %{__gtkdocize}
107 %{__intltoolize}
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         %{__enable_disable vala vala} \
115         --with-zoneinfo-dir=%{_datadir}/zoneinfo \
116         --enable-gtk-doc \
117         --with-html-dir=%{_gtkdocdir} \
118         --disable-silent-rules \
119         --enable-static
120
121 %{__make} -j1 -C data
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/es_ES
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
132
133 %find_lang libgweather-3.0 --all-name
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 /sbin/ldconfig
140 %glib_compile_schemas
141
142 %postun
143 /sbin/ldconfig
144 %glib_compile_schemas
145
146 %files -f libgweather-3.0.lang
147 %defattr(644,root,root,755)
148 %doc AUTHORS HACKING NEWS README
149 %attr(755,root,root) %{_libdir}/libgweather-3.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libgweather-3.so.6
151 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.enums.xml
152 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.gschema.xml
153 %dir %{_datadir}/libgweather
154 %{_datadir}/libgweather/Locations.xml
155 %{_datadir}/libgweather/locations.dtd
156 %{_libdir}/girepository-1.0/GWeather-3.0.typelib
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libgweather-3.so
161 %{_includedir}/libgweather-3.0
162 %{_pkgconfigdir}/gweather-3.0.pc
163 %{_datadir}/gir-1.0/GWeather-3.0.gir
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libgweather-3.a
168
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/libgweather-3.0
172
173 %if %{with vala}
174 %files -n vala-libgweather
175 %defattr(644,root,root,755)
176 %{_datadir}/vala/vapi/gweather-3.0.vapi
177 %endif
This page took 0.16347 seconds and 4 git commands to generate.