]> git.pld-linux.org Git - packages/libgweather.git/blob - libgweather.spec
Update to 3.28.2
[packages/libgweather.git] / libgweather.spec
1 #
2 # Conditional build:
3 %bcond_without  glade   # Glade catalog
4 %bcond_without  vala    # do not build Vala API
5
6 Summary:        Library to access weather information from online services for numerous locations
7 Summary(pl.UTF-8):      Biblioteka dostępu do informacji pogodowych z serwisów internetowych dla różnych miejsc
8 Name:           libgweather
9 Version:        3.28.2
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgweather/3.28/%{name}-%{version}.tar.xz
14 # Source0-md5:  4f8771fedc83bd1c7594c5aa7f21dedb
15 URL:            http://www.gnome.org/
16 BuildRequires:  geocode-glib-devel
17 BuildRequires:  gettext-tools >= 0.18
18 %{?with_glade:BuildRequires:    glade-devel >= 2.0}
19 BuildRequires:  glib2-devel >= 1:2.35.1
20 BuildRequires:  gnome-common >= 2.20.0
21 BuildRequires:  gobject-introspection-devel >= 0.10.0
22 BuildRequires:  gtk+3-devel >= 3.14.0
23 BuildRequires:  gtk-doc >= 1.11
24 BuildRequires:  intltool >= 0.50.0
25 BuildRequires:  libsoup-devel >= 2.44.0
26 BuildRequires:  libxml2-devel >= 1:2.6.30
27 BuildRequires:  meson >= 0.43.0
28 BuildRequires:  pkgconfig >= 1:0.19
29 BuildRequires:  rpmbuild(macros) >= 1.592
30 BuildRequires:  tar >= 1:1.22
31 %{?with_vala:BuildRequires:     vala >= 2:0.18.0}
32 BuildRequires:  xz
33 Requires(post,postun):  /sbin/ldconfig
34 Requires(post,postun):  glib2 >= 1:2.35.1
35 Requires:       glib2 >= 1:2.35.1
36 Requires:       gtk+3 >= 3.14.0
37 Requires:       libsoup >= 2.44.0
38 Requires:       libxml2 >= 1:2.6.30
39 # sr@Latn vs. sr@latin
40 Conflicts:      glibc-misc < 6:2.7
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 libgweather is a library to access weather information from online
45 services for numerous locations.
46
47 %description -l pl.UTF-8
48 libgweather to biblioteka pozwalająca na dostęp do informacji
49 pogodowych z serwisów internetowych dla różnych miejsc.
50
51 %package devel
52 Summary:        Header files for libgweather
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgweather
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       gtk+3-devel >= 3.14.0
57 Requires:       libsoup-devel >= 2.44.0
58 Requires:       libxml2-devel >= 1:2.6.30
59 Obsoletes:      gnome-applets-devel <= 2.21.4
60 Obsoletes:      libgweather-static < 3.28.0
61
62 %description devel
63 Header files for libgweather.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki libgweather.
67
68 %package static
69 Summary:        Static libgweather library
70 Summary(pl.UTF-8):      Statyczna biblioteka libgweather
71 Group:          X11/Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static libgweather library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka libgweather.
79
80 %package apidocs
81 Summary:        libgweather API documentation
82 Summary(pl.UTF-8):      Dokumentacja API biblioteki libgweather
83 Group:          Documentation
84 Requires:       gtk-doc-common
85 %if "%{_rpmversion}" >= "5"
86 BuildArch:      noarch
87 %endif
88
89 %description apidocs
90 libgweather API documentation.
91
92 %description apidocs -l pl.UTF-8
93 Dokumentacja API biblioteki libgweather.
94
95 %package glade
96 Summary:        libgweather catalog file for Glade
97 Summary(pl.UTF-8):      Plik katalogu libgweather dla Glade
98 Group:          X11/Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100 Requires:       glade >= 2.0
101
102 %description glade
103 libgweather catalog file for Glade.
104
105 %description glade -l pl.UTF-8
106 Plik katalogu libgweather dla Glade.
107
108 %package -n vala-libgweather
109 Summary:        libgweather API for Vala language
110 Summary(pl.UTF-8):      API biblioteki libgweather dla języka Vala
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113 Requires:       vala >= 2:0.18.0
114 %if "%{_rpmversion}" >= "5"
115 BuildArch:      noarch
116 %endif
117
118 %description -n vala-libgweather
119 libgweather API for Vala language.
120
121 %description -n vala-libgweather -l pl.UTF-8
122 API biblioteki libgweather dla języka Vala.
123
124 %prep
125 %setup -q
126
127 %build
128 %meson build \
129         -Dglade_catalog=%{!?with_glade:false}%{?with_glade:true} \
130         -Dgtk_doc=true \
131         -Dzoneinfo_dir=%{_datadir}/zoneinfo \
132         -Denable_vala=%{!?with_vala:false}%{?with_vala:true}
133
134 %meson_build -C build
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %meson_install -C build
140
141 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/es_ES
142
143 %find_lang libgweather-3.0 --all-name
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 /sbin/ldconfig
150 %glib_compile_schemas
151
152 %postun
153 /sbin/ldconfig
154 %glib_compile_schemas
155
156 %files -f libgweather-3.0.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS HACKING NEWS README
159 %attr(755,root,root) %{_libdir}/libgweather-3.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libgweather-3.so.15
161 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.enums.xml
162 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.gschema.xml
163 %dir %{_datadir}/libgweather
164 %{_datadir}/libgweather/Locations.xml
165 %{_datadir}/libgweather/locations.dtd
166 %{_libdir}/girepository-1.0/GWeather-3.0.typelib
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libgweather-3.so
171 %{_includedir}/libgweather-3.0
172 %{_pkgconfigdir}/gweather-3.0.pc
173 %{_datadir}/gir-1.0/GWeather-3.0.gir
174
175 %files apidocs
176 %defattr(644,root,root,755)
177 %{_gtkdocdir}/libgweather
178
179 %if %{with glade}
180 %files glade
181 %defattr(644,root,root,755)
182 %{_datadir}/glade/catalogs/libgweather.xml
183 %endif
184
185 %if %{with vala}
186 %files -n vala-libgweather
187 %defattr(644,root,root,755)
188 %{_datadir}/vala/vapi/gweather-3.0.vapi
189 %{_datadir}/vala/vapi/gweather-3.0.deps
190 %endif
This page took 0.084722 seconds and 3 git commands to generate.