]> git.pld-linux.org Git - packages/libguestfs.git/blobdiff - libguestfs.spec
- started update to 1.40.2
[packages/libguestfs.git] / libguestfs.spec
index 0c183e1abef40258a244b2298b09d1eb834792a1..e3981ab66b27864eb7afe0ae8cea1ec97cc0681d 100644 (file)
 # TODO:
-# - finish haskell bindings (when finished upstream, not ready as of 1.20.2)
+# - finish haskell bindings (when finished upstream, not ready as of 1.30.4)
 # - PLD appliance support? (needs at least package list adjustment)
+# 
+# /etc/xdg/virt-builder/repos.d/opensuse.conf
+# /etc/xdg/virt-builder/repos.d/opensuse.gpg
+# %{_bindir}/virt-builder-repository
+# %{bash_compdir}/libguestfs-test-tool
+# %{_mandir}/ja/man1/guestfs-building.1*
+# %{_mandir}/ja/man1/virt-v2v-copy-to-local.1*
+# %{_mandir}/ja/man1/virt-v2v-input-vmware.1*
+# %{_mandir}/ja/man1/virt-v2v-input-xen.1*
+# %{_mandir}/ja/man1/virt-v2v-output-local.1*
+# %{_mandir}/ja/man1/virt-v2v-output-openstack.1*
+# %{_mandir}/ja/man1/virt-v2v-output-rhv.1*
+# %{_mandir}/ja/man1/virt-v2v-support.1*
+# %{_mandir}/ja/man3/guestfs-golang.3*
+# %{_mandir}/ja/man3/guestfs-java.3*
+# %{_mandir}/man1/guestfs-building.1*
+# %{_mandir}/man1/virt-builder-repository.1*
+# %{_mandir}/man1/virt-v2v-input-vmware.1*
+# %{_mandir}/man1/virt-v2v-input-xen.1*
+# %{_mandir}/man1/virt-v2v-output-local.1*
+# %{_mandir}/man1/virt-v2v-output-openstack.1*
+# %{_mandir}/man1/virt-v2v-output-rhv.1*
+# %{_mandir}/man1/virt-v2v-support.1*
+# %{_mandir}/man3/guestfs-gobject.3*
+# %{_mandir}/uk/man1/guestfs-building.1*
+# %{_mandir}/uk/man1/virt-v2v-copy-to-local.1*
+# %{_mandir}/uk/man1/virt-v2v-input-vmware.1*
+# %{_mandir}/uk/man1/virt-v2v-input-xen.1*
+# %{_mandir}/uk/man1/virt-v2v-output-local.1*
+# %{_mandir}/uk/man1/virt-v2v-output-openstack.1*
+# %{_mandir}/uk/man1/virt-v2v-output-rhv.1*
+# %{_mandir}/uk/man1/virt-v2v-support.1*
+# %{_mandir}/uk/man3/guestfs-golang.3*
+# %{_mandir}/uk/man3/guestfs-java.3*
 #
 # Conditional build:
 %bcond_with    static_libs     # build static libraries
 %bcond_with    appliance       # appliance build (no PLD support)
 %bcond_without erlang          # Erlang binding
-%bcond_without golang          # Go language binding
+%bcond_with    golang          # Go language binding
+%bcond_without gtk             # GTK+ based virt-p2v
 %bcond_with    haskell         # Haskell (GHC) binding [incomplete, nothing is installed]
-%bcond_without java            # Java binding
+%bcond_with    java            # Java binding (broken linking, missing symbols)
 %bcond_without lua             # Lua binding
 %bcond_without ocaml           # OCaml binding and tools
+%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
 %bcond_without perl            # Perl binding
 %bcond_without perltools       # Perl tools
-%bcond_without php             # PHP binding
+%bcond_with    php             # PHP binding
 %bcond_without python          # Python binding
 %bcond_without ruby            # Ruby binding
 %bcond_without systemtap       # systemtap/dtrace probes
 
-%include       /usr/lib/rpm/macros.perl
-%include       /usr/lib/rpm/macros.java
+%if 0%{!?php_name:1}
+%define                php_name        php55
+%endif
+
+%ifarch x32
+%undefine      with_erlang
+%undefine      with_golang
+%undefine      with_ocaml_opt
+%endif
+
 Summary:       Library and tools for accessing and modifying virtual machine disk images
 Summary(pl.UTF-8):     Biblioteka i narzędzia do dostępu i modyfikacji obrazów dysków maszyn wirtualnych
 Name:          libguestfs
-Version:       1.24.8
-Release:       1
+Version:       1.40.2
+Release:       0.1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://libguestfs.org/download/1.24-stable/%{name}-%{version}.tar.gz
-# Source0-md5: 4506538266bd19db721c71908790db35
+Source0:       http://libguestfs.org/download/1.40-stable/%{name}-%{version}.tar.gz
+# Source0-md5: 7cf90b71013c83f28fead844d3b343ea
 Patch0:                ncurses.patch
 Patch1:                augeas-libxml2.patch
 Patch2:                %{name}-link.patch
 Patch3:                %{name}-completionsdir.patch
+Patch4:                golang14nosrcpkg.patch
+Patch5:                ocaml-4.12.patch
 URL:           http://libguestfs.org/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
 BuildRequires: augeas-devel >= 1.0.0
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+BuildRequires: bison
 BuildRequires: cdrkit-mkisofs
 BuildRequires: db-utils
-# erl_interface package
-%{?with_erlang:BuildRequires:  erlang}
-%if %{with appliance}
-#BuildRequires:        febootstrap >= 3.20
-# or
-#BuildRequires:        supermin >= 4.1.0
-%endif
-BuildRequires: gettext-devel
-%{?with_haskell:BuildRequires: ghc}
+BuildRequires: flex
+BuildRequires: gettext-tools
 BuildRequires: glib2-devel >= 1:2.26.0
 BuildRequires: gobject-introspection-devel >= 1.30.0
-%{?with_golang:BuildRequires:  golang}
 BuildRequires: gperf
-BuildRequires: gtk-doc >= 1.14
+%{?with_gtk:BuildRequires:     gtk+2-devel >= 2.0}
 BuildRequires: hivex-devel >= 1.2.7
-%{?with_java:BuildRequires:    jdk}
 BuildRequires: libcap-devel
 BuildRequires: libconfig-devel
 BuildRequires: libfuse-devel
 BuildRequires: libmagic-devel
 BuildRequires: libselinux-devel
+BuildRequires: libtirpc-devel
 BuildRequires: libtool
 BuildRequires: libvirt-devel >= 0.10.2
 BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libxml2-progs
-%{?with_java:BuildRequires:    rpm-javaprov}
+BuildRequires: ncurses-devel
+BuildRequires: pcre-devel
+BuildRequires: perl-base
+BuildRequires: perl-tools-pod
+BuildRequires: pkgconfig
+BuildRequires: po4a
+BuildRequires: qemu-img >= 1.0
+BuildRequires: readline-devel
+BuildRequires: rpmbuild(macros) >= 1.656
+# libsystemd-journal
+BuildRequires: systemd-devel >= 1:196
+BuildRequires: yajl-devel >= 2.0.4
+%if %{with appliance}
+BuildRequires: supermin >= 5.1.0
+%endif
+%if %{with erlang}
+# erl_interface package
+BuildRequires: erlang
+%endif
+%if %{with golang}
+BuildRequires: golang
+%endif
+%if %{with haskell}
+BuildRequires: ghc
+%endif
+%if %{with java}
+BuildRequires: jdk
+BuildRequires: rpm-javaprov
+%endif
 %if %{with lua}
 # use 5.2 as 5.1 packaging in PLD was incompatible with what's expected by configure
 BuildRequires: lua52
 BuildRequires: lua52-devel
 %endif
-BuildRequires: ncurses-devel
 %if %{with ocaml}
-BuildRequires: ocaml
+BuildRequires: ocaml >= 1:4.0
 BuildRequires: ocaml-camlp4
 BuildRequires: ocaml-fileutils-devel
 BuildRequires: ocaml-findlib
 BuildRequires: ocaml-gettext-devel
+BuildRequires: ocaml-hivex-devel
+BuildRequires: ocaml-libvirt-devel >= 0.6.1.4-4
 BuildRequires: ocaml-pcre-devel
+# for virt-builder
+BuildRequires: xz-devel
 %endif
-BuildRequires: pcre-devel
-BuildRequires: perl-base
-BuildRequires: perl-tools-pod
 %if %{with perl}
 BuildRequires: perl-ExtUtils-MakeMaker
+BuildRequires: perl-Module-Build
 BuildRequires: perl-Test-Simple
 BuildRequires: rpm-perlprov
 %endif
@@ -102,18 +170,15 @@ BuildRequires:    perl-hivex >= 1.2.7
 BuildRequires: perl-libintl
 BuildRequires: perl-modules
 %endif
-%{?with_php:BuildRequires:     /usr/bin/php}
-%{?with_php:BuildRequires:     php-devel}
-BuildRequires: pkgconfig
-BuildRequires: po4a
+%if %{with php}
+BuildRequires: %{php_name}-devel
+BuildRequires: %{php_name}-program
+%endif
 %if %{with python}
-BuildRequires: python
-BuildRequires: python-devel
+BuildRequires: python >= 1:2.7
+BuildRequires: python-devel >= 1:2.7
 BuildRequires: rpm-pythonprov
 %endif
-BuildRequires: qemu-img
-BuildRequires: readline-devel
-BuildRequires: rpmbuild(macros) >= 1.656
 %if %{with ruby}
 BuildRequires: rpm-rubyprov
 BuildRequires: ruby
@@ -123,16 +188,24 @@ BuildRequires:    ruby-rake
 BuildRequires: ruby-rdoc
 BuildRequires: ruby-rubygems
 %endif
-# libsystemd-journal
-BuildRequires: systemd-devel
-%{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
-BuildRequires: yajl-devel >= 2
+%if %{with systemtap}
+BuildRequires: systemtap-sdt-devel
+%endif
 Requires:      qemu-common >= 1.1.0
+Requires:      yajl >= 2.0.4
 Suggests:      db-utils
 Suggests:      icoutils
 Suggests:      netpbm-progs
+Obsoletes:     libguestfs-apidocs < 1.40.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%ifarch %{ix86}
+%define                qemu_bin        /usr/bin/qemu-system-i386
+%endif
+%ifarch %{x8664} x32
+%define                qemu_bin        /usr/bin/qemu-system-x86_64
+%endif
+
 %description
 libguestfs is a library and set of tools for accessing and modifying
 virtual machine (VM) disk images. You can use this for viewing and
@@ -172,17 +245,6 @@ Static libguestfs library.
 %description static -l pl.UTF-8
 Statyczna biblioteka libguestfs.
 
-%package apidocs
-Summary:       libguestfs API documentation
-Summary(pl.UTF-8):     Dokumentacja API libguestfs
-Group:         Documentation
-
-%description apidocs
-libguestfs API documentation.
-
-%description apidocs -l pl.UTF-8
-Dokumentacja API libguestfs.
-
 %package gobject
 Summary:       GObject bindings to libguestfs library
 Summary(pl.UTF-8):     Wiązania GObject do biblioteki libguestfs
@@ -227,9 +289,15 @@ Summary:   libguestfs tools for accessing and modifying virtual machine disk image
 Summary(pl.UTF-8):     Narzędzia libguestfs do dostępu i modyfikacji obrazów dysków maszyn wirtualnych
 Group:         Applications/System
 Requires:      %{name} = %{version}-%{release}
+Requires:      augeas-libs >= 1.0.0
 %{?with_ocaml:Requires:        ocaml-libguestfs = %{version}-%{release}}
 %{?with_perltools:Requires:    perl-libguestfs = %{version}-%{release}}
-Requires:      augeas-libs >= 1.0.0
+%if %{with ocaml}
+Requires:      ocaml-libvirt >= 0.6.1.4-4
+Suggests:      unzip
+Suggests:      xz
+Suggests:      zip
+%endif
 
 %description tools
 libguestfs tools for accessing and modifying virtual machine (VM) disk
@@ -343,17 +411,17 @@ Perl bindings for libguestfs.
 %description -n perl-libguestfs -l pl.UTF-8
 Wiązania Perla do libguestfs.
 
-%package -n php-guestfs
+%package -n %{php_name}-guestfs
 Summary:       PHP bindings for libguestfs
 Summary(pl.UTF-8):     Wiązania PHP do libguestfs
 Group:         Development/Languages/PHP
 Requires:      %{name} = %{version}-%{release}
 %{?requires_php_extension}
 
-%description -n php-guestfs
+%description -n %{php_name}-guestfs
 PHP bindings for libguestfs.
 
-%description -n php-guestfs -l pl.UTF-8
+%description -n %{php_name}-guestfs -l pl.UTF-8
 Wiązania PHP do libguestfs.
 
 %package -n python-libguestfs
@@ -399,8 +467,17 @@ Bashowe uzupełnianie argumentów dla narzędzi libguestfs.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' \
+      tools/virt-list-filesystems \
+      tools/virt-list-partitions \
+      tools/virt-tar \
+      tools/virt-win-reg \
 
 %build
+# preserve dir across libtoolize
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
@@ -408,17 +485,21 @@ Bashowe uzupełnianie argumentów dla narzędzi libguestfs.
 %{__automake}
 %configure \
        vmchannel_test=no \
+       DB_DUMP=/usr/bin/db_dump \
+       DB_LOAD=/usr/bin/db_load \
        %{?with_lua:LUA=/usr/bin/lua5.2} \
        PBMTEXT=/usr/bin/pbmtext \
        PNMTOPNG=/usr/bin/pnmtopng \
        BMPTOPNM=/usr/bin/bmptopnm \
        PAMCUT=/usr/bin/pamcut \
+       SUPERMIN=/usr/bin/supermin \
+       UNZIP=/usr/bin/unzip \
        WRESTOOL=/usr/bin/wrestool \
-       QEMU=%{_bindir}/qemu \
+       QEMU=%{?qemu_bin}%{!?qemu_bin:/usr/bin/qemu} \
+       ZIP=/usr/bin/zip \
        --with-completionsdir=%{_datadir}/bash-completion/completions \
-       --with-html-dir=%{_gtkdocdir} \
        --with-java=%{?with_java:%{java_home}}%{!?with_java:no} \
-       --with-qemu=qemu \
+       --with-python-installdir=%{py_sitedir} \
        --enable-install-daemon \
        %{!?with_appliance:--disable-appliance} \
        %{!?with_erlang:--disable-erlang} \
@@ -434,7 +515,7 @@ Bashowe uzupełnianie argumentów dla narzędzi libguestfs.
        --disable-silent-rules \
        %{__enable_disable static_libs static}
 
-%{__make} \
+%{__make} -j1 \
        INSTALLDIRS=vendor
 
 %install
@@ -443,7 +524,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        INSTALLDIRS=vendor \
        DESTDIR=$RPM_BUILD_ROOT \
-       phpdir=%{_sysconfdir}/php/conf.d
+       phpdir=%{php_sysconfdir}/conf.d
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
 %if %{with lua}
@@ -452,11 +533,28 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python}
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
 %endif
+# doc cleanup
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/libguestfs/{example-*,virt-inspector.rng}
 
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_postclean
 
+%if %{without appliance}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/{ja,uk}/man1/libguestfs-make-fixed-appliance.1
+%endif
+%if %{with ocaml}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dll*.so.owner
+%else
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/{ja,uk}/man1/virt-{builder,index-validate,resize,sparsify,sysprep,v2v-test-harness}.1 \
+       $RPM_BUILD_ROOT%{_mandir}/{ja,uk}/man3/guestfs-ocaml.3
+%endif
+%if %{without ruby}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/{ja,uk}/man3/guestfs-ruby.3
+%endif
+
+install -d $RPM_BUILD_ROOT%{_libdir}/guestfs
+
 %find_lang %{name}
 
 %clean
@@ -473,23 +571,33 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS BUGS ChangeLog README ROADMAP TODO
+%doc AUTHORS BUGS ChangeLog README TODO
 %attr(755,root,root) %{_libdir}/libguestfs.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libguestfs.so.0
+%dir %{_libdir}/guestfs
 %{_mandir}/man1/guestfs-release-notes.1*
+%{_mandir}/man1/guestfs-security.1*
 %lang(ja) %{_mandir}/ja/man1/guestfs-release-notes.1*
+%lang(ja) %{_mandir}/ja/man1/guestfs-security.1*
 %lang(uk) %{_mandir}/uk/man1/guestfs-release-notes.1*
+%lang(uk) %{_mandir}/uk/man1/guestfs-security.1*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libguestfs.so
 %{_includedir}/guestfs.h
 %{_pkgconfigdir}/libguestfs.pc
+%{_mandir}/man1/guestfs-hacking.1*
+%{_mandir}/man1/guestfs-internals.1*
 %{_mandir}/man3/guestfs.3*
 %{_mandir}/man3/guestfs-examples.3*
 %{_mandir}/man3/libguestfs.3*
+%lang(ja) %{_mandir}/ja/man1/guestfs-hacking.1*
+%lang(ja) %{_mandir}/ja/man1/guestfs-internals.1*
 %lang(ja) %{_mandir}/ja/man3/guestfs.3*
 %lang(ja) %{_mandir}/ja/man3/guestfs-examples.3*
+%lang(uk) %{_mandir}/uk/man1/guestfs-hacking.1*
+%lang(uk) %{_mandir}/uk/man1/guestfs-internals.1*
 %lang(uk) %{_mandir}/uk/man3/guestfs.3*
 %lang(uk) %{_mandir}/uk/man3/guestfs-examples.3*
 
@@ -499,10 +607,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libguestfs.a
 %endif
 
-%files apidocs
-%defattr(644,root,root,755)
-%{_gtkdocdir}/guestfs
-
 %files gobject
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libguestfs-gobject-1.0.so.*.*.*
@@ -530,19 +634,24 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/guestunmount
 %attr(755,root,root) %{_bindir}/libguestfs-test-tool
 %attr(755,root,root) %{_bindir}/virt-alignment-scan
-%attr(755,root,root) %{_bindir}/virt-builder
 %attr(755,root,root) %{_bindir}/virt-cat
 %attr(755,root,root) %{_bindir}/virt-copy-in
 %attr(755,root,root) %{_bindir}/virt-copy-out
 %attr(755,root,root) %{_bindir}/virt-df
+%attr(755,root,root) %{_bindir}/virt-dib
+%attr(755,root,root) %{_bindir}/virt-diff
 %attr(755,root,root) %{_bindir}/virt-edit
 %attr(755,root,root) %{_bindir}/virt-filesystems
 %attr(755,root,root) %{_bindir}/virt-format
+%attr(755,root,root) %{_bindir}/virt-get-kernel
 %attr(755,root,root) %{_bindir}/virt-inspector
+%attr(755,root,root) %{_bindir}/virt-log
 %attr(755,root,root) %{_bindir}/virt-ls
 %attr(755,root,root) %{_bindir}/virt-rescue
+%attr(755,root,root) %{_bindir}/virt-tail
 %attr(755,root,root) %{_bindir}/virt-tar-in
 %attr(755,root,root) %{_bindir}/virt-tar-out
+%attr(755,root,root) %{_bindir}/virt-v2v-copy-to-local
 %attr(755,root,root) %{_sbindir}/guestfsd
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libguestfs-tools.conf
 %{_mandir}/man1/guestfish.1*
@@ -554,19 +663,24 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/guestunmount.1*
 %{_mandir}/man1/libguestfs-test-tool.1*
 %{_mandir}/man1/virt-alignment-scan.1*
-%{_mandir}/man1/virt-builder.1*
 %{_mandir}/man1/virt-cat.1*
 %{_mandir}/man1/virt-copy-in.1*
 %{_mandir}/man1/virt-copy-out.1*
 %{_mandir}/man1/virt-df.1*
+%{_mandir}/man1/virt-dib.1*
+%{_mandir}/man1/virt-diff.1*
 %{_mandir}/man1/virt-edit.1*
 %{_mandir}/man1/virt-filesystems.1*
 %{_mandir}/man1/virt-format.1*
+%{_mandir}/man1/virt-get-kernel.1*
 %{_mandir}/man1/virt-inspector.1*
+%{_mandir}/man1/virt-log.1*
 %{_mandir}/man1/virt-ls.1*
 %{_mandir}/man1/virt-rescue.1*
+%{_mandir}/man1/virt-tail.1*
 %{_mandir}/man1/virt-tar-in.1*
 %{_mandir}/man1/virt-tar-out.1*
+%{_mandir}/man1/virt-v2v-copy-to-local.1*
 %{_mandir}/man5/libguestfs-tools.conf.5*
 %{_mandir}/man8/guestfsd.8*
 %lang(ja) %{_mandir}/ja/man1/guestfish.1*
@@ -578,15 +692,18 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_mandir}/ja/man1/guestunmount.1*
 %lang(ja) %{_mandir}/ja/man1/libguestfs-test-tool.1*
 %lang(ja) %{_mandir}/ja/man1/virt-alignment-scan.1*
-%lang(ja) %{_mandir}/ja/man1/virt-builder.1*
+%lang(ja) %{_mandir}/ja/man1/virt-diff.1*
 %lang(ja) %{_mandir}/ja/man1/virt-cat.1*
 %lang(ja) %{_mandir}/ja/man1/virt-copy-in.1*
 %lang(ja) %{_mandir}/ja/man1/virt-copy-out.1*
 %lang(ja) %{_mandir}/ja/man1/virt-df.1*
+%lang(ja) %{_mandir}/ja/man1/virt-dib.1*
 %lang(ja) %{_mandir}/ja/man1/virt-edit.1*
 %lang(ja) %{_mandir}/ja/man1/virt-filesystems.1*
 %lang(ja) %{_mandir}/ja/man1/virt-format.1*
+%lang(ja) %{_mandir}/ja/man1/virt-get-kernel.1*
 %lang(ja) %{_mandir}/ja/man1/virt-inspector.1*
+%lang(ja) %{_mandir}/ja/man1/virt-log.1*
 %lang(ja) %{_mandir}/ja/man1/virt-ls.1*
 %lang(ja) %{_mandir}/ja/man1/virt-rescue.1*
 %lang(ja) %{_mandir}/ja/man1/virt-tar-in.1*
@@ -601,33 +718,58 @@ rm -rf $RPM_BUILD_ROOT
 %lang(uk) %{_mandir}/uk/man1/guestunmount.1*
 %lang(uk) %{_mandir}/uk/man1/libguestfs-test-tool.1*
 %lang(uk) %{_mandir}/uk/man1/virt-alignment-scan.1*
-%lang(uk) %{_mandir}/uk/man1/virt-builder.1*
 %lang(uk) %{_mandir}/uk/man1/virt-cat.1*
 %lang(uk) %{_mandir}/uk/man1/virt-copy-in.1*
 %lang(uk) %{_mandir}/uk/man1/virt-copy-out.1*
 %lang(uk) %{_mandir}/uk/man1/virt-df.1*
+%lang(ja) %{_mandir}/uk/man1/virt-dib.1*
+%lang(uk) %{_mandir}/uk/man1/virt-diff.1*
 %lang(uk) %{_mandir}/uk/man1/virt-edit.1*
 %lang(uk) %{_mandir}/uk/man1/virt-filesystems.1*
 %lang(uk) %{_mandir}/uk/man1/virt-format.1*
+%lang(ja) %{_mandir}/uk/man1/virt-get-kernel.1*
 %lang(uk) %{_mandir}/uk/man1/virt-inspector.1*
+%lang(uk) %{_mandir}/uk/man1/virt-log.1*
 %lang(uk) %{_mandir}/uk/man1/virt-ls.1*
 %lang(uk) %{_mandir}/uk/man1/virt-rescue.1*
 %lang(uk) %{_mandir}/uk/man1/virt-tar-in.1*
 %lang(uk) %{_mandir}/uk/man1/virt-tar-out.1*
 %lang(uk) %{_mandir}/uk/man5/libguestfs-tools.conf.5*
 %if %{with ocaml}
+%attr(755,root,root) %{_bindir}/virt-builder
+%attr(755,root,root) %{_bindir}/virt-customize
+%attr(755,root,root) %{_bindir}/virt-index-validate
 %attr(755,root,root) %{_bindir}/virt-resize
 %attr(755,root,root) %{_bindir}/virt-sparsify
 %attr(755,root,root) %{_bindir}/virt-sysprep
+%attr(755,root,root) %{_bindir}/virt-v2v
+# compat dir symlink
+%{_sysconfdir}/virt-builder
+%dir /etc/xdg/virt-builder
+%dir /etc/xdg/virt-builder/repos.d
+%config(noreplace) %verify(not md5 mtime size) /etc/xdg/virt-builder/repos.d/libguestfs.conf
+%config(noreplace) %verify(not md5 mtime size) /etc/xdg/virt-builder/repos.d/libguestfs.gpg
+%{_mandir}/man1/virt-builder.1*
+%{_mandir}/man1/virt-customize.1*
+%{_mandir}/man1/virt-index-validate.1*
 %{_mandir}/man1/virt-resize.1*
 %{_mandir}/man1/virt-sparsify.1*
 %{_mandir}/man1/virt-sysprep.1*
+%{_mandir}/man1/virt-v2v.1*
+%lang(ja) %{_mandir}/ja/man1/virt-builder.1*
+%lang(ja) %{_mandir}/ja/man1/virt-customize.1*
+%lang(ja) %{_mandir}/ja/man1/virt-index-validate.1*
 %lang(ja) %{_mandir}/ja/man1/virt-resize.1*
 %lang(ja) %{_mandir}/ja/man1/virt-sparsify.1*
 %lang(ja) %{_mandir}/ja/man1/virt-sysprep.1*
+%lang(ja) %{_mandir}/ja/man1/virt-v2v.1*
+%lang(uk) %{_mandir}/uk/man1/virt-builder.1*
+%lang(uk) %{_mandir}/uk/man1/virt-customize.1*
+%lang(uk) %{_mandir}/uk/man1/virt-index-validate.1*
 %lang(uk) %{_mandir}/uk/man1/virt-resize.1*
 %lang(uk) %{_mandir}/uk/man1/virt-sparsify.1*
 %lang(uk) %{_mandir}/uk/man1/virt-sysprep.1*
+%lang(uk) %{_mandir}/uk/man1/virt-v2v.1*
 %endif
 %if %{with perltools}
 %attr(755,root,root) %{_bindir}/virt-list-filesystems
@@ -652,6 +794,24 @@ rm -rf $RPM_BUILD_ROOT
 %lang(uk) %{_mandir}/uk/man1/virt-win-reg.1*
 %endif
 
+%if %{with gtk}
+%attr(755,root,root) %{_bindir}/virt-p2v-make-disk
+%attr(755,root,root) %{_bindir}/virt-p2v-make-kickstart
+%attr(755,root,root) %{_bindir}/virt-p2v-make-kiwi
+%attr(755,root,root) %{_libdir}/virt-p2v
+%{_datadir}/virt-p2v
+%{_mandir}/man1/virt-p2v.1*
+%{_mandir}/man1/virt-p2v-make-disk.1*
+%{_mandir}/man1/virt-p2v-make-kickstart.1*
+%{_mandir}/man1/virt-p2v-make-kiwi.1*
+%lang(ja) %{_mandir}/ja/man1/virt-p2v.1*
+%lang(ja) %{_mandir}/ja/man1/virt-p2v-make-disk.1*
+%lang(ja) %{_mandir}/ja/man1/virt-p2v-make-kickstart.1*
+%lang(uk) %{_mandir}/uk/man1/virt-p2v.1*
+%lang(uk) %{_mandir}/uk/man1/virt-p2v-make-disk.1*
+%lang(uk) %{_mandir}/uk/man1/virt-p2v-make-kickstart.1*
+%endif
+
 %if %{with appliance}
 %attr(755,root,root) %{_sbindir}/libguestfs-make-fixed-appliance
 %{_mandir}/man1/libguestfs-make-fixed-appliance.1*
@@ -683,7 +843,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/golang/pkg/linux_*/libguestfs.org
 %dir %{_libdir}/golang/pkg/linux_*/libguestfs.org/guestfs
 %{_libdir}/golang/pkg/linux_*/libguestfs.org/guestfs/guestfs.a
-%{_libdir}/golang/src/pkg/libguestfs.org
+%{_libdir}/golang/src/libguestfs.org
 %{_mandir}/man3/guestfs-golang.3*
 %lang(ja) %{_mandir}/ja/man3/guestfs-golang.3*
 %lang(uk) %{_mandir}/uk/man3/guestfs-golang.3*
@@ -718,20 +878,33 @@ rm -rf $RPM_BUILD_ROOT
 %files -n ocaml-libguestfs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllmlguestfs.so
-%{_libdir}/ocaml/stublibs/dllmlguestfs.so.owner
+#%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllv2v_test_harness.so
+%dir %{_libdir}/ocaml/guestfs
+%{_libdir}/ocaml/guestfs/META
+%{_libdir}/ocaml/guestfs/mlguestfs.cma
 
 %files -n ocaml-libguestfs-devel
 %defattr(644,root,root,755)
-%dir %{_libdir}/ocaml/guestfs
-%{_libdir}/ocaml/guestfs/META
 %{_libdir}/ocaml/guestfs/guestfs.cmi
-%{_libdir}/ocaml/guestfs/guestfs.cmx
 %{_libdir}/ocaml/guestfs/guestfs.mli
 %{_libdir}/ocaml/guestfs/libmlguestfs.a
+#%dir %{_libdir}/ocaml/v2v_test_harness
+#%{_libdir}/ocaml/v2v_test_harness/META
+#%{_libdir}/ocaml/v2v_test_harness/libv2v_test_harness.a
+#%{_libdir}/ocaml/v2v_test_harness/v2v_test_harness.cmi
+#%{_libdir}/ocaml/v2v_test_harness/v2v_test_harness.mli
+%if %{with ocaml_opt}
+%{_libdir}/ocaml/guestfs/guestfs.cmx
 %{_libdir}/ocaml/guestfs/mlguestfs.a
-%{_libdir}/ocaml/guestfs/mlguestfs.cma
 %{_libdir}/ocaml/guestfs/mlguestfs.cmxa
+#%{_libdir}/ocaml/v2v_test_harness/v2v_test_harness.a
+#%{_libdir}/ocaml/v2v_test_harness/v2v_test_harness.cmx
+#%{_libdir}/ocaml/v2v_test_harness/v2v_test_harness.cmxa
+%endif
+#%{_mandir}/man1/virt-v2v-test-harness.1*
 %{_mandir}/man3/guestfs-ocaml.3*
+%lang(ja) %{_mandir}/ja/man1/virt-v2v-test-harness.1*
+%lang(uk) %{_mandir}/uk/man1/virt-v2v-test-harness.1*
 %lang(ja) %{_mandir}/ja/man3/guestfs-ocaml.3*
 %lang(uk) %{_mandir}/uk/man3/guestfs-ocaml.3*
 %endif
@@ -740,9 +913,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -n perl-libguestfs
 %defattr(644,root,root,755)
 %{perl_vendorarch}/Sys/Guestfs.pm
-%{perl_vendorarch}/Sys/bindtests.pl
 %dir %{perl_vendorarch}/auto/Sys/Guestfs
-%{perl_vendorarch}/auto/Sys/Guestfs/Guestfs.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Guestfs/Guestfs.so
 %{_mandir}/man3/guestfs-perl.3*
 %{_mandir}/man3/Sys::Guestfs.3pm*
@@ -751,10 +922,10 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %if %{with php}
-%files -n php-guestfs
+%files -n %{php_name}-guestfs
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php/conf.d/guestfs_php.ini
-%attr(755,root,root) %{_libdir}/php/guestfs_php.so
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/guestfs_php.ini
+%attr(755,root,root) %{php_extensiondir}/guestfs_php.so
 %endif
 
 %if %{with python}
@@ -779,6 +950,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n bash-completion-libguestfs
 %defattr(644,root,root,755)
-%{_datadir}/bash-completion/completions/guestfish
-%{_datadir}/bash-completion/completions/guestmount
-%{_datadir}/bash-completion/completions/virt-*
+%{bash_compdir}/guestfish
+%{bash_compdir}/guestmount
+%{bash_compdir}/guestunmount
+%{bash_compdir}/virt-*
This page took 0.115698 seconds and 4 git commands to generate.