Renamed to libgnome-games-support and updated to 1.2.0
[packages/libgnome-games-support.git] / libgnome-games-support.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Support library for GNOME games
6 Summary(pl.UTF-8):      Biblioteka wspierająca dla gier GNOME
7 Name:           libgnome-games-support
8 Version:        1.2.0
9 Release:        1
10 License:        LGPL v3+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgnome-games-support/1.2/%{name}-%{version}.tar.xz
13 # Source0-md5:  faedf9fbea367623314eb70f58017a24
14 BuildRequires:  autoconf >= 2.69
15 BuildRequires:  automake >= 1:1.11
16 BuildRequires:  glib2-devel >= 1:2.40.0
17 BuildRequires:  gtk+3-devel >= 3.20.0
18 BuildRequires:  libgee-devel >= 0.8
19 BuildRequires:  libtool >= 2:2.2
20 BuildRequires:  pkgconfig
21 BuildRequires:  vala >= 2:0.24.0
22 Requires:       glib2 >= 1:2.40.0
23 Requires:       gtk+3 >= 3.20.0
24 Provides:       libgames-support = %{version}-%{release}
25 Obsoletes:      libgames-support < 1.2.0-1
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libgnome-games-support is a small library intended for internal use by
30 GNOME Games, but it may be used by others. The API will only break
31 with the major version number. The ABI is unstable.
32
33 %description -l pl.UTF-8
34 libgnome-games-support to mała biblioteka przeznaczona do użytku
35 wewnętrznego gier ze środowiska GNOME, ale może być wykorzystywana
36 także przez innych. API może się zmieniać tylko wraz z głównym numerem
37 wersji; ABI nie jest stabilne.
38
39 %package devel
40 Summary:        Header files for libgnome-games-support library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgnome-games-support
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       glib2-devel >= 1:2.40.0
45 Requires:       gtk+3-devel >= 3.20.0
46 Provides:       libgames-support-devel = %{version}-%{release}
47 Obsoletes:      libgames-support-devel < 1.2.0-1
48
49 %description devel
50 Header files for libgnome-games-support library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki libgnome-games-support.
54
55 %package static
56 Summary:        Static libgnome-games-support library
57 Summary(pl.UTF-8):      Statyczna biblioteka libgnome-games-support
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60 Provides:       libgames-support-static = %{version}-%{release}
61 Obsoletes:      libgames-support-static < 1.2.0-1
62
63 %description static
64 Static libgnome-games-support library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libgnome-games-support.
68
69 %package -n vala-libgnome-games-support
70 Summary:        Vala API for libgnome-games-support library
71 Summary(pl.UTF-8):      API języka Vala do bibliotek libgnome-games-support
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74 Provides:       vala-libgames-support = %{version}-%{release}
75 Obsoletes:      vala-libgames-support < 1.2.0-1
76 %if "%{_rpmversion}" >= "5"
77 BuildArch:      noarch
78 %endif
79
80 %description -n vala-libgnome-games-support
81 Vala API for libgnome-games-support library.
82
83 %description -n vala-libgnome-games-support -l pl.UTF-8
84 API języka Vala do bibliotek libgnome-games-support.
85
86 %prep
87 %setup -q
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         --disable-silent-rules \
96         %{?with_static_libs:--enable-static}
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc NEWS README
118 %attr(755,root,root) %{_libdir}/libgnome-games-support-1.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libgnome-games-support-1.so.2
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libgnome-games-support-1.so
124 %{_includedir}/gnome-games-support-1
125 %{_pkgconfigdir}/libgnome-games-support-1.pc
126
127 %if %{with static_libs}
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libgnome-games-support-1.a
131 %endif
132
133 %files -n vala-libgnome-games-support
134 %defattr(644,root,root,755)
135 %{_datadir}/vala/vapi/libgnome-games-support-1.vapi
This page took 0.080066 seconds and 3 git commands to generate.