Update to 1.2.3
[packages/libgnome-games-support.git] / libgnome-games-support.spec
CommitLineData
444a1b2f
MB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4
5Summary: Support library for GNOME games
6Summary(pl.UTF-8): Biblioteka wspierająca dla gier GNOME
7Name: libgnome-games-support
cfa2aec1 8Version: 1.2.3
444a1b2f
MB
9Release: 1
10License: LGPL v3+
11Group: X11/Libraries
12Source0: http://ftp.gnome.org/pub/GNOME/sources/libgnome-games-support/1.2/%{name}-%{version}.tar.xz
cfa2aec1 13# Source0-md5: aa450e7cf337452270d358c8905d8f8f
444a1b2f
MB
14BuildRequires: autoconf >= 2.69
15BuildRequires: automake >= 1:1.11
490df34b 16BuildRequires: gettext-tools >= 0.19.8
444a1b2f
MB
17BuildRequires: glib2-devel >= 1:2.40.0
18BuildRequires: gtk+3-devel >= 3.20.0
19BuildRequires: libgee-devel >= 0.8
20BuildRequires: libtool >= 2:2.2
21BuildRequires: pkgconfig
22BuildRequires: vala >= 2:0.24.0
23Requires: glib2 >= 1:2.40.0
24Requires: gtk+3 >= 3.20.0
25Provides: libgames-support = %{version}-%{release}
26Obsoletes: libgames-support < 1.2.0-1
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30libgnome-games-support is a small library intended for internal use by
31GNOME Games, but it may be used by others. The API will only break
32with the major version number. The ABI is unstable.
33
34%description -l pl.UTF-8
35libgnome-games-support to mała biblioteka przeznaczona do użytku
36wewnętrznego gier ze środowiska GNOME, ale może być wykorzystywana
37także przez innych. API może się zmieniać tylko wraz z głównym numerem
38wersji; ABI nie jest stabilne.
39
40%package devel
41Summary: Header files for libgnome-games-support library
42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libgnome-games-support
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: glib2-devel >= 1:2.40.0
46Requires: gtk+3-devel >= 3.20.0
47Provides: libgames-support-devel = %{version}-%{release}
48Obsoletes: libgames-support-devel < 1.2.0-1
49
50%description devel
51Header files for libgnome-games-support library.
52
53%description devel -l pl.UTF-8
54Pliki nagłówkowe biblioteki libgnome-games-support.
55
56%package static
57Summary: Static libgnome-games-support library
58Summary(pl.UTF-8): Statyczna biblioteka libgnome-games-support
59Group: Development/Libraries
60Requires: %{name}-devel = %{version}-%{release}
61Provides: libgames-support-static = %{version}-%{release}
62Obsoletes: libgames-support-static < 1.2.0-1
63
64%description static
65Static libgnome-games-support library.
66
67%description static -l pl.UTF-8
68Statyczna biblioteka libgnome-games-support.
69
70%package -n vala-libgnome-games-support
71Summary: Vala API for libgnome-games-support library
72Summary(pl.UTF-8): API języka Vala do bibliotek libgnome-games-support
73Group: Development/Libraries
74Requires: %{name}-devel = %{version}-%{release}
75Provides: vala-libgames-support = %{version}-%{release}
76Obsoletes: vala-libgames-support < 1.2.0-1
77%if "%{_rpmversion}" >= "5"
78BuildArch: noarch
79%endif
80
81%description -n vala-libgnome-games-support
82Vala API for libgnome-games-support library.
83
84%description -n vala-libgnome-games-support -l pl.UTF-8
85API języka Vala do bibliotek libgnome-games-support.
86
87%prep
88%setup -q
89
90%build
91%{__libtoolize}
92%{__aclocal} -I m4
93%{__autoconf}
94%{__automake}
95%configure \
96 --disable-silent-rules \
97 %{?with_static_libs:--enable-static}
98%{__make}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
107
108%find_lang %{name}
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files -f %{name}.lang
117%defattr(644,root,root,755)
118%doc NEWS README
119%attr(755,root,root) %{_libdir}/libgnome-games-support-1.so.*.*.*
120%attr(755,root,root) %ghost %{_libdir}/libgnome-games-support-1.so.2
121
122%files devel
123%defattr(644,root,root,755)
124%attr(755,root,root) %{_libdir}/libgnome-games-support-1.so
125%{_includedir}/gnome-games-support-1
126%{_pkgconfigdir}/libgnome-games-support-1.pc
127
128%if %{with static_libs}
129%files static
130%defattr(644,root,root,755)
131%{_libdir}/libgnome-games-support-1.a
132%endif
133
134%files -n vala-libgnome-games-support
135%defattr(644,root,root,755)
136%{_datadir}/vala/vapi/libgnome-games-support-1.vapi
This page took 0.074839 seconds and 4 git commands to generate.