- updated to 1.4.4
[packages/libgnome-games-support.git] / libgnome-games-support.spec
CommitLineData
444a1b2f
MB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4
5Summary: Support library for GNOME games
6Summary(pl.UTF-8): Biblioteka wspierająca dla gier GNOME
7Name: libgnome-games-support
92cb72af 8Version: 1.4.4
444a1b2f
MB
9Release: 1
10License: LGPL v3+
11Group: X11/Libraries
b70a16eb 12Source0: http://ftp.gnome.org/pub/GNOME/sources/libgnome-games-support/1.4/%{name}-%{version}.tar.xz
92cb72af 13# Source0-md5: 2bc7594ad4b54f25648964792112bc51
c8dc2358 14URL: https://github.com/GNOME/libgnome-games-support
444a1b2f
MB
15BuildRequires: autoconf >= 2.69
16BuildRequires: automake >= 1:1.11
490df34b 17BuildRequires: gettext-tools >= 0.19.8
444a1b2f
MB
18BuildRequires: glib2-devel >= 1:2.40.0
19BuildRequires: gtk+3-devel >= 3.20.0
20BuildRequires: libgee-devel >= 0.8
21BuildRequires: libtool >= 2:2.2
22BuildRequires: pkgconfig
b70a16eb 23BuildRequires: vala >= 2:0.40.0
444a1b2f
MB
24Requires: glib2 >= 1:2.40.0
25Requires: gtk+3 >= 3.20.0
c8dc2358 26Requires: libgee >= 0.8
444a1b2f
MB
27Provides: libgames-support = %{version}-%{release}
28Obsoletes: libgames-support < 1.2.0-1
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32libgnome-games-support is a small library intended for internal use by
33GNOME Games, but it may be used by others. The API will only break
34with the major version number. The ABI is unstable.
35
36%description -l pl.UTF-8
37libgnome-games-support to mała biblioteka przeznaczona do użytku
38wewnętrznego gier ze środowiska GNOME, ale może być wykorzystywana
39także przez innych. API może się zmieniać tylko wraz z głównym numerem
40wersji; ABI nie jest stabilne.
41
42%package devel
43Summary: Header files for libgnome-games-support library
44Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libgnome-games-support
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: glib2-devel >= 1:2.40.0
48Requires: gtk+3-devel >= 3.20.0
c8dc2358 49Requires: libgee-devel >= 0.8
444a1b2f
MB
50Provides: libgames-support-devel = %{version}-%{release}
51Obsoletes: libgames-support-devel < 1.2.0-1
52
53%description devel
54Header files for libgnome-games-support library.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe biblioteki libgnome-games-support.
58
59%package static
60Summary: Static libgnome-games-support library
61Summary(pl.UTF-8): Statyczna biblioteka libgnome-games-support
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64Provides: libgames-support-static = %{version}-%{release}
65Obsoletes: libgames-support-static < 1.2.0-1
66
67%description static
68Static libgnome-games-support library.
69
70%description static -l pl.UTF-8
71Statyczna biblioteka libgnome-games-support.
72
73%package -n vala-libgnome-games-support
74Summary: Vala API for libgnome-games-support library
75Summary(pl.UTF-8): API języka Vala do bibliotek libgnome-games-support
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78Provides: vala-libgames-support = %{version}-%{release}
79Obsoletes: vala-libgames-support < 1.2.0-1
80%if "%{_rpmversion}" >= "5"
81BuildArch: noarch
82%endif
83
84%description -n vala-libgnome-games-support
85Vala API for libgnome-games-support library.
86
87%description -n vala-libgnome-games-support -l pl.UTF-8
88API języka Vala do bibliotek libgnome-games-support.
89
90%prep
91%setup -q
92
93%build
94%{__libtoolize}
95%{__aclocal} -I m4
96%{__autoconf}
97%{__automake}
98%configure \
99 --disable-silent-rules \
100 %{?with_static_libs:--enable-static}
101%{__make}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
109%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
110
111%find_lang %{name}
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files -f %{name}.lang
120%defattr(644,root,root,755)
121%doc NEWS README
122%attr(755,root,root) %{_libdir}/libgnome-games-support-1.so.*.*.*
b70a16eb 123%attr(755,root,root) %ghost %{_libdir}/libgnome-games-support-1.so.3
444a1b2f
MB
124
125%files devel
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_libdir}/libgnome-games-support-1.so
128%{_includedir}/gnome-games-support-1
129%{_pkgconfigdir}/libgnome-games-support-1.pc
130
131%if %{with static_libs}
132%files static
133%defattr(644,root,root,755)
134%{_libdir}/libgnome-games-support-1.a
135%endif
136
137%files -n vala-libgnome-games-support
138%defattr(644,root,root,755)
139%{_datadir}/vala/vapi/libgnome-games-support-1.vapi
This page took 0.132427 seconds and 4 git commands to generate.