- obsolete old gnome-games libs/common and devel packages
[packages/libgnome-games-support.git] / libgnome-games-support.spec
CommitLineData
444a1b2f
MB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4
5Summary: Support library for GNOME games
6Summary(pl.UTF-8): Biblioteka wspierająca dla gier GNOME
7Name: libgnome-games-support
92cb72af 8Version: 1.4.4
444a1b2f
MB
9Release: 1
10License: LGPL v3+
11Group: X11/Libraries
b70a16eb 12Source0: http://ftp.gnome.org/pub/GNOME/sources/libgnome-games-support/1.4/%{name}-%{version}.tar.xz
92cb72af 13# Source0-md5: 2bc7594ad4b54f25648964792112bc51
c8dc2358 14URL: https://github.com/GNOME/libgnome-games-support
444a1b2f
MB
15BuildRequires: autoconf >= 2.69
16BuildRequires: automake >= 1:1.11
490df34b 17BuildRequires: gettext-tools >= 0.19.8
444a1b2f
MB
18BuildRequires: glib2-devel >= 1:2.40.0
19BuildRequires: gtk+3-devel >= 3.20.0
20BuildRequires: libgee-devel >= 0.8
21BuildRequires: libtool >= 2:2.2
22BuildRequires: pkgconfig
b70a16eb 23BuildRequires: vala >= 2:0.40.0
444a1b2f
MB
24Requires: glib2 >= 1:2.40.0
25Requires: gtk+3 >= 3.20.0
c8dc2358 26Requires: libgee >= 0.8
444a1b2f 27Provides: libgames-support = %{version}-%{release}
ee387c8a 28Obsoletes: gnome-games < 1:3.8.0
444a1b2f
MB
29Obsoletes: libgames-support < 1.2.0-1
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33libgnome-games-support is a small library intended for internal use by
34GNOME Games, but it may be used by others. The API will only break
35with the major version number. The ABI is unstable.
36
37%description -l pl.UTF-8
38libgnome-games-support to mała biblioteka przeznaczona do użytku
39wewnętrznego gier ze środowiska GNOME, ale może być wykorzystywana
40także przez innych. API może się zmieniać tylko wraz z głównym numerem
41wersji; ABI nie jest stabilne.
42
43%package devel
44Summary: Header files for libgnome-games-support library
45Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libgnome-games-support
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: glib2-devel >= 1:2.40.0
49Requires: gtk+3-devel >= 3.20.0
c8dc2358 50Requires: libgee-devel >= 0.8
444a1b2f 51Provides: libgames-support-devel = %{version}-%{release}
ee387c8a
JB
52Obsoletes: gnome-games-devel < 1:2.8.0
53Obsoletes: gnome-games-static < 1:2.8.0
444a1b2f
MB
54Obsoletes: libgames-support-devel < 1.2.0-1
55
56%description devel
57Header files for libgnome-games-support library.
58
59%description devel -l pl.UTF-8
60Pliki nagłówkowe biblioteki libgnome-games-support.
61
62%package static
63Summary: Static libgnome-games-support library
64Summary(pl.UTF-8): Statyczna biblioteka libgnome-games-support
65Group: Development/Libraries
66Requires: %{name}-devel = %{version}-%{release}
67Provides: libgames-support-static = %{version}-%{release}
68Obsoletes: libgames-support-static < 1.2.0-1
69
70%description static
71Static libgnome-games-support library.
72
73%description static -l pl.UTF-8
74Statyczna biblioteka libgnome-games-support.
75
76%package -n vala-libgnome-games-support
77Summary: Vala API for libgnome-games-support library
78Summary(pl.UTF-8): API języka Vala do bibliotek libgnome-games-support
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81Provides: vala-libgames-support = %{version}-%{release}
82Obsoletes: vala-libgames-support < 1.2.0-1
83%if "%{_rpmversion}" >= "5"
84BuildArch: noarch
85%endif
86
87%description -n vala-libgnome-games-support
88Vala API for libgnome-games-support library.
89
90%description -n vala-libgnome-games-support -l pl.UTF-8
91API języka Vala do bibliotek libgnome-games-support.
92
93%prep
94%setup -q
95
96%build
97%{__libtoolize}
98%{__aclocal} -I m4
99%{__autoconf}
100%{__automake}
101%configure \
102 --disable-silent-rules \
103 %{?with_static_libs:--enable-static}
104%{__make}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
111
112%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
113
114%find_lang %{name}
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files -f %{name}.lang
123%defattr(644,root,root,755)
124%doc NEWS README
125%attr(755,root,root) %{_libdir}/libgnome-games-support-1.so.*.*.*
b70a16eb 126%attr(755,root,root) %ghost %{_libdir}/libgnome-games-support-1.so.3
444a1b2f
MB
127
128%files devel
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/libgnome-games-support-1.so
131%{_includedir}/gnome-games-support-1
132%{_pkgconfigdir}/libgnome-games-support-1.pc
133
134%if %{with static_libs}
135%files static
136%defattr(644,root,root,755)
137%{_libdir}/libgnome-games-support-1.a
138%endif
139
140%files -n vala-libgnome-games-support
141%defattr(644,root,root,755)
142%{_datadir}/vala/vapi/libgnome-games-support-1.vapi
This page took 0.427589 seconds and 4 git commands to generate.