]> git.pld-linux.org Git - packages/libgnome-games-support.git/blame - libgames-support.spec
- release 2
[packages/libgnome-games-support.git] / libgames-support.spec
CommitLineData
4c688f6c
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
c8018e9e 5Summary: Support library for GNOME games
4c688f6c 6Summary(pl.UTF-8): Biblioteka wspierająca dla gier GNOME
c8018e9e
MB
7Name: libgames-support
8Version: 0.1
ab389d4f 9Release: 2
c8018e9e
MB
10License: LGPL v3+
11Group: X11/Libraries
12Source0: http://download.gnome.org/sources/libgames-support/0.1/%{name}-%{version}.tar.xz
13# Source0-md5: 741a504dd001450473045079d63ada9c
14BuildRequires: autoconf >= 2.69
15BuildRequires: automake >= 1:1.11
16BuildRequires: glib2-devel >= 1:2.40.0
17BuildRequires: gtk+3-devel >= 3.12.0
18BuildRequires: intltool >= 0.50.2
4c688f6c 19BuildRequires: libgee-devel >= 0.8
c8018e9e
MB
20BuildRequires: libtool >= 2:2.2
21BuildRequires: pkgconfig
22BuildRequires: vala >= 2:0.24.0
23Requires: glib2 >= 1:2.40.0
24Requires: gtk+3 >= 3.12.0
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28libgames-support is a small library intended for internal use by GNOME
29Games, but it may be used by others. The API will only break with the
30major version number. The ABI is unstable.
31
4c688f6c
JB
32%description -l pl.UTF-8
33libgames-support to mała biblioteka przeznaczona do użytku
34wewnętrznego gier ze środowiska GNOME, ale może być wykorzystywana
35także przez innych. API może się zmieniać tylko wraz z głównym numerem
36wersji; ABI nie jest stabilne.
37
c8018e9e
MB
38%package devel
39Summary: Header files for libgames-support library
40Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libgames-support
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: glib2-devel >= 1:2.40.0
44Requires: gtk+3-devel >= 3.12.0
45
46%description devel
47Header files for libgames-support library.
48
49%description devel -l pl.UTF-8
50Pliki nagłówkowe biblioteki libgames-support.
51
4c688f6c
JB
52%package static
53Summary: Static libgames-support library
54Summary(pl.UTF-8): Statyczna biblioteka libgames-support
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
57
58%description static
59Static libgames-support library.
60
61%description static -l pl.UTF-8
62Statyczna biblioteka libgames-support.
63
64%package -n vala-libgames-support
65Summary: Vala API for libgames-support library
66Summary(pl.UTF-8): API języka Vala do bibliotek libgames-support
67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description -n vala-libgames-support
71Vala API for libgames-support library.
72
73%description -n vala-libgames-support -l pl.UTF-8
74API języka Vala do bibliotek libgames-support.
75
c8018e9e
MB
76%prep
77%setup -q
78
79%build
80%{__intltoolize}
81%{__libtoolize}
4c688f6c 82%{__aclocal} -I m4
c8018e9e
MB
83%{__autoconf}
84%{__automake}
4c688f6c
JB
85%configure \
86 %{?with_static_libs:--enable-static}
c8018e9e
MB
87%{__make}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92%{__make} install \
93 DESTDIR=$RPM_BUILD_ROOT
94
4c688f6c 95%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
c8018e9e
MB
96
97%find_lang %{name}
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103%postun -p /sbin/ldconfig
104
105%files -f %{name}.lang
106%defattr(644,root,root,755)
107%doc NEWS README
108%attr(755,root,root) %{_libdir}/libgames-support.so.*.*.*
109%attr(755,root,root) %ghost %{_libdir}/libgames-support.so.0
110
111%files devel
112%defattr(644,root,root,755)
113%attr(755,root,root) %{_libdir}/libgames-support.so
114%{_includedir}/gnome-games
115%{_pkgconfigdir}/libgames-support-1.0.pc
4c688f6c
JB
116
117%if %{with static_libs}
118%files static
119%defattr(644,root,root,755)
120%{_libdir}/libgames-support.a
121%endif
122
123%files -n vala-libgames-support
124%defattr(644,root,root,755)
c8018e9e 125%{_datadir}/vala/vapi/libgames-support-1.0.vapi
This page took 0.135646 seconds and 4 git commands to generate.