]> git.pld-linux.org Git - packages/libextractor.git/commitdiff
- updated to 1.6
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 14 Dec 2017 04:32:35 +0000 (05:32 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 14 Dec 2017 04:32:35 +0000 (05:32 +0100)
- updated rpm5,pl.po-update patches
- removed obsolete giflib,ffmpeg3,exiv2-types patches
- switched to tidy 5

exiv2-types.patch [deleted file]
ffmpeg3.patch [deleted file]
libextractor-giflib.patch [deleted file]
libextractor-pl.po-update.patch
libextractor-rpm5.patch
libextractor.spec

diff --git a/exiv2-types.patch b/exiv2-types.patch
deleted file mode 100644 (file)
index 788a0aa..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- libextractor-1.3/src/plugins/exiv2_extractor.cc.orig       2013-06-25 13:02:05.000000000 +0200
-+++ libextractor-1.3/src/plugins/exiv2_extractor.cc    2017-10-01 16:48:54.189104795 +0200
-@@ -180,7 +180,7 @@
-    *
-    * @return -1 on error
-    */
--  virtual long int size (void) const;
-+  virtual size_t size (void) const;
-   /**
-    * Check if file is open.
-@@ -445,7 +445,7 @@
-  *
-  * @return -1 on error
-  */
--long int 
-+size_t
- ExtractorIO::size (void) const
- {
-   return (long) ec->get_size (ec->cls);
diff --git a/ffmpeg3.patch b/ffmpeg3.patch
deleted file mode 100644 (file)
index 2f35f19..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
---- libextractor-1.3/src/plugins/thumbnailffmpeg_extractor.c~  2013-12-22 01:04:41.000000000 +0900
-+++ libextractor-1.3/src/plugins/thumbnailffmpeg_extractor.c   2016-03-31 22:37:45.139770144 +0900
-@@ -153,7 +153,7 @@
- static size_t 
- create_thumbnail (int src_width, int src_height, 
-                 int src_stride[],
--                enum PixelFormat src_pixfmt, 
-+                enum AVPixelFormat src_pixfmt, 
-                 const uint8_t * const src_data[],
-                 int dst_width, int dst_height,
-                 uint8_t **output_data, 
-@@ -189,7 +189,7 @@
-   if (NULL == 
-       (scaler_ctx =
-        sws_getContext (src_width, src_height, src_pixfmt,
--                     dst_width, dst_height, PIX_FMT_RGB24, 
-+                     dst_width, dst_height, AV_PIX_FMT_RGB24, 
-                      SWS_BILINEAR, NULL, NULL, NULL)))
-     {
- #if DEBUG
-@@ -209,7 +209,7 @@
-       return 0;
-     }
-   if (NULL == (dst_buffer =
--             av_malloc (avpicture_get_size (PIX_FMT_RGB24, dst_width, dst_height))))
-+             av_malloc (avpicture_get_size (AV_PIX_FMT_RGB24, dst_width, dst_height))))
-     {
- #if DEBUG
-       fprintf (stderr,
-@@ -220,7 +220,7 @@
-       return 0;
-     }
-   avpicture_fill ((AVPicture *) dst_frame, dst_buffer,
--                  PIX_FMT_RGB24, dst_width, dst_height);
-+                  AV_PIX_FMT_RGB24, dst_width, dst_height);
-   sws_scale (scaler_ctx,
-              src_data, 
-              src_stride,
-@@ -255,7 +255,7 @@
-     }
-   encoder_codec_ctx->width = dst_width;
-   encoder_codec_ctx->height = dst_height;
--  encoder_codec_ctx->pix_fmt = PIX_FMT_RGB24;
-+  encoder_codec_ctx->pix_fmt = AV_PIX_FMT_RGB24;
-   opts = NULL;
-   if (avcodec_open2 (encoder_codec_ctx, encoder_codec, &opts) < 0)
-     {
diff --git a/libextractor-giflib.patch b/libextractor-giflib.patch
deleted file mode 100644 (file)
index 6db2f9c..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- libextractor-1.3/src/plugins/gif_extractor.c~      2013-06-21 18:00:16.000000000 +0200
-+++ libextractor-1.3/src/plugins/gif_extractor.c       2014-11-10 08:06:50.807376620 +0100
-@@ -78,7 +78,7 @@
-   if (gif_file == NULL || gif_error != 0)
-   {
-     if (gif_file != NULL)
--      EGifCloseFile (gif_file);
-+      EGifCloseFile (gif_file, NULL);
-     return; /* not a GIF */
-   }
- #endif
-@@ -133,7 +133,7 @@
-              DGifGetExtensionNext(gif_file, &ext)) &&
-             (NULL != ext) ) ; /* keep going */
-     }
--  DGifCloseFile (gif_file);
-+  DGifCloseFile (gif_file, NULL);
- }
- /* end of gif_extractor.c */
index 90c6ca1e16e11427f28eb726682729f851a5e8cb..a9a37019ab6c0cb28da295f680e815cf308edc4e 100644 (file)
@@ -1,28 +1,28 @@
---- libextractor-1.3/po/pl.po.orig     2013-12-22 23:11:22.000000000 +0100
-+++ libextractor-1.3/po/pl.po  2013-12-26 20:33:06.570265595 +0100
+--- libextractor-1.6/po/pl.po.orig     2017-10-15 21:38:52.000000000 +0200
++++ libextractor-1.6/po/pl.po  2017-12-07 18:33:43.479681961 +0100
 @@ -5,10 +5,10 @@
  #
  msgid ""
  msgstr ""
 -"Project-Id-Version: libextractor 1.0.0-pre1\n"
-+"Project-Id-Version: libextractor 1.3\n"
++"Project-Id-Version: libextractor 1.6\n"
  "Report-Msgid-Bugs-To: libextractor@gnu.org\n"
- "POT-Creation-Date: 2013-12-22 23:11+0100\n"
+ "POT-Creation-Date: 2017-10-15 21:38+0200\n"
 -"PO-Revision-Date: 2012-12-01 15:45+0100\n"
-+"PO-Revision-Date: 2013-12-26 20:30+0100\n"
++"PO-Revision-Date: 2017-12-07 15:45+0100\n"
  "Last-Translator: Jakub Bogusz <qboosh@pld-linux.org>\n"
  "Language-Team: Polish <translation-team-pl@lists.sourceforge.net>\n"
  "Language: pl\n"
 @@ -129,9 +129,8 @@
  msgstr "Opcja --help pozwala uzyskać listę opcji.\n"
  
- #: src/main/extract.c:964
+ #: src/main/extract.c:970
 -#, fuzzy
  msgid "% BiBTeX file\n"
 -msgstr "%% plik BiBTeX\n"
 +msgstr "% plik BiBTeX\n"
  
- #: src/main/extract.c:972
+ #: src/main/extract.c:978
  #, c-format
 @@ -1693,7 +1692,6 @@
  msgstr "numer sezonu przestawienia/serialu"
@@ -32,7 +32,7 @@
  msgid "grouping"
  msgstr "grupowanie"
  
-@@ -1854,14 +1852,12 @@
+@@ -1854,32 +1852,29 @@
  msgstr "czas trwania strumienia napisów"
  
  #: src/main/extractor_metatypes.c:551
 -msgstr "częstotliwość próbkowania ścieżki dźwiękowej"
 +msgstr "podgląd strumienia dźwięku z pliku"
  
- #: src/main/extractor_metatypes.c:554 src/main/extractor_metatypes.c:555
+ #: src/main/extractor_metatypes.c:554
+ msgid "narinfo"
+-msgstr ""
++msgstr "narinfo"
+ #: src/main/extractor_metatypes.c:555
+ msgid ""
+ "file containing information about contents of a normalized archive (nar)"
+-msgstr ""
++msgstr "plik zawierający informacje o zawartości archiwum znormalizowanego (nar)"
+ #: src/main/extractor_metatypes.c:557
+-#, fuzzy
+ msgid "nar"
+-msgstr "zarządca"
++msgstr "nar"
+ #: src/main/extractor_metatypes.c:558
+ msgid "normalized archive"
+-msgstr ""
++msgstr "archiwum znormalizowane"
+ #: src/main/extractor_metatypes.c:560 src/main/extractor_metatypes.c:561
  msgid "last"
index 545be367409658f1f69da1391d730e3f82adf449..7a892ef64a7967da6d3a9d75596696e328cb9a41 100644 (file)
@@ -20,26 +20,28 @@ index 192a838..4ddd127 100644
  
  AC_CHECK_LIB(mpeg2, mpeg2_init,
          [AC_CHECK_HEADERS([mpeg2dec/mpeg2.h],
---- libextractor-1.0.1/src/plugins/Makefile.am.orig    2012-12-01 16:30:21.501145332 +0100
-+++ libextractor-1.0.1/src/plugins/Makefile.am 2012-12-01 16:50:19.671120357 +0100
-@@ -1,6 +1,7 @@
- INCLUDES = \
+--- libextractor-1.6/src/plugins/Makefile.am.orig      2017-10-09 15:29:32.000000000 +0200
++++ libextractor-1.6/src/plugins/Makefile.am   2017-12-07 18:27:17.926353030 +0100
+@@ -1,7 +1,8 @@
+ # This Makefile.am is in the public domain
+ AM_CPPFLAGS = \
   -I$(top_srcdir)/src/include \
-- -I$(top_srcdir)/src/common 
+- -I$(top_srcdir)/src/common
 + -I$(top_srcdir)/src/common \
 + $(RPM_CFLAGS)
  
  
  # install plugins under:
---- libextractor-1.3/src/plugins/rpm_extractor.c.orig  2013-11-28 22:16:45.000000000 +0100
-+++ libextractor-1.3/src/plugins/rpm_extractor.c       2013-12-26 20:29:36.083607762 +0100
-@@ -25,9 +25,10 @@
+--- libextractor-1.6/src/plugins/rpm_extractor.c.orig  2017-10-15 20:44:15.000000000 +0200
++++ libextractor-1.6/src/plugins/rpm_extractor.c       2017-12-07 18:29:10.923018408 +0100
+@@ -25,9 +25,11 @@
  #include "platform.h"
  #include "extractor.h"
  #include <stdint.h>
 -#include <rpm/rpmlib.h>
 -#include <rpm/rpmts.h>
 -#include <rpm/rpmlog.h>
++#include <rpmutil.h>
 +#include <rpmcli.h>
 +#include <rpmio.h>
 +#include <rpmts.h>
@@ -163,13 +165,13 @@ index 192a838..4ddd127 100644
            {
              if (p->tag == RPMTAG_BUILDTIME)
                {
-                 char tmp[30];
+                 char tmp[80];
 -                uint32_t *v = rpmtdNextUint32 (p);
 +                uint32_t *v = p->p.ui32p;
                  time_t tp = (time_t) *v;
  
-                 ctime_r (&tp, tmp);
-@@ -371,7 +405,7 @@ EXTRACTOR_rpm_extract_method (struct EXT
+                   if (NULL == ctime_r (&tp, tmp))
+@@ -374,7 +408,7 @@ EXTRACTOR_rpm_extract_method (struct EXT
              else
                {
                  char tmp[14];
@@ -178,7 +180,7 @@ index 192a838..4ddd127 100644
  
                  snprintf (tmp,
                            sizeof (tmp),
-@@ -398,7 +432,6 @@ EXTRACTOR_rpm_extract_method (struct EXT
+@@ -401,7 +435,6 @@ EXTRACTOR_rpm_extract_method (struct EXT
          }
        }
   CLEANUP:
index b0ef748f12ad1a2005769966cd04e7da70877bb2..eebc952bb632f77a70137998f72275fb5642a844 100644 (file)
@@ -9,23 +9,21 @@
 Summary:       Meta-data extraction library
 Summary(pl.UTF-8):     Biblioteka do ekstrakcji metadanych
 Name:          libextractor
-Version:       1.3
-Release:       11
+Version:       1.6
+Release:       1
 License:       GPL v3+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/libextractor/%{name}-%{version}.tar.gz
-# Source0-md5: 35b8913dbebafe583a2781bf71509c48
+# Source0-md5: cbadbfa6051ee54837299ee81732a0eb
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-rpm5.patch
 Patch2:                %{name}-pl.po-update.patch
-Patch3:                %{name}-giflib.patch
-Patch4:                ffmpeg3.patch
-Patch5:                exiv2-types.patch
 URL:           http://www.gnu.org/software/libextractor/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake >= 1:1.11
 BuildRequires: bzip2-devel
 BuildRequires: exiv2-devel
+BuildRequires: gdk-pixbuf2-devel >= 2.4
 BuildRequires: gettext-tools >= 0.16.1
 # libavformat libavcodec libavutil libswscale
 BuildRequires: ffmpeg-devel
@@ -37,6 +35,7 @@ BuildRequires:        gstreamer-devel >= 0.11.93
 BuildRequires: gstreamer-plugins-base >= 0.11.93
 %endif
 BuildRequires: gtk+3-devel >= 3.0.0
+BuildRequires: libapparmor-devel
 BuildRequires: libarchive-devel
 BuildRequires: libgsf-devel
 BuildRequires: libjpeg-devel
@@ -54,7 +53,7 @@ BuildRequires:        pkgconfig >= 1:0.7
 BuildRequires: rpm-devel >= 4.5
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
-%{?with_tidy:BuildRequires:    tidy-devel}
+%{?with_tidy:BuildRequires:    tidy-devel >= 5}
 BuildRequires: zlib-devel
 %{?with_tests:BuildRequires:   zzuf}
 Obsoletes:     libextractor-printable
@@ -122,6 +121,7 @@ Summary:    GTK+ Thumbnail plugin for libextractor
 Summary(pl.UTF-8):     Wtyczka obsługująca miniaturki obrazów poprzez GTK+ dla biblioteki libextractor
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      gdk-pixbuf2 >= 2.4
 Obsoletes:     libextractor-thumbnail < 1.0.1
 
 %description thumbnail-gtk
@@ -137,6 +137,7 @@ Summary(pl.UTF-8):  Pliki nagłówkowe libextractor
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      bzip2-devel
+Requires:      libapparmor-devel
 Requires:      libltdl-devel
 Requires:      zlib-devel
 
@@ -165,12 +166,8 @@ Statyczna wersja bibliotek libextractor.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
 %{__rm} po/stamp-po
-%{__sed} -i -e 's,tidy/\(tidy\|buffio\)\.h,\1.h,' configure.ac src/plugins/html_extractor.c
 
 %build
 %{__gettextize}
@@ -258,6 +255,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_ogg.so
 # R: libgsf
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_ole2.so
+%attr(755,root,root) %{_libdir}/%{name}/libextractor_pdf.so
+# R: zlib
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_png.so
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_ps.so
 %attr(755,root,root) %{_libdir}/%{name}/libextractor_riff.so
This page took 0.204569 seconds and 4 git commands to generate.