]> git.pld-linux.org Git - packages/libextractor.git/commitdiff
- fix building with ffmpeg 3 auto/th/libextractor-1.3-8
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 31 Mar 2016 13:40:53 +0000 (22:40 +0900)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 31 Mar 2016 13:40:53 +0000 (22:40 +0900)
- rel 8

ffmpeg3.patch [new file with mode: 0644]
libextractor.spec

diff --git a/ffmpeg3.patch b/ffmpeg3.patch
new file mode 100644 (file)
index 0000000..2f35f19
--- /dev/null
@@ -0,0 +1,47 @@
+--- libextractor-1.3/src/plugins/thumbnailffmpeg_extractor.c~  2013-12-22 01:04:41.000000000 +0900
++++ libextractor-1.3/src/plugins/thumbnailffmpeg_extractor.c   2016-03-31 22:37:45.139770144 +0900
+@@ -153,7 +153,7 @@
+ static size_t 
+ create_thumbnail (int src_width, int src_height, 
+                 int src_stride[],
+-                enum PixelFormat src_pixfmt, 
++                enum AVPixelFormat src_pixfmt, 
+                 const uint8_t * const src_data[],
+                 int dst_width, int dst_height,
+                 uint8_t **output_data, 
+@@ -189,7 +189,7 @@
+   if (NULL == 
+       (scaler_ctx =
+        sws_getContext (src_width, src_height, src_pixfmt,
+-                     dst_width, dst_height, PIX_FMT_RGB24, 
++                     dst_width, dst_height, AV_PIX_FMT_RGB24, 
+                      SWS_BILINEAR, NULL, NULL, NULL)))
+     {
+ #if DEBUG
+@@ -209,7 +209,7 @@
+       return 0;
+     }
+   if (NULL == (dst_buffer =
+-             av_malloc (avpicture_get_size (PIX_FMT_RGB24, dst_width, dst_height))))
++             av_malloc (avpicture_get_size (AV_PIX_FMT_RGB24, dst_width, dst_height))))
+     {
+ #if DEBUG
+       fprintf (stderr,
+@@ -220,7 +220,7 @@
+       return 0;
+     }
+   avpicture_fill ((AVPicture *) dst_frame, dst_buffer,
+-                  PIX_FMT_RGB24, dst_width, dst_height);
++                  AV_PIX_FMT_RGB24, dst_width, dst_height);
+   sws_scale (scaler_ctx,
+              src_data, 
+              src_stride,
+@@ -255,7 +255,7 @@
+     }
+   encoder_codec_ctx->width = dst_width;
+   encoder_codec_ctx->height = dst_height;
+-  encoder_codec_ctx->pix_fmt = PIX_FMT_RGB24;
++  encoder_codec_ctx->pix_fmt = AV_PIX_FMT_RGB24;
+   opts = NULL;
+   if (avcodec_open2 (encoder_codec_ctx, encoder_codec, &opts) < 0)
+     {
index ac6f896c91f3fa529aac3cba6c06608efad71691..7bf251fa2d007575e91f24a7da48a10c8553324a 100644 (file)
@@ -10,7 +10,7 @@ Summary:      Meta-data extraction library
 Summary(pl.UTF-8):     Biblioteka do ekstrakcji metadanych
 Name:          libextractor
 Version:       1.3
-Release:       7
+Release:       8
 License:       GPL v3+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/libextractor/%{name}-%{version}.tar.gz
@@ -19,6 +19,7 @@ Patch0:               %{name}-info.patch
 Patch1:                %{name}-rpm5.patch
 Patch2:                %{name}-pl.po-update.patch
 Patch3:                %{name}-giflib.patch
+Patch4:                ffmpeg3.patch
 URL:           http://www.gnu.org/software/libextractor/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake >= 1:1.11
@@ -164,6 +165,7 @@ Statyczna wersja bibliotek libextractor.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %{__rm} po/stamp-po
 %{__sed} -i -e 's,tidy/\(tidy\|buffio\)\.h,\1.h,' configure.ac src/plugins/html_extractor.c
This page took 0.129763 seconds and 4 git commands to generate.