]> git.pld-linux.org Git - packages/libextractor.git/commitdiff
- fix building with giflib 5.1 auto/th/libextractor-1.3-6
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 10 Nov 2014 07:07:50 +0000 (08:07 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 10 Nov 2014 07:07:50 +0000 (08:07 +0100)
- rel 6

libextractor-giflib.patch [new file with mode: 0644]
libextractor.spec

diff --git a/libextractor-giflib.patch b/libextractor-giflib.patch
new file mode 100644 (file)
index 0000000..6db2f9c
--- /dev/null
@@ -0,0 +1,20 @@
+--- libextractor-1.3/src/plugins/gif_extractor.c~      2013-06-21 18:00:16.000000000 +0200
++++ libextractor-1.3/src/plugins/gif_extractor.c       2014-11-10 08:06:50.807376620 +0100
+@@ -78,7 +78,7 @@
+   if (gif_file == NULL || gif_error != 0)
+   {
+     if (gif_file != NULL)
+-      EGifCloseFile (gif_file);
++      EGifCloseFile (gif_file, NULL);
+     return; /* not a GIF */
+   }
+ #endif
+@@ -133,7 +133,7 @@
+              DGifGetExtensionNext(gif_file, &ext)) &&
+             (NULL != ext) ) ; /* keep going */
+     }
+-  DGifCloseFile (gif_file);
++  DGifCloseFile (gif_file, NULL);
+ }
+ /* end of gif_extractor.c */
index 0afb2405f052d72795c0f478c21692989e4c1699..98ff8af7a1493abbb055c8e6ea9c4a4030784f5e 100644 (file)
@@ -10,7 +10,7 @@ Summary:      Meta-data extraction library
 Summary(pl.UTF-8):     Biblioteka do ekstrakcji metadanych
 Name:          libextractor
 Version:       1.3
-Release:       5
+Release:       6
 License:       GPL v3+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/libextractor/%{name}-%{version}.tar.gz
@@ -18,6 +18,7 @@ Source0:      http://ftp.gnu.org/gnu/libextractor/%{name}-%{version}.tar.gz
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-rpm5.patch
 Patch2:                %{name}-pl.po-update.patch
+Patch3:                %{name}-giflib.patch
 URL:           http://www.gnu.org/software/libextractor/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake >= 1:1.11
@@ -27,7 +28,7 @@ BuildRequires:        gettext-devel >= 0.16.1
 # libavformat libavcodec libavutil libswscale
 BuildRequires: ffmpeg-devel
 BuildRequires: flac-devel
-BuildRequires: giflib-devel
+BuildRequires: giflib-devel >= 5.1.0
 BuildRequires: glib2-devel >= 2.0.0
 %if %{with gstreamer}
 BuildRequires: gstreamer-devel >= 0.11.93
@@ -162,6 +163,7 @@ Statyczna wersja bibliotek libextractor.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %{__rm} po/stamp-po
 %{__sed} -i -e 's,tidy/\(tidy\|buffio\)\.h,\1.h,' configure.ac src/plugins/html_extractor.c
This page took 0.154672 seconds and 4 git commands to generate.