]> git.pld-linux.org Git - packages/libebml.git/commitdiff
- adjusted to 0.7.2 (by Karol Krenski <charles(at)os.pl>)
authorMichal Chruszcz <mchruszcz@gmail.com>
Sun, 7 Nov 2004 14:50:52 +0000 (14:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    libebml-makefile.patch -> 1.6

libebml-makefile.patch

index 7ed3b84b077ca3d61b9fdd96bc287d85969f8d6e..01417a4bca3ba9dfaa4c6f08c2587d811b52d3ea 100644 (file)
@@ -1,6 +1,6 @@
---- libebml/make/linux/Makefile.orig   2003-07-17 11:47:07.000000000 +0200
-+++ libebml/make/linux/Makefile        2003-09-02 15:18:20.727607600 +0200
-@@ -25,6 +25,7 @@
+--- libebml-0.7.2/make/linux/Makefile.orig     2004-07-19 18:39:13.000000000 +0200
++++ libebml0.7.2/make/linux/Makefile   2004-11-07 13:30:20.287470496 +0100
+@@ -30,6 +30,7 @@
  INSTALL_OPTS = -m 644
  INSTALL_OPTS_LIB = -m 644
  INSTALL_DIR_OPTS = -m 755
@@ -8,7 +8,7 @@
  
  # Options
  EXTENSION=.cpp
-@@ -45,7 +46,7 @@
+@@ -48,7 +49,7 @@
  LIBS=
  
  # Names
@@ -17,7 +17,7 @@
  
  # source-files
  sources:=$(wildcard ${SRC_DIR}*$(EXTENSION))
-@@ -56,8 +57,8 @@
+@@ -59,8 +60,8 @@
  # files holding dependency information; replace .cxx extension with .dep
  dependencies:=$(patsubst %$(EXTENSION),%.dep,$(sources))
  
 +# object files; replace .cxx extension with .lo
 +objects:=$(patsubst %$(EXTENSION),%.lo,$(sources))
  
- DEPENDFLAGS  = ${CXXFLAGS} ${INCLUDE}
-@@ -66,14 +67,12 @@
+ WARNINGFLAGS=-Wall -Wno-unknown-pragmas -ansi -fno-gnu-keywords -Wshadow
+ COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE)
+@@ -71,12 +72,11 @@
  lib library: $(LIBRARY)
  
  # Build rules
 -%.o: %$(EXTENSION)
--      $(CXX) -c $(CXXFLAGS) $(INCLUDE) -o $@ $<
+-      $(CXX) -c $(COMPILEFLAGS) -o $@ $<
 +%.lo: %$(EXTENSION)
 +      $(LIBTOOL) --mode=compile $(CXX) -c $(CXXFLAGS) $(INCLUDE) -o $@ $<
  
  $(LIBRARY): $(objects)
 -      $(AR) $@ $(objects)
 -      $(RANLIB) $@
--#     $(LD) $(LDFLAGS) -o $@ $^ $(LIBS)
--#     ${LD} -o $@ ${LDFLAGS} ${OBJS} ${LIBS} ${EXTRA_LIBS}
 +      $(LIBTOOL) --mode=link $(LD) $(LDFLAGS) -o $@ $^ $(LIBS) -rpath $(libdir)
-+
  
  clean:
        rm -f $(objects)
-@@ -86,15 +85,15 @@
+@@ -89,15 +89,15 @@
        $(DEPEND) $(DEPENDFLAGS) $(sources)
  
  install: $(LIBRARY)
This page took 0.182279 seconds and 4 git commands to generate.