]> git.pld-linux.org Git - packages/libebml.git/commitdiff
- updated to 1.3.6; build system has been changed to cmake
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 19 Feb 2019 19:25:41 +0000 (20:25 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 19 Feb 2019 19:25:41 +0000 (20:25 +0100)
libebml.spec

index 5f104181de1028cbc96e92f3419492c5a4673d6e..cb2056d14739c42b24c7a961e2b73587aea0c308 100644 (file)
@@ -1,13 +1,18 @@
+#
+# Conditional build:
+%bcond_without static_libs     # static library
+
 Summary:       Extensible Binary Meta Language access library
 Summary(pl.UTF-8):     Biblioteka dostępu rozszerzalnego metajęzyka binarnego
 Name:          libebml
 Summary:       Extensible Binary Meta Language access library
 Summary(pl.UTF-8):     Biblioteka dostępu rozszerzalnego metajęzyka binarnego
 Name:          libebml
-Version:       1.3.5
-Release:       2
+Version:       1.3.6
+Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       https://dl.matroska.org/downloads/libebml/%{name}-%{version}.tar.xz
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       https://dl.matroska.org/downloads/libebml/%{name}-%{version}.tar.xz
-# Source0-md5: f1e8c8e4664abb9f51483ff95019eeed
+# Source0-md5: 3e2bc574bb22582c724ab659652fe0db
 URL:           https://www.matroska.org/
 URL:           https://www.matroska.org/
+BuildRequires: cmake >= 3.1.2
 BuildRequires: libstdc++-devel
 BuildRequires: rpmbuild(macros) >= 1.553
 BuildRequires: xz
 BuildRequires: libstdc++-devel
 BuildRequires: rpmbuild(macros) >= 1.553
 BuildRequires: xz
@@ -52,14 +57,35 @@ Statyczna wersja biblioteki rozszerzalnego metajęzyka binarnego.
 %setup -q
 
 %build
 %setup -q
 
 %build
-%configure
+# .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
+%if %{with static_libs}
+install -d build-static
+cd build-static
+%cmake .. \
+       -DBUILD_SHARED_LIBS:BOOL=OFF \
+       -DCMAKE_INSTALL_INCLUDEDIR=include \
+       -DCMAKE_INSTALL_LIBDIR=%{_lib}
+%{__make}
+cd ..
+%endif
+
+install -d build
+cd build
+%cmake .. \
+       -DCMAKE_INSTALL_INCLUDEDIR=include \
+       -DCMAKE_INSTALL_LIBDIR=%{_lib}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%if %{with static_libs}
+%{__make} -C build-static install \
+       DESTDIR=$RPM_BUILD_ROOT
+%endif
+
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %clean
        DESTDIR=$RPM_BUILD_ROOT
 
 %clean
@@ -70,17 +96,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog
+%doc ChangeLog README.md
 %attr(755,root,root) %{_libdir}/libebml.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libebml.so.4
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libebml.so
 %attr(755,root,root) %{_libdir}/libebml.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libebml.so.4
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libebml.so
-%{_libdir}/libebml.la
 %{_includedir}/ebml
 %{_pkgconfigdir}/libebml.pc
 %{_includedir}/ebml
 %{_pkgconfigdir}/libebml.pc
+%{_libdir}/cmake/ebml
 
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libebml.a
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libebml.a
+%endif
This page took 0.081906 seconds and 4 git commands to generate.