]> git.pld-linux.org Git - packages/libebml.git/commitdiff
- updated to version 0.6.0
authorgrzegol <grzegol@pld-linux.org>
Tue, 30 Sep 2003 18:03:26 +0000 (18:03 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    libebml-makefile.patch -> 1.5

libebml-makefile.patch

index 17253b996009ac352b919d3e218dd724db7ae3bc..7ed3b84b077ca3d61b9fdd96bc287d85969f8d6e 100644 (file)
@@ -1,71 +1,71 @@
 --- libebml/make/linux/Makefile.orig   2003-07-17 11:47:07.000000000 +0200
 +++ libebml/make/linux/Makefile        2003-09-02 15:18:20.727607600 +0200
 @@ -25,6 +25,7 @@
- INSTALL_OPTS = -m 644\r
- INSTALL_OPTS_LIB = -m 644\r
- INSTALL_DIR_OPTS = -m 755\r
-+LIBTOOL = libtool\r
\r
- # Options\r
- EXTENSION=.cpp\r
+ INSTALL_OPTS = -m 644
+ INSTALL_OPTS_LIB = -m 644
+ INSTALL_DIR_OPTS = -m 755
++LIBTOOL = libtool
+ # Options
+ EXTENSION=.cpp
 @@ -45,7 +46,7 @@
- LIBS=\r
\r
- # Names\r
--LIBRARY=libebml.a\r
-+LIBRARY=libebml.la\r
\r
- # source-files\r
- sources:=$(wildcard ${SRC_DIR}*$(EXTENSION))\r
+ LIBS=
+ # Names
+-LIBRARY=libebml.a
++LIBRARY=libebml.la
+ # source-files
+ sources:=$(wildcard ${SRC_DIR}*$(EXTENSION))
 @@ -56,8 +57,8 @@
- # files holding dependency information; replace .cxx extension with .dep\r
- dependencies:=$(patsubst %$(EXTENSION),%.dep,$(sources))\r
\r
--# object files; replace .cxx extension with .o\r
--objects:=$(patsubst %$(EXTENSION),%.o,$(sources))\r
-+# object files; replace .cxx extension with .lo\r
-+objects:=$(patsubst %$(EXTENSION),%.lo,$(sources))\r
\r
- DEPENDFLAGS  = ${CXXFLAGS} ${INCLUDE}\r
\r
+ # files holding dependency information; replace .cxx extension with .dep
+ dependencies:=$(patsubst %$(EXTENSION),%.dep,$(sources))
+-# object files; replace .cxx extension with .o
+-objects:=$(patsubst %$(EXTENSION),%.o,$(sources))
++# object files; replace .cxx extension with .lo
++objects:=$(patsubst %$(EXTENSION),%.lo,$(sources))
+ DEPENDFLAGS  = ${CXXFLAGS} ${INCLUDE}
 @@ -66,14 +67,12 @@
- lib library: $(LIBRARY)\r
\r
- # Build rules\r
--%.o: %$(EXTENSION)\r
--      $(CXX) -c $(CXXFLAGS) $(INCLUDE) -o $@ $<\r
-+%.lo: %$(EXTENSION)\r
-+      $(LIBTOOL) --mode=compile $(CXX) -c $(CXXFLAGS) $(INCLUDE) -o $@ $<\r
\r
- $(LIBRARY): $(objects)\r
--      $(AR) $@ $(objects)\r
--      $(RANLIB) $@\r
--#     $(LD) $(LDFLAGS) -o $@ $^ $(LIBS)\r
--#     ${LD} -o $@ ${LDFLAGS} ${OBJS} ${LIBS} ${EXTRA_LIBS}\r
-+      $(LIBTOOL) --mode=link $(LD) $(LDFLAGS) -o $@ $^ $(LIBS) -rpath $(libdir)\r
-+\r
\r
- clean:\r
-       rm -f $(objects)\r
+ lib library: $(LIBRARY)
+ # Build rules
+-%.o: %$(EXTENSION)
+-      $(CXX) -c $(CXXFLAGS) $(INCLUDE) -o $@ $<
++%.lo: %$(EXTENSION)
++      $(LIBTOOL) --mode=compile $(CXX) -c $(CXXFLAGS) $(INCLUDE) -o $@ $<
+ $(LIBRARY): $(objects)
+-      $(AR) $@ $(objects)
+-      $(RANLIB) $@
+-#     $(LD) $(LDFLAGS) -o $@ $^ $(LIBS)
+-#     ${LD} -o $@ ${LDFLAGS} ${OBJS} ${LIBS} ${EXTRA_LIBS}
++      $(LIBTOOL) --mode=link $(LD) $(LDFLAGS) -o $@ $^ $(LIBS) -rpath $(libdir)
++
+ clean:
+       rm -f $(objects)
 @@ -86,15 +85,15 @@
-       $(DEPEND) $(DEPENDFLAGS) $(sources)\r
\r
- install: $(LIBRARY)\r
--      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(libdir)\r
--      $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(libdir)\r
--      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)\r
-+      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)\r
-+      $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(DESTDIR)$(libdir)\r
-+      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(includedir)\r
-       for i in $(INCLUDE_DIR)/*.h; do \\r
--              $(INSTALL) $(INSTALL_OPTS) $$i $(includedir) ; \\r
-+              $(INSTALL) $(INSTALL_OPTS) $$i $(DESTDIR)$(includedir) ; \\r
-       done\r
--      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)/c\r
-+      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(includedir)/c\r
-       for i in $(INCLUDE_DIR)/c/*.h; do \\r
--              $(INSTALL) $(INSTALL_OPTS) $$i $(includedir)/c ; \\r
-+              $(INSTALL) $(INSTALL_OPTS) $$i $(DESTDIR)$(includedir)/c ; \\r
-       done\r
\r
- # DO NOT DELETE\r
+       $(DEPEND) $(DEPENDFLAGS) $(sources)
+ install: $(LIBRARY)
+-      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(libdir)
+-      $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(libdir)
+-      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)
++      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
++      $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(DESTDIR)$(libdir)
++      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(includedir)
+       for i in $(INCLUDE_DIR)/*.h; do \
+-              $(INSTALL) $(INSTALL_OPTS) $$i $(includedir) ; \
++              $(INSTALL) $(INSTALL_OPTS) $$i $(DESTDIR)$(includedir) ; \
+       done
+-      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)/c
++      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(includedir)/c
+       for i in $(INCLUDE_DIR)/c/*.h; do \
+-              $(INSTALL) $(INSTALL_OPTS) $$i $(includedir)/c ; \
++              $(INSTALL) $(INSTALL_OPTS) $$i $(DESTDIR)$(includedir)/c ; \
+       done
+ # DO NOT DELETE
This page took 0.163251 seconds and 4 git commands to generate.