]> git.pld-linux.org Git - packages/libebml.git/blobdiff - libebml-makefile.patch
- up to 1.0.0, new soname
[packages/libebml.git] / libebml-makefile.patch
index d359127fca769c5df1fc6c0aa56cab8137c85c51..c3cb04484163421671966224327b73ae4cceafee 100644 (file)
@@ -1,5 +1,5 @@
---- libebml-0.7.5/make/linux/Makefile.orig     2005-04-19 08:56:06.000000000 +0200
-+++ libebml-0.7.5/make/linux/Makefile  2005-06-12 20:47:04.374324344 +0200
+--- libebml-1.0.0/make/linux/Makefile~ 2010-08-05 23:04:21.000000000 +0300
++++ libebml-1.0.0/make/linux/Makefile  2010-08-05 23:04:54.438670198 +0300
 @@ -28,6 +28,7 @@
  INSTALL_OPTS = -m 644
  INSTALL_OPTS_LIB = -m 644
@@ -14,7 +14,7 @@
  # Names
 -LIBRARY=libebml.a
 -LIBRARY_SO=libebml.so
--LIBRARY_SO_VER=libebml.so.0
+-LIBRARY_SO_VER=libebml.so.2
 +LIBRARY=libebml.la
  
  # source-files
@@ -31,7 +31,7 @@
  
  WARNINGFLAGS=-Wall -Wno-unknown-pragmas -ansi -fno-gnu-keywords -Wshadow
  COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE)
-@@ -83,19 +81,11 @@
+@@ -78,20 +78,11 @@
        @false
  
  # Build rules
 -
  %.lo: %$(EXTENSION)
 -      $(CXX) -c $(COMPILEFLAGS) -fPIC -o $@ $<
-+      $(LIBTOOL) --mode=compile $(CXX) -c $(COMPILEFLAGS) -o $@ $<
++      $(LIBTOOL) --mode=compile --tag=CC $(CXX) -c $(COMPILEFLAGS) -o $@ $<
  
  $(LIBRARY): $(objects)
--      $(AR) $@ $(objects)
+-      $(AR) rcvu $@ $(objects)
 -      $(RANLIB) $@
 -
 -$(LIBRARY_SO): $(objects_so)
 -      $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so)
+-      rm -f $(LIBRARY_SO)
 -      ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
-+      $(LIBTOOL) --mode=link $(LD) $(LDFLAGS) -o $@ $^ $(LIBS) -rpath $(libdir)
++      $(LIBTOOL) --mode=link --tag=CC $(LD) $(LDFLAGS) -version-info 2:0:0 -o $@ $^ $(LIBS) -rpath $(libdir)
  
  clean:
        rm -f $(objects) $(objects_so)
-@@ -120,26 +110,22 @@
+@@ -121,27 +110,22 @@
  ifeq (Darwin,$(shell uname -s))
  install: install_staticlib install_headers
  else
@@ -80,8 +81,9 @@
 -      $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(libdir)
 -
 -install_sharedlib: $(LIBRARY_SO)
+-      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(libdir)
 -      $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY_SO_VER) $(libdir)
--      ln -s $(LIBRARY_SO_VER) $(libdir)/$(LIBRARY_SO)
+-      ln -fs $(LIBRARY_SO_VER) $(libdir)/$(LIBRARY_SO)
 +install_lib: $(LIBRARY)
 +      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
 +      $(LIBTOOL) --mode=install $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(DESTDIR)$(libdir)
This page took 0.06202 seconds and 4 git commands to generate.