]> git.pld-linux.org Git - packages/libebml.git/blobdiff - libebml-makefile.patch
- updated to 1.3.0 (note: new soname)
[packages/libebml.git] / libebml-makefile.patch
index cc28d29affddd2f465562372462f3126a6b4729b..5c2f12f479cb21f4b787f7dc5118f754f2d254cc 100644 (file)
@@ -1,6 +1,6 @@
---- libebml-0.7.4/make/linux/Makefile.orig     2005-04-16 13:19:57.000000000 +0200
-+++ libebml-0.7.4/make/linux/Makefile  2005-04-24 01:00:00.947584792 +0200
-@@ -28,6 +28,7 @@
+--- libebml-1.3.0/make/linux/Makefile.orig     2013-03-22 22:37:42.558227596 +0100
++++ libebml-1.3.0/make/linux/Makefile  2013-03-22 22:38:41.438225125 +0100
+@@ -29,6 +29,7 @@
  INSTALL_OPTS = -m 644
  INSTALL_OPTS_LIB = -m 644
  INSTALL_DIR_OPTS = -m 755
@@ -8,18 +8,18 @@
  
  # Options
  EXTENSION=.cpp
-@@ -50,9 +51,7 @@
+@@ -47,9 +48,7 @@
  LIBS=
  
  # Names
 -LIBRARY=libebml.a
 -LIBRARY_SO=libebml.so
--LIBRARY_SO_VER=libebml.so.0
+-LIBRARY_SO_VER=libebml.so.4
 +LIBRARY=libebml.la
  
  # source-files
  sources:=$(wildcard ${SRC_DIR}*$(EXTENSION))
-@@ -60,9 +59,8 @@
+@@ -57,9 +56,8 @@
  # header files; replace .cxx extension with .h
  headers:=$(patsubst %$(EXTENSION),%.h,$(sources))
  
@@ -29,9 +29,9 @@
 +# object files; replace .cxx extension with .lo
 +objects:=$(patsubst %$(EXTENSION),%.lo,$(sources))
  
- WARNINGFLAGS=-Wall -Wno-unknown-pragmas -ansi -fno-gnu-keywords -Wshadow
+ WARNINGFLAGS=-Wall -Wextra -Wno-unknown-pragmas -ansi -fno-gnu-keywords -Wshadow
  COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE)
-@@ -79,19 +77,11 @@
+@@ -80,20 +78,11 @@
        @false
  
  # Build rules
 -
  %.lo: %$(EXTENSION)
 -      $(CXX) -c $(COMPILEFLAGS) -fPIC -o $@ $<
-+      $(LIBTOOL) --mode=compile $(CXX) -c $(COMPILEFLAGS) -o $@ $<
++      $(LIBTOOL) --mode=compile --tag=CXX $(CXX) -c $(COMPILEFLAGS) -o $@ $<
  
  $(LIBRARY): $(objects)
--      $(AR) $@ $(objects)
+-      $(AR) rcvu $@ $(objects)
 -      $(RANLIB) $@
 -
 -$(LIBRARY_SO): $(objects_so)
 -      $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so)
+-      rm -f $(LIBRARY_SO)
 -      ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
-+      $(LIBTOOL) --mode=link $(LD) $(LDFLAGS) -o $@ $^ $(LIBS) -rpath $(libdir)
++      $(LIBTOOL) --mode=link --tag=CXX $(LD) $(LDFLAGS) -version-info 4:0:0 -o $@ $^ $(LIBS) -rpath $(libdir)
  
  clean:
        rm -f $(objects) $(objects_so)
-@@ -113,26 +103,21 @@
-               $(CXX) $(DEPENDFLAGS) -MM -MT $$o $$i >> .depend ; \
-       done
+@@ -118,27 +107,22 @@
+ ifeq (Darwin,$(shell uname -s))
+ install: install_staticlib install_headers
+ else
 -install: install_staticlib install_sharedlib install_headers
 +install: install_lib install_headers
+ endif
  
  install_headers:
 -      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)
 -      $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(libdir)
 -
 -install_sharedlib: $(LIBRARY_SO)
+-      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(libdir)
 -      $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY_SO_VER) $(libdir)
--      ln -s $(LIBRARY_SO_VER) $(libdir)/$(LIBRARY_SO)
--
+-      ln -fs $(LIBRARY_SO_VER) $(libdir)/$(LIBRARY_SO)
 +install_lib: $(LIBRARY)
 +      $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
-+      $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(DESTDIR)$(libdir)
++      $(LIBTOOL) --mode=install $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(DESTDIR)$(libdir)
  
  ifneq ($(wildcard .depend),)
- include .depend
This page took 0.086497 seconds and 4 git commands to generate.