]> git.pld-linux.org Git - packages/libebml.git/blob - libebml.spec
up to 1.4.5
[packages/libebml.git] / libebml.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Extensible Binary Meta Language access library
6 Summary(pl.UTF-8):      Biblioteka dostępu rozszerzalnego metajęzyka binarnego
7 Name:           libebml
8 Version:        1.4.5
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        https://dl.matroska.org/downloads/libebml/%{name}-%{version}.tar.xz
13 # Source0-md5:  2b6c3c60e0eb54f0156561052ebfba2f
14 URL:            https://www.matroska.org/
15 BuildRequires:  cmake >= 3.1.2
16 BuildRequires:  libstdc++-devel >= 6:5
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRequires:  tar >= 1:1.22
19 BuildRequires:  xz
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Extensible Binary Meta Language access library is a library for
24 reading and writing files with the Extensible Binary Meta Language, a
25 binary pendant to XML.
26
27 %description -l pl.UTF-8
28 Biblioteka rozszerzalnego metajęzyka binarnego (Extensible Binary Meta
29 Language, w skrócie EBML) umożliwia czytanie i zapisywanie plików w
30 tym metajęzyku, będącym binarnym uzupełnieniem XML-a.
31
32 %package devel
33 Summary:        Header files for Extensible Binary Meta Language library
34 Summary(pl.UTF-8):      Nagłówki biblioteki rozszerzalnego metajęzyka binarnego
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel >= 6:4.7
38
39 %description devel
40 Header files for Extensible Binary Meta Language library.
41
42 %description devel -l pl.UTF-8
43 Nagłówki biblioteki rozszerzalnego metajęzyka binarnego.
44
45 %package static
46 Summary:        Static version of Extensible Binary Meta Language library
47 Summary(pl.UTF-8):      Statyczna wersja biblioteki rozszerzalnego metajęzyka binarnego
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static version of Extensible Binary Meta Language library.
53
54 %description static -l pl.UTF-8
55 Statyczna wersja biblioteki rozszerzalnego metajęzyka binarnego.
56
57 %prep
58 %setup -q
59
60 %build
61 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
62 %if %{with static_libs}
63 install -d build-static
64 cd build-static
65 %cmake .. \
66         -DBUILD_SHARED_LIBS:BOOL=OFF \
67         -DCMAKE_INSTALL_INCLUDEDIR=include \
68         -DCMAKE_INSTALL_LIBDIR=%{_lib}
69
70 %{__make}
71 cd ..
72 %endif
73
74 install -d build
75 cd build
76 %cmake .. \
77         -DCMAKE_INSTALL_INCLUDEDIR=include \
78         -DCMAKE_INSTALL_LIBDIR=%{_lib}
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %if %{with static_libs}
86 %{__make} -C build-static install \
87         DESTDIR=$RPM_BUILD_ROOT
88 %endif
89
90 %{__make} -C build install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc NEWS.md README.md
102 %attr(755,root,root) %{_libdir}/libebml.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libebml.so.5
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libebml.so
108 %{_includedir}/ebml
109 %{_pkgconfigdir}/libebml.pc
110 %{_libdir}/cmake/EBML
111
112 %if %{with static_libs}
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libebml.a
116 %endif
This page took 0.107556 seconds and 4 git commands to generate.