]> git.pld-linux.org Git - packages/libebml.git/blob - libebml.spec
up to 1.4.1
[packages/libebml.git] / libebml.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Extensible Binary Meta Language access library
6 Summary(pl.UTF-8):      Biblioteka dostępu rozszerzalnego metajęzyka binarnego
7 Name:           libebml
8 Version:        1.4.1
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        https://dl.matroska.org/downloads/libebml/%{name}-%{version}.tar.xz
13 # Source0-md5:  f4794019c85f61443757ac639cd4a7f5
14 URL:            https://www.matroska.org/
15 BuildRequires:  cmake >= 3.1.2
16 BuildRequires:  libstdc++-devel >= 6:4.7
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRequires:  xz
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Extensible Binary Meta Language access library is a library for
23 reading and writing files with the Extensible Binary Meta Language, a
24 binary pendant to XML.
25
26 %description -l pl.UTF-8
27 Biblioteka rozszerzalnego metajęzyka binarnego (Extensible Binary Meta
28 Language, w skrócie EBML) umożliwia czytanie i zapisywanie plików w
29 tym metajęzyku, będącym binarnym uzupełnieniem XML-a.
30
31 %package devel
32 Summary:        Header files for Extensible Binary Meta Language library
33 Summary(pl.UTF-8):      Nagłówki biblioteki rozszerzalnego metajęzyka binarnego
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       libstdc++-devel >= 6:4.7
37
38 %description devel
39 Header files for Extensible Binary Meta Language library.
40
41 %description devel -l pl.UTF-8
42 Nagłówki biblioteki rozszerzalnego metajęzyka binarnego.
43
44 %package static
45 Summary:        Static version of Extensible Binary Meta Language library
46 Summary(pl.UTF-8):      Statyczna wersja biblioteki rozszerzalnego metajęzyka binarnego
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static version of Extensible Binary Meta Language library.
52
53 %description static -l pl.UTF-8
54 Statyczna wersja biblioteki rozszerzalnego metajęzyka binarnego.
55
56 %prep
57 %setup -q
58
59 %build
60 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
61 %if %{with static_libs}
62 install -d build-static
63 cd build-static
64 %cmake .. \
65         -DBUILD_SHARED_LIBS:BOOL=OFF \
66         -DCMAKE_INSTALL_INCLUDEDIR=include \
67         -DCMAKE_INSTALL_LIBDIR=%{_lib}
68
69 %{__make}
70 cd ..
71 %endif
72
73 install -d build
74 cd build
75 %cmake .. \
76         -DCMAKE_INSTALL_INCLUDEDIR=include \
77         -DCMAKE_INSTALL_LIBDIR=%{_lib}
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %if %{with static_libs}
85 %{__make} -C build-static install \
86         DESTDIR=$RPM_BUILD_ROOT
87 %endif
88
89 %{__make} -C build install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc ChangeLog README.md
101 %attr(755,root,root) %{_libdir}/libebml.so.*.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libebml.so.5
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libebml.so
107 %{_includedir}/ebml
108 %{_pkgconfigdir}/libebml.pc
109 %{_libdir}/cmake/EBML
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libebml.a
115 %endif
This page took 0.031619 seconds and 3 git commands to generate.