]> git.pld-linux.org Git - packages/libdom.git/commitdiff
pass our CC, cleanup, fix bad copy-paste
authorElan Ruusamäe <glen@delfi.ee>
Sat, 27 Apr 2013 14:08:08 +0000 (17:08 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 27 Apr 2013 14:08:08 +0000 (17:08 +0300)
libdom.spec

index d0a8ef30904c9212d80d12445f73d971538660db..5754a1e306f8fefdec7ba09f7ad3a817ead53022 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Conditional build:
 %bcond_without static_libs     # don't build static library
-#
+
 Summary:       Implementation of W3C DOM
 Name:          libdom
 Version:       0.0.1
@@ -53,33 +53,32 @@ Statyczna biblioteka libdom.
 %setup -q
 
 %build
-CFLAGS="%{rpmcflags}"
-LDFLAGS="%{rpmldflags}"
-export CFLAGS
-export LDFLAGS
+export CC="%{__cc}"
+export CFLAGS="%{rpmcflags}"
+export LDFLAGS="%{rpmldflags}"
+
+%{__make} Q= \
+       PREFIX=%{_prefix} \
+       COMPONENT_TYPE=lib-shared
 
-%{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
-       -Iinclude -Isrc"
 %if %{with static_libs}
-%{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
-       -Iinclude -Isrc"
+%{__make} Q= \
+       PREFIX=%{_prefix} \
+       COMPONENT_TYPE=lib-static
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
+%{__make} install Q= \
        PREFIX=%{_prefix} \
        COMPONENT_TYPE=lib-shared \
-       Q=''
+       DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with static_libs}
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
+%{__make} install Q= \
        PREFIX=%{_prefix} \
        COMPONENT_TYPE=lib-static \
-       Q=''
+       DESTDIR=$RPM_BUILD_ROOT
 %endif
 
 %clean
This page took 0.076663 seconds and 4 git commands to generate.