]> git.pld-linux.org Git - packages/libdom.git/blob - libdom.spec
- pl
[packages/libdom.git] / libdom.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of W3C DOM
6 Summary(pl.UTF-8):      Implementacja W3C DOM
7 Name:           libdom
8 Version:        0.1.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  055878cf633a935031517e2e209062f6
14 URL:            http://www.netsurf-browser.org/projects/libdom/
15 BuildRequires:  expat-devel >= 1.95
16 BuildRequires:  libhubbub-devel >= 0.3.0
17 BuildRequires:  libparserutils-devel >= 0.2.0
18 BuildRequires:  libwapcaplet-devel >= 0.2.1
19 BuildRequires:  libxml2-devel >= 2.0
20 BuildRequires:  netsurf-buildsystem >= 1.1
21 BuildRequires:  pkgconfig
22 Requires:       libparserutils >= 0.2.0
23 Requires:       libwapcaplet >= 0.2.1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 LibDOM is an implementation of the W3C DOM, written in C. It is
28 currently in development for use with NetSurf and is intended to be
29 suitable for use in other projects too.
30
31 %description -l pl.UTF-8
32 LibDOM to implementacja W3C DOM, napisana w C. Jest rozwijana do
33 wykorzystania w ramach projektu NetSurf, ale także z myślą o
34 możliwości użycia w innych projektach.
35
36 %package devel
37 Summary:        libdom library headers
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libdom
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       expat-devel
42 Requires:       libhubbub-devel >= 0.3.0
43
44 %description devel
45 This package contains the include files and other resources you can
46 use to incorporate libdom into applications.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
50 programach.
51
52 %package static
53 Summary:        libdom static library
54 Summary(pl.UTF-8):      Statyczna biblioteka libdom
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 This is package with static libdom library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libdom.
63
64 %prep
65 %setup -q
66
67 %build
68 export CC="%{__cc}"
69 export CFLAGS="%{rpmcflags}"
70 export LDFLAGS="%{rpmldflags}"
71
72 %{__make} \
73         Q= \
74         PREFIX=%{_prefix} \
75         LIBDIR=%{_lib} \
76         COMPONENT_TYPE=lib-shared
77
78 %if %{with static_libs}
79 %{__make} \
80         Q= \
81         PREFIX=%{_prefix} \
82         LIBDIR=%{_lib} \
83         COMPONENT_TYPE=lib-static
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} install \
89         Q= \
90         PREFIX=%{_prefix} \
91         LIBDIR=%{_lib} \
92         COMPONENT_TYPE=lib-shared \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %if %{with static_libs}
96 %{__make} install \
97         Q= \
98         PREFIX=%{_prefix} \
99         LIBDIR=%{_lib} \
100         COMPONENT_TYPE=lib-static \
101         DESTDIR=$RPM_BUILD_ROOT
102 %endif
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc COPYING README
113 %attr(755,root,root) %{_libdir}/libdom.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libdom.so.0
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libdom.so
119 %{_includedir}/dom
120 %{_pkgconfigdir}/libdom.pc
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libdom.a
126 %endif
This page took 0.098569 seconds and 3 git commands to generate.