]> git.pld-linux.org Git - packages/libdom.git/blob - libdom.spec
e7d3a16405adb9c48ea24e9d6dec29ed416b0700
[packages/libdom.git] / libdom.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of W3C DOM
6 Name:           libdom
7 Version:        0.0.1
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  dea386cfe4fc65b79a1815b0515fc688
13 Patch0:         lib.patch
14 URL:            http://www.netsurf-browser.org/projects/libdom/
15 BuildRequires:  libhubbub-devel >= 0.2.0
16 BuildRequires:  libparserutils-devel >= 0.1.2
17 BuildRequires:  libwapcaplet-devel >= 0.2.0
18 BuildRequires:  libxml2-devel
19 BuildRequires:  netsurf-buildsystem
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 LibDOM is an implementation of the W3C DOM, written in C. It is
24 currently in development for use with NetSurf and is intended to be
25 suitable for use in other projects too.
26
27 %package devel
28 Summary:        libdom library headers
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libdom
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 This is the libraries, include files and other resources you can use
35 to incorporate libdom into applications.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
39 programach.
40
41 %package static
42 Summary:        libdom static libraries
43 Summary(pl.UTF-8):      Statyczne biblioteki libdom
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 This is package with static libdom libraries.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka libdom.
52
53 %prep
54 %setup -q
55 %patch0 -p1
56
57 %build
58 export CC="%{__cc}"
59 export CFLAGS="%{rpmcflags}"
60 export LDFLAGS="%{rpmldflags}"
61
62 %{__make} Q= \
63         PREFIX=%{_prefix} \
64         COMPONENT_TYPE=lib-shared
65
66 %if %{with static_libs}
67 %{__make} Q= \
68         PREFIX=%{_prefix} \
69         COMPONENT_TYPE=lib-static
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install Q= \
75         lib=%{_lib} \
76         PREFIX=%{_prefix} \
77         COMPONENT_TYPE=lib-shared \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %if %{with static_libs}
81 %{__make} install Q= \
82         lib=%{_lib} \
83         PREFIX=%{_prefix} \
84         COMPONENT_TYPE=lib-static \
85         DESTDIR=$RPM_BUILD_ROOT
86 %endif
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/lib*.so
101 %{_includedir}/dom
102 %{_pkgconfigdir}/*pc
103
104 %if %{with static_libs}
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/lib*.a
108 %endif
This page took 0.057697 seconds and 2 git commands to generate.