]> git.pld-linux.org Git - packages/libdom.git/blob - libdom.spec
- removed outdated no-Werror patch
[packages/libdom.git] / libdom.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of W3C DOM
6 Summary(pl.UTF-8):      Implementacja W3C DOM
7 Name:           libdom
8 Version:        0.3.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  269bd1ceb4debfc1c3e3732a26ded992
14 URL:            http://www.netsurf-browser.org/projects/libdom/
15 BuildRequires:  expat-devel >= 1.95
16 BuildRequires:  libhubbub-devel >= 0.3.3
17 BuildRequires:  libparserutils-devel >= 0.2.3
18 BuildRequires:  libwapcaplet-devel >= 0.3.0
19 BuildRequires:  libxml2-devel >= 2.0
20 BuildRequires:  netsurf-buildsystem >= 1.5
21 BuildRequires:  pkgconfig
22 Requires:       libparserutils >= 0.2.3
23 Requires:       libwapcaplet >= 0.3.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 LibDOM is an implementation of the W3C DOM, written in C. It is
28 currently in development for use with NetSurf and is intended to be
29 suitable for use in other projects too.
30
31 %description -l pl.UTF-8
32 LibDOM to implementacja W3C DOM, napisana w C. Jest rozwijana do
33 wykorzystania w ramach projektu NetSurf, ale także z myślą o
34 możliwości użycia w innych projektach.
35
36 %package devel
37 Summary:        libdom library headers
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libdom
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       expat-devel >= 1.95
42 Requires:       libhubbub-devel >= 0.3.1
43
44 %description devel
45 This package contains the include files and other resources you can
46 use to incorporate libdom into applications.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
50 programach.
51
52 %package static
53 Summary:        libdom static library
54 Summary(pl.UTF-8):      Statyczna biblioteka libdom
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 This is package with static libdom library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libdom.
63
64 %prep
65 %setup -q
66
67 %build
68 export AR="%{__ar}"
69 export CC="%{__cc}"
70 export CFLAGS="%{rpmcflags}"
71 export LDFLAGS="%{rpmldflags}"
72
73 %{__make} \
74         Q= \
75         PREFIX=%{_prefix} \
76         LIBDIR=%{_lib} \
77         COMPONENT_TYPE=lib-shared
78
79 %if %{with static_libs}
80 %{__make} \
81         Q= \
82         PREFIX=%{_prefix} \
83         LIBDIR=%{_lib} \
84         COMPONENT_TYPE=lib-static
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 export AR="%{__ar}"
91 export CC="%{__cc}"
92 export CFLAGS="%{rpmcflags}"
93 export LDFLAGS="%{rpmldflags}"
94
95 %{__make} install \
96         Q= \
97         PREFIX=%{_prefix} \
98         LIBDIR=%{_lib} \
99         COMPONENT_TYPE=lib-shared \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %if %{with static_libs}
103 %{__make} install \
104         Q= \
105         PREFIX=%{_prefix} \
106         LIBDIR=%{_lib} \
107         COMPONENT_TYPE=lib-static \
108         DESTDIR=$RPM_BUILD_ROOT
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc COPYING README
120 %attr(755,root,root) %{_libdir}/libdom.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libdom.so.0
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libdom.so
126 %{_includedir}/dom
127 %{_pkgconfigdir}/libdom.pc
128
129 %if %{with static_libs}
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/libdom.a
133 %endif
This page took 0.058024 seconds and 3 git commands to generate.