]> git.pld-linux.org Git - packages/libdom.git/blob - libdom.spec
- updated to 0.3.2
[packages/libdom.git] / libdom.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of W3C DOM
6 Summary(pl.UTF-8):      Implementacja W3C DOM
7 Name:           libdom
8 Version:        0.3.2
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  0b121c2cacaae95c6d753b5ca8ff1e7c
14 URL:            http://www.netsurf-browser.org/projects/libdom/
15 BuildRequires:  expat-devel >= 1.95
16 BuildRequires:  libhubbub-devel >= 0.3.4
17 BuildRequires:  libparserutils-devel >= 0.2.3
18 BuildRequires:  libwapcaplet-devel >= 0.4.0
19 BuildRequires:  libxml2-devel >= 2.0
20 BuildRequires:  netsurf-buildsystem >= 1.6
21 BuildRequires:  pkgconfig
22 Requires:       libhubbub >= 0.3.4
23 Requires:       libparserutils >= 0.2.3
24 Requires:       libwapcaplet >= 0.4.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 LibDOM is an implementation of the W3C DOM, written in C. It is
29 currently in development for use with NetSurf and is intended to be
30 suitable for use in other projects too.
31
32 %description -l pl.UTF-8
33 LibDOM to implementacja W3C DOM, napisana w C. Jest rozwijana do
34 wykorzystania w ramach projektu NetSurf, ale także z myślą o
35 możliwości użycia w innych projektach.
36
37 %package devel
38 Summary:        libdom library headers
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libdom
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       expat-devel >= 1.95
43 Requires:       libhubbub-devel >= 0.3.1
44
45 %description devel
46 This package contains the include files and other resources you can
47 use to incorporate libdom into applications.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
51 programach.
52
53 %package static
54 Summary:        libdom static library
55 Summary(pl.UTF-8):      Statyczna biblioteka libdom
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 This is package with static libdom library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka libdom.
64
65 %prep
66 %setup -q
67
68 %build
69 export AR="%{__ar}"
70 export CC="%{__cc}"
71 export CFLAGS="%{rpmcflags}"
72 export LDFLAGS="%{rpmldflags}"
73
74 %{__make} \
75         Q= \
76         PREFIX=%{_prefix} \
77         LIBDIR=%{_lib} \
78         COMPONENT_TYPE=lib-shared
79
80 %if %{with static_libs}
81 %{__make} \
82         Q= \
83         PREFIX=%{_prefix} \
84         LIBDIR=%{_lib} \
85         COMPONENT_TYPE=lib-static
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 export AR="%{__ar}"
92 export CC="%{__cc}"
93 export CFLAGS="%{rpmcflags}"
94 export LDFLAGS="%{rpmldflags}"
95
96 %{__make} install \
97         Q= \
98         PREFIX=%{_prefix} \
99         LIBDIR=%{_lib} \
100         COMPONENT_TYPE=lib-shared \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %if %{with static_libs}
104 %{__make} install \
105         Q= \
106         PREFIX=%{_prefix} \
107         LIBDIR=%{_lib} \
108         COMPONENT_TYPE=lib-static \
109         DESTDIR=$RPM_BUILD_ROOT
110 %endif
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc COPYING README
121 %attr(755,root,root) %{_libdir}/libdom.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libdom.so.0
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libdom.so
127 %{_includedir}/dom
128 %{_pkgconfigdir}/libdom.pc
129
130 %if %{with static_libs}
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libdom.a
134 %endif
This page took 0.054754 seconds and 3 git commands to generate.