]> git.pld-linux.org Git - packages/libdom.git/blame - libdom.spec
- new
[packages/libdom.git] / libdom.spec
CommitLineData
d9686636 1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
5Summary: Implementation of W3C DOM
6Name: libdom
7Version: 0.0.1
8Release: 1
9License: MIT
10Group: Libraries
11Source0: http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12# Source0-md5: dea386cfe4fc65b79a1815b0515fc688
13URL: http://www.netsurf-browser.org/projects/libdom/
14BuildRequires: libhubbub-devel >= 0.2.0
15BuildRequires: libparserutils-devel >= 0.1.2
16BuildRequires: libwapcaplet-devel >= 0.2.0
17BuildRequires: libxml2-devel
18BuildRequires: netsurf-buildsystem
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22LibDOM is an implementation of the W3C DOM, written in C. It is
23currently in development for use with NetSurf and is intended to be
24suitable for use in other projects too.
25
26%package devel
27Summary: libdom library headers
28Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libdom
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32%description devel
33This is the libraries, include files and other resources you can use
34to incorporate libdom into applications.
35
36%description devel -l pl.UTF-8
37Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
38programach.
39
40%package static
41Summary: libdom static libraries
42Summary(pl.UTF-8): Statyczne biblioteki libdom
43Group: Development/Libraries
44Requires: %{name}-devel = %{version}-%{release}
45
46%description static
47This is package with static libdom libraries.
48
49%description static -l pl.UTF-8
50Statyczna biblioteka libdom.
51
52%prep
53%setup -q
54
55%build
56CFLAGS="%{rpmcflags}"
57LDFLAGS="%{rpmldflags}"
58export CFLAGS
59export LDFLAGS
60
61%{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
62 -Iinclude -Isrc"
63%if %{with static_libs}
64%{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
65 -Iinclude -Isrc"
66%endif
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71%{__make} install \
72 DESTDIR=$RPM_BUILD_ROOT \
73 PREFIX=%{_prefix} \
74 COMPONENT_TYPE=lib-shared \
75 Q=''
76
77%if %{with static_libs}
78%{__make} install \
79 DESTDIR=$RPM_BUILD_ROOT \
80 PREFIX=%{_prefix} \
81 COMPONENT_TYPE=lib-static \
82 Q=''
83%endif
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(644,root,root,755)
93%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
94
95%files devel
96%defattr(644,root,root,755)
97%attr(755,root,root) %{_libdir}/lib*.so
98%{_includedir}/dom
99%{_pkgconfigdir}/*pc
100
101%if %{with static_libs}
102%files static
103%defattr(644,root,root,755)
104%{_libdir}/lib*.a
105%endif
This page took 0.135041 seconds and 4 git commands to generate.