]> git.pld-linux.org Git - packages/libcmis.git/blame_incremental - libcmis.spec
- icu-57.1 rebuild
[packages/libcmis.git] / libcmis.spec
... / ...
CommitLineData
1#
2# Conditonal build:
3%bcond_without static_libs # static library
4#
5Summary: A C++ client library for the CMIS interface
6Summary(pl.UTF-8): Biblioteka klienta C++ dla inferfejsu CMIS
7Name: libcmis
8Version: 0.5.0
9Release: 8
10License: GPL v2+ or LGPL v2+ or MPL v1.1
11Group: Libraries
12Source0: http://downloads.sourceforge.net/libcmis/%{name}-%{version}.tar.gz
13# Source0-md5: 5821b806a98e6c38370970e682ce76e8
14Patch0: %{name}-boost-gcc.patch
15URL: http://sourceforge.net/projects/libcmis/
16BuildRequires: autoconf >= 2.63
17BuildRequires: automake
18BuildRequires: boost-devel
19BuildRequires: cppunit-devel >= 1.12
20BuildRequires: curl-devel >= 7.12.3
21BuildRequires: docbook2X >= 0.8.8-4
22BuildRequires: libstdc++-devel
23BuildRequires: libtool >= 2:2
24BuildRequires: libxml2-devel >= 2.0
25BuildRequires: pkgconfig
26BuildRequires: sed >= 4.0
27Requires: curl-libs >= 7.12.3
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31LibCMIS is a C++ client library for the CMIS interface. This allows
32C++ applications to connect to any ECM behaving as a CMIS server like
33Alfresco, Nuxeo for the open source ones.
34
35%description -l pl.UTF-8
36LibCMIS to biblioteka klienta C++ dla interfejsu CMIS. Pozwala ona
37aplikacjom C++ na łączenie się z każdym ECM zachowującym się jako
38serwer CMIS, taki jak Alfresco, Nuxeo (biorąc pod uwagę implementacje
39o otwartych źródłach).
40
41%package devel
42Summary: Development files for CMIS library
43Summary(pl.UTF-8): Pliki nagłówkowe biblioteki CMIS
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: boost-devel
47Requires: curl-devel >= 7.12.3
48Requires: libstdc++-devel
49Requires: libxml2-devel >= 2.0
50
51%description devel
52This package contains the header files for developing applications
53that use CMIS library.
54
55%description devel -l pl.UTF-8
56Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
57bibliotece CMIS
58
59%package static
60Summary: Static CMIS library
61Summary(pl.UTF-8): Statyczna biblioteka CMIS
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66Static CMIS library.
67
68%description static -l pl.UTF-8
69Statyczna biblioteka CMIS.
70
71%package tools
72Summary: Command line tool to access CMIS
73Summary(pl.UTF-8): Narzędzie wiersza poleceń dla CMIS
74Group: Applications/Publishing
75Requires: %{name} = %{version}-%{release}
76
77%description tools
78This package contains a tool for accessing CMIS from the command line.
79
80%description tools -l pl.UTF-8
81Ten pakiet zawiera narzędzie do łączenia się do CMIS z wiersza
82poleceń.
83
84%prep
85%setup -q
86%patch0 -p1
87
88#%{__sed} -i -e 's/docbook-to-man/docbook2X2man/' configure.ac
89
90%build
91%{__libtoolize}
92%{__aclocal} -I m4
93%{__autoconf}
94%{__automake}
95%configure \
96 DOCBOOK2MAN=/usr/bin/docbook2X2man \
97 --disable-silent-rules \
98 %{!?with_static_libs:--disable-static} \
99 --disable-tests \
100 --disable-werror
101
102%{__make}
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107%{__make} install \
108 DESTDIR=$RPM_BUILD_ROOT
109
110# obsoleted by pkg-config
111%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files
120%defattr(644,root,root,755)
121%doc AUTHORS ChangeLog NEWS README
122%attr(755,root,root) %{_libdir}/libcmis-0.5.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libcmis-0.5.so.5
124%attr(755,root,root) %{_libdir}/libcmis-c-0.5.so.*.*.*
125%attr(755,root,root) %ghost %{_libdir}/libcmis-c-0.5.so.5
126
127%files devel
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_libdir}/libcmis-0.5.so
130%attr(755,root,root) %{_libdir}/libcmis-c-0.5.so
131%{_includedir}/libcmis-0.5
132%{_includedir}/libcmis-c-0.5
133%{_pkgconfigdir}/libcmis-0.5.pc
134%{_pkgconfigdir}/libcmis-c-0.5.pc
135
136%if %{with static_libs}
137%files static
138%defattr(644,root,root,755)
139%{_libdir}/libcmis-0.5.a
140%{_libdir}/libcmis-c-0.5.a
141%endif
142
143%files tools
144%defattr(644,root,root,755)
145%attr(755,root,root) %{_bindir}/cmis-client
146%{_mandir}/man1/cmis-client.1*
This page took 0.058666 seconds and 4 git commands to generate.