]> git.pld-linux.org Git - packages/libcap.git/blobdiff - libcap-link.patch
This commit was manufactured by cvs2git to create branch 'AC-branch'.
[packages/libcap.git] / libcap-link.patch
diff --git a/libcap-link.patch b/libcap-link.patch
new file mode 100644 (file)
index 0000000..2a24355
--- /dev/null
@@ -0,0 +1,37 @@
+--- libcap-1.92/libcap/Makefile.orig   Fri Apr 23 08:15:10 1999
++++ libcap-1.92/libcap/Makefile        Tue Oct 22 23:33:28 2002
+@@ -34,12 +34,12 @@
+ #     @sed -ne '/^#define[ \t]CAP[_A-Z]\+[ \t]\+[0-9]\+/{s/^#define CAP_\([^ \t]*\)[ \t]*\([^ \t]*\)/  \{ \2, \"\1\" \},/;y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/;p;}' < /usr/include/linux/capability.h | fgrep -v 0x > cap_names.sed
+ $(MINLIBNAME): $(OBJS)
+-      $(LD) -soname $(MAJLIBNAME) -x -shared -o $@ $(OBJS)
++      $(CC) -Wl,-soname -Wl,$(MAJLIBNAME) -Wl,-x -shared -o $@ $(OBJS)
+       ln -sf $(MINLIBNAME) $(MAJLIBNAME)
+       ln -sf $(MAJLIBNAME) $(LIBNAME)
+ %.o: %.c $(INCLS)
+-      $(CC) $(CFLAGS) -c $< -o $@
++      $(CC) $(CFLAGS) -fPIC -c $< -o $@
+ install: all
+       mkdir -p -m 0755 $(INCDIR)/sys
+--- libcap-1.10/libcap/cap_sys.c.orig  1999-04-18 00:16:31.000000000 +0200
++++ libcap-1.10/libcap/cap_sys.c       2004-08-03 21:06:00.506249264 +0200
+@@ -8,16 +8,8 @@
+  */
+ #include "libcap.h"
+-#define __LIBRARY__
+-#include <linux/unistd.h>
+-_syscall2(int, capget,
+-        cap_user_header_t, header,
+-        cap_user_data_t, data)
+-
+-_syscall2(int, capset,
+-        cap_user_header_t, header,
+-        const cap_user_data_t, data)
++/* capget(), capset() syscalls are defined in libc */
+ /*
+  * $Log$
This page took 0.138925 seconds and 4 git commands to generate.