- updated to 0.13.6 (note: new soname)
[packages/libass.git] / libass.spec
CommitLineData
b9fc0da1
JB
1Summary: LibASS - SSA/ASS subtitles rendering library
2Summary(pl.UTF-8): LibASS - biblioteka renderująca napisy SSA/ASS
3Name: libass
66aba02d 4Version: 0.13.6
6d229e9e 5Release: 1
012f0c52 6License: MIT-like
b9fc0da1 7Group: Libraries
6d229e9e 8#Source0Download: https://github.com/libass/libass/releases
cfe7bfd4 9Source0: https://github.com/libass/libass/releases/download/%{version}/%{name}-%{version}.tar.xz
66aba02d 10# Source0-md5: daa6cfca437c0776af5f79750cdd9b4e
5e58a9c8 11URL: https://github.com/libass/libass/
cfe7bfd4 12BuildRequires: autoconf >= 2.50
5e58a9c8 13BuildRequires: automake
6d229e9e 14BuildRequires: fontconfig-devel >= 1:2.10.92
012f0c52 15BuildRequires: fribidi-devel >= 0.19.0
86f88999
JB
16# pkgconfig(freetype2) >= 9.10.3
17BuildRequires: freetype-devel >= 1:2.2.1
f8fdb212 18BuildRequires: harfbuzz-devel >= 0.9.5
cfe7bfd4 19BuildRequires: libtool >= 2:2
b9fc0da1 20BuildRequires: pkgconfig
50411762
JB
21BuildRequires: tar >= 1:1.22
22BuildRequires: xz
6d229e9e 23%ifarch %{ix86} %{x8664} x32
2da258ee 24BuildRequires: yasm >= 1.3.0
6d229e9e
JB
25%endif
26Requires: fontconfig-libs >= 1:2.10.92
86f88999 27Requires: freetype >= 1:2.2.1
5e58a9c8 28Requires: fribidi >= 0.19.0
f8fdb212 29Requires: harfbuzz >= 0.9.5
b9fc0da1
JB
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33LibASS is a portable subtitle renderer for the ASS/SSA (Advanced
34Substation Alpha/Substation Alpha) subtitle format. It is mostly
35compatible with VSFilter.
36
b9fc0da1
JB
37%description -l pl.UTF-8
38LibASS to przenośna biblioteka renderująca napisy w formacie ASS/SSA
39(Advanced Substation Alpha/Substation Alpha). Jest w większości
40kompatybilna z VSFiltrem.
41
42%package devel
43Summary: Header files for LibASS library
44Summary(pl.UTF-8): Pliki nagłówkowe biblioteki LibASS
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
6d229e9e 47Requires: fontconfig-devel >= 1:2.10.92
86f88999 48Requires: freetype-devel >= 1:2.2.1
5e58a9c8 49Requires: fribidi-devel >= 0.19.0
f8fdb212 50Requires: harfbuzz-devel >= 0.9.5
b9fc0da1
JB
51
52%description devel
53This package contains the header files for developing applications
54that use LibASS library.
55
56%description devel -l pl.UTF-8
57Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
58wykorzystujących bibliotekę LibASS.
59
60%package static
61Summary: Static LibASS library
62Summary(pl.UTF-8): Statyczna biblioteka LibASS
63Group: Development/Libraries
64Requires: %{name}-devel = %{version}-%{release}
65
66%description static
67Static LibASS library.
68
69%description static -l pl.UTF-8
70Statyczna biblioteka LibASS.
71
72%prep
73%setup -q
74
75%build
5e58a9c8
JP
76%{__libtoolize}
77%{__aclocal} -I m4
78%{__autoconf}
79%{__autoheader}
80%{__automake}
b9fc0da1
JB
81%configure \
82 --disable-silent-rules
83
84%{__make}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89%{__make} install \
90 DESTDIR=$RPM_BUILD_ROOT
91
cfe7bfd4
JB
92# obsoleted by pkg-config
93%{__rm} $RPM_BUILD_ROOT%{_libdir}/libass.la
94
b9fc0da1
JB
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post -p /sbin/ldconfig
99%postun -p /sbin/ldconfig
100
101%files
102%defattr(644,root,root,755)
012f0c52 103%doc COPYING Changelog
b9fc0da1 104%attr(755,root,root) %{_libdir}/libass.so.*.*.*
66aba02d 105%attr(755,root,root) %ghost %{_libdir}/libass.so.9
b9fc0da1
JB
106
107%files devel
108%defattr(644,root,root,755)
109%attr(755,root,root) %{_libdir}/libass.so
b9fc0da1
JB
110%{_includedir}/ass
111%{_pkgconfigdir}/libass.pc
112
113%files static
114%defattr(644,root,root,755)
115%{_libdir}/libass.a
This page took 0.088733 seconds and 4 git commands to generate.