]> git.pld-linux.org Git - packages/libaio.git/blame - libaio.spec
- fix building on x32
[packages/libaio.git] / libaio.spec
CommitLineData
382975ad
JB
1#
2# Conditional build:
3%bcond_without tests # don't perform make partcheck
4#
bb7286e8 5Summary: Linux-native asynchronous I/O access library
97a58730 6Summary(pl.UTF-8): Biblioteka natywnego dla Linuksa asynchronicznego dostępu do wejścia/wyjścia
bb7286e8 7Name: libaio
9d128561
AM
8Version: 0.3.109
9Release: 1
bb7286e8
JB
10License: LGPL v2+
11Group: Libraries
8b5c9a1e
AM
12Source0: ftp://ftp.kernel.org/pub/linux/libs/aio/%{name}-%{version}.tar.gz
13# Source0-md5: 435a5b16ca6198eaf01155263d855756
9d128561 14Patch0: %{name}-DESTDIR.patch
c7725059 15Patch1: %{name}-Werror.patch
3bbf7e38 16Patch2: x32.patch
bb7286e8
JB
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20The Linux-native asynchronous I/O facility ("async I/O", or "aio") has
21a richer API and capability set than the simple POSIX async I/O
c44802ec
ER
22facility.
23
24This library, libaio, provides the Linux-native API for async I/O. The
25POSIX async I/O facility requires this library in order to provide
26kernel-accelerated async I/O capabilities, as do applications which
27require the Linux-native async I/O API.
bb7286e8 28
df913f84
JR
29%description -l pl.UTF-8
30Natywna dla Linuksa obsługa asynchronicznego wejścia/wyjścia ("async
31I/O" lub "aio") ma bogatsze API i zestaw możliwości niż proste
c44802ec
ER
32asynchroniczne wejście/wyjście zgodne z POSIX.
33
34Ta biblioteka - libaio - udostępnia natywne Linuksowe API dla
35asynchronicznego we/wy. Zgodne z POSIX asynchroniczne we/wy wymaga tej
36biblioteki do udostępnienia przyspieszanych przez jądro możliwości
37asynchronicznego we/wy, podobnie jak aplikacje wymagające natywnego
38dla Linuksa API asynchronicznego we/wy.
bb7286e8
JB
39
40%package devel
41Summary: Header files for libaio library
97a58730 42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libaio
bb7286e8
JB
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45
46%description devel
47Header files for libaio library.
48
df913f84
JR
49%description devel -l pl.UTF-8
50Pliki nagłówkowe biblioteki libaio.
bb7286e8
JB
51
52%package static
53Summary: Static libaio library
97a58730 54Summary(pl.UTF-8): Statyczna biblioteka libaio
bb7286e8
JB
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
57
58%description static
59Static libaio library.
60
df913f84 61%description static -l pl.UTF-8
bb7286e8
JB
62Statyczna biblioteka libaio.
63
64%prep
8b5c9a1e 65%setup -q
c862da45 66%patch0 -p1
c7725059 67%patch1 -p1
3bbf7e38 68%patch2 -p1
bb7286e8
JB
69
70%build
71%{__make} \
72 CC="%{__cc}" \
9d128561 73 CFLAGS="%{rpmcppflags} %{rpmcflags} -fomit-frame-pointer -fPIC -Wall -I. -nostdlib -nostartfiles"
bb7286e8 74
450ab932
AM
75%{?with_tests:%{__make} CC="%{__cc}" partcheck}
76
bb7286e8
JB
77%install
78rm -rf $RPM_BUILD_ROOT
3ebe367c 79install -d $RPM_BUILD_ROOT/%{_lib}
bb7286e8
JB
80
81%{__make} install \
3f1eec63
ER
82 libdir=/%{_lib} \
83 usrlibdir=%{_libdir} \
c44802ec 84 DESTDIR=$RPM_BUILD_ROOT
bb7286e8 85
48e39479
JB
86# omit some manuals:
87# man2/io_* already included in man-pages
88# some man3/aio_* already included in glibc-devel-doc (from man-pages)
89install -d $RPM_BUILD_ROOT%{_mandir}/man3
c44802ec
ER
90cp -a man/aio{,_cancel64,_error64,_fsync64,_init,_read64,_return64,_suspend64,_write64}.3 $RPM_BUILD_ROOT%{_mandir}/man3
91cp -a man/io*.3 $RPM_BUILD_ROOT%{_mandir}/man3
92cp -a man/lio*.3 $RPM_BUILD_ROOT%{_mandir}/man3
bb7286e8
JB
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98%postun -p /sbin/ldconfig
99
100%files
101%defattr(644,root,root,755)
102%doc ChangeLog TODO
3ebe367c 103%attr(755,root,root) /%{_lib}/libaio.so.*.*.*
c862da45 104%attr(755,root,root) %ghost /%{_lib}/libaio.so.1
bb7286e8
JB
105
106%files devel
107%defattr(644,root,root,755)
108%attr(755,root,root) %{_libdir}/libaio.so
109%{_includedir}/libaio.h
f3df8777
JB
110%{_mandir}/man3/aio*.3*
111%{_mandir}/man3/io*.3*
112%{_mandir}/man3/lio_*.3*
bb7286e8
JB
113
114%files static
115%defattr(644,root,root,755)
116%{_libdir}/libaio.a
This page took 0.047506 seconds and 4 git commands to generate.