]> git.pld-linux.org Git - packages/lftp.git/blame_incremental - lftp.spec
- up to 4.7.5
[packages/lftp.git] / lftp.spec
... / ...
CommitLineData
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3#
4# Conditional build:
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
7# better just preload it instead forcing linking
8%bcond_with dante # Dante-based SOCKS support
9# broken currently https://www.dnssec-tools.org/trac/ticket/173
10%bcond_with dnssec # DNSSEC local validation
11#
12%if %{with ssl}
13%define with_openssl 1
14%endif
15
16%if %{with gnutls} && %{with ssl}
17%undefine with_openssl
18%endif
19
20Summary: Sophisticated command line FTP/HTTP client
21Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
22Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
23Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
24Summary(zh_CN.UTF-8): lftp 客户端程序
25Name: lftp
26Version: 4.7.5
27Release: 1
28License: GPL v3+
29Group: Applications/Networking
30Source0: https://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
31# Source0-md5: 88c1505f8264429353ea7f249597eeb7
32Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
33# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
34Source2: %{name}.desktop
35Source3: %{name}-icon.png
36Patch100: %{name}-git.patch
37Patch0: %{name}-makefile.patch
38Patch1: %{name}-m4.patch
39Patch2: aliases.patch
40# when updated attach at https://github.com/lavv17/lftp/issues
41Patch3: %{name}-pl.po-update.patch
42Patch4: %{name}-am.patch
43URL: http://lftp.tech/
44BuildRequires: autoconf >= 2.60
45BuildRequires: automake
46%{?with_dante:BuildRequires: dante-devel}
47%{?with_dnssec:BuildRequires: dnssec-tools-devel}
48BuildRequires: expat-devel
49BuildRequires: gettext-tools >= 0.14.2
50%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
51BuildRequires: libstdc++-devel
52BuildRequires: libtool >= 1:1.4.2-9
53BuildRequires: ncurses-devel >= 5.2
54%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
55BuildRequires: pkgconfig
56BuildRequires: readline-devel >= 4.2
57BuildRequires: tar >= 1:1.22
58BuildRequires: xz
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
62%if %{_gcc_ver} == 2
63%define __cxx "%{__cc}"
64%endif
65
66%description
67LFTP is a shell-like command line FTP/HTTP client. The main two
68advantages over other FTP clients are reliability and ability to
69perform tasks in background. It will reconnect and reget the file
70being transferred if the connection broke. You can start a transfer in
71background and continue browsing on the FTP site. It does this all in
72one process. When you have started background jobs and feel you are
73done, you can just exit lftp and it automatically moves to nohup mode
74and completes the transfers. It has also such nice features as reput
75and mirror.
76
77%description -l pl.UTF-8
78Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
79połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
80ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
81połączenia po tym jak się wylogujesz. Program ten honoruje komendy
82powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
83jako aplikacja do mirrorowania serwerów FTP.
84
85%description -l pt_BR.UTF-8
86O lftp é um programa de transferência de arquivos por linha de
87comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
88HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
89tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
90o arquivo FEATURES para uma lista mais detalhada.
91
92%prep
93%setup -q
94#%patch100 -p1
95%patch0 -p1
96%patch1 -p1
97%patch2 -p1
98#%patch3 -p1
99%patch4 -p1
100
101%{__rm} po/stamp-po
102
103%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
104
105%build
106%{__libtoolize}
107%{__gettextize}
108%{__aclocal} -I m4
109%{__autoconf}
110%{__automake}
111CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
112%configure \
113 --without-included-regex \
114 --with-dnssec-local-validation%{!?with_dnssec:=no} \
115 --with-modules \
116 --with-socksdante%{!?with_dante:=no} \
117 --with%{!?with_openssl:out}-openssl \
118 --with%{!?with_gnutls:out}-gnutls
119
120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT
127
128cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
129cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
130cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
131
132bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
133%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
134%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
135
136%find_lang %{name}
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
143
144%files -f %{name}.lang
145%defattr(644,root,root,755)
146%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
147%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
148%attr(755,root,root) %{_bindir}/lftp
149%attr(755,root,root) %{_bindir}/lftpget
150%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
151%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
152%dir %{_libdir}/lftp
153%attr(755,root,root) %{_libdir}/lftp/*.so
154%attr(755,root,root) %{_datadir}/lftp
155%{_mandir}/man1/lftp.1*
156%{_mandir}/man1/lftpget.1*
157%lang(pl) %{_mandir}/pl/man1/lftpget.1*
158%{_mandir}/man5/lftp.conf.5*
159%{_desktopdir}/lftp.desktop
160%{_pixmapsdir}/lftp.png
This page took 0.090401 seconds and 4 git commands to generate.