]> git.pld-linux.org Git - packages/lftp.git/blame_incremental - lftp.spec
- up to 4.8.3
[packages/lftp.git] / lftp.spec
... / ...
CommitLineData
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3#
4# Conditional build:
5%bcond_without tests
6%bcond_without ssl # do not use SSL
7%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
8# better just preload it instead forcing linking
9%bcond_with dante # Dante-based SOCKS support
10# broken currently https://www.dnssec-tools.org/trac/ticket/173
11%bcond_with dnssec # DNSSEC local validation
12#
13%if %{with ssl}
14%define with_openssl 1
15%endif
16
17%if %{with gnutls} && %{with ssl}
18%undefine with_openssl
19%endif
20
21Summary: Sophisticated command line FTP/HTTP client
22Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
23Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
24Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
25Summary(zh_CN.UTF-8): lftp 客户端程序
26Name: lftp
27Version: 4.8.3
28Release: 1
29License: GPL v3+
30Group: Applications/Networking
31Source0: https://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
32# Source0-md5: 8beb3d814d60f52ac70cffd6dff23d85
33Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
34# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
35Source2: %{name}.desktop
36Source3: %{name}-icon.png
37Patch100: %{name}-git.patch
38Patch0: %{name}-makefile.patch
39Patch1: %{name}-m4.patch
40Patch2: aliases.patch
41# when updated attach at https://github.com/lavv17/lftp/issues
42Patch3: %{name}-pl.po-update.patch
43Patch4: %{name}-am.patch
44URL: http://lftp.tech/
45BuildRequires: autoconf >= 2.60
46BuildRequires: automake
47%{?with_dante:BuildRequires: dante-devel}
48%{?with_dnssec:BuildRequires: dnssec-tools-devel}
49BuildRequires: expat-devel
50BuildRequires: gettext-tools >= 0.14.2
51%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
52BuildRequires: libidn2-devel
53BuildRequires: libstdc++-devel
54BuildRequires: libtool >= 2:2
55BuildRequires: ncurses-devel >= 5.2
56%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
57BuildRequires: pkgconfig
58BuildRequires: readline-devel >= 5.0
59BuildRequires: tar >= 1:1.22
60BuildRequires: xz
61BuildRequires: zlib-devel
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%description
65LFTP is a shell-like command line FTP/HTTP client. The main two
66advantages over other FTP clients are reliability and ability to
67perform tasks in background. It will reconnect and reget the file
68being transferred if the connection broke. You can start a transfer in
69background and continue browsing on the FTP site. It does this all in
70one process. When you have started background jobs and feel you are
71done, you can just exit lftp and it automatically moves to nohup mode
72and completes the transfers. It has also such nice features as reput
73and mirror.
74
75%description -l pl.UTF-8
76Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
77połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
78ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
79połączenia po tym jak się wylogujesz. Program ten honoruje komendy
80powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
81jako aplikacja do mirrorowania serwerów FTP.
82
83%description -l pt_BR.UTF-8
84O lftp é um programa de transferência de arquivos por linha de
85comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
86HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
87tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
88o arquivo FEATURES para uma lista mais detalhada.
89
90%prep
91%setup -q
92#%patch100 -p1
93%patch0 -p1
94%patch1 -p1
95%patch2 -p1
96#%patch3 -p1
97%patch4 -p1
98
99%{__rm} po/stamp-po
100
101%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
102
103%build
104%{__libtoolize}
105%{__gettextize}
106%{__aclocal} -I m4
107%{__autoconf}
108%{__automake}
109CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
110%configure \
111 --without-included-regex \
112 --with-dnssec-local-validation%{!?with_dnssec:=no} \
113 --with-modules \
114 --with-socksdante%{!?with_dante:=no} \
115 --with%{!?with_openssl:out}-openssl \
116 --with%{!?with_gnutls:out}-gnutls
117
118%{__make}
119
120%{?with_tests:%{__make} check}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT
127
128cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
129cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
130cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
131
132bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
133%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
134%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
135
136%find_lang %{name}
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
143
144%files -f %{name}.lang
145%defattr(644,root,root,755)
146%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
147%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
148%attr(755,root,root) %{_bindir}/lftp
149%attr(755,root,root) %{_bindir}/lftpget
150%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
151%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
152%dir %{_libdir}/lftp
153%attr(755,root,root) %{_libdir}/lftp/*.so
154%attr(755,root,root) %{_datadir}/lftp
155%{_mandir}/man1/lftp.1*
156%{_mandir}/man1/lftpget.1*
157%lang(pl) %{_mandir}/pl/man1/lftpget.1*
158%{_mandir}/man5/lftp.conf.5*
159%{_desktopdir}/lftp.desktop
160%{_pixmapsdir}/lftp.png
This page took 0.028694 seconds and 4 git commands to generate.