]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- try without parallel test (hangs on builders)
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
324a7201 5%bcond_without tests
7b39c852
JB
6%bcond_without ssl # do not use SSL
7%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
5596a2d5
AM
8# better just preload it instead forcing linking
9%bcond_with dante # Dante-based SOCKS support
db510deb
AM
10# broken currently https://www.dnssec-tools.org/trac/ticket/173
11%bcond_with dnssec # DNSSEC local validation
5869f11d 12#
117d16ec 13%if %{with ssl}
14%define with_openssl 1
15%endif
16
4f313d5c 17%if %{with gnutls} && %{with ssl}
117d16ec 18%undefine with_openssl
4f313d5c 19%endif
117d16ec 20
aa601f68 21Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
22Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
23Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
24Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
25Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 26Name: lftp
9f5f5419 27Version: 4.8.3
df55f7fc 28Release: 1
474948d1 29License: GPL v3+
4e6de64c 30Group: Applications/Networking
df55f7fc 31Source0: https://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
9f5f5419 32# Source0-md5: 8beb3d814d60f52ac70cffd6dff23d85
e84c29c9 33Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 34# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 35Source2: %{name}.desktop
fbf2ab8a 36Source3: %{name}-icon.png
93dfd0ea 37Patch100: %{name}-git.patch
5bf73c23
JB
38Patch0: %{name}-makefile.patch
39Patch1: %{name}-m4.patch
40Patch2: aliases.patch
88eff545 41# when updated attach at https://github.com/lavv17/lftp/issues
5bf73c23 42Patch3: %{name}-pl.po-update.patch
9d3763af 43Patch4: %{name}-am.patch
df55f7fc 44URL: http://lftp.tech/
7e9d0681 45BuildRequires: autoconf >= 2.60
2a2b7922 46BuildRequires: automake
5869f11d
JB
47%{?with_dante:BuildRequires: dante-devel}
48%{?with_dnssec:BuildRequires: dnssec-tools-devel}
5bf73c23 49BuildRequires: expat-devel
fb96bafa 50BuildRequires: gettext-tools >= 0.14.2
d4e96cc1 51%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
42656b3d 52BuildRequires: libidn2-devel
131b64b6 53BuildRequires: libstdc++-devel
f9f0c5b5 54BuildRequires: libtool >= 2:2
eb634329 55BuildRequires: ncurses-devel >= 5.2
117d16ec 56%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 57BuildRequires: pkgconfig
f9f0c5b5 58BuildRequires: readline-devel >= 5.0
7bf4d9a3 59BuildRequires: tar >= 1:1.22
60BuildRequires: xz
f9f0c5b5 61BuildRequires: zlib-devel
4502d222 62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 63
64%description
aa601f68 65LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 66advantages over other FTP clients are reliability and ability to
c37d8459 67perform tasks in background. It will reconnect and reget the file
68being transferred if the connection broke. You can start a transfer in
b25ac3f9 69background and continue browsing on the FTP site. It does this all in
c37d8459 70one process. When you have started background jobs and feel you are
71done, you can just exit lftp and it automatically moves to nohup mode
72and completes the transfers. It has also such nice features as reput
73and mirror.
0fcf33fd 74
29127d3f 75%description -l pl.UTF-8
aa601f68 76Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
77połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
78ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
79połączenia po tym jak się wylogujesz. Program ten honoruje komendy
80powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
81jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 82
29127d3f
JR
83%description -l pt_BR.UTF-8
84O lftp é um programa de transferência de arquivos por linha de
aa601f68 85comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
86HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
87tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 88o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 89
0fcf33fd 90%prep
6588894c 91%setup -q
df55f7fc 92#%patch100 -p1
5bf73c23 93%patch0 -p1
43f4d1c2 94%patch1 -p1
ec7a935e 95%patch2 -p1
42656b3d 96#%patch3 -p1
bce12c75 97%patch4 -p1
a41e3bec 98
b9a2e61d
JB
99%{__rm} po/stamp-po
100
33b4fdae
AM
101%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
102
0fcf33fd 103%build
dc2417fa 104%{__libtoolize}
07e8f8cb 105%{__gettextize}
29f4b0b0 106%{__aclocal} -I m4
cbf16d8c 107%{__autoconf}
108%{__automake}
8ad8d289 109CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 110%configure \
d2c1e0b5 111 --without-included-regex \
5869f11d 112 --with-dnssec-local-validation%{!?with_dnssec:=no} \
9f24e3d9 113 --with-modules \
5869f11d 114 --with-socksdante%{!?with_dante:=no} \
117d16ec 115 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
116 --with%{!?with_gnutls:out}-gnutls
117
3579d696 118%{__make}
0fcf33fd 119
f66dfc48 120%{?with_tests:%{__make} -j1 check}
324a7201 121
0fcf33fd 122%install
123rm -rf $RPM_BUILD_ROOT
10a3b210 124install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT
be14979d 127
f1bf5d4a
ER
128cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
129cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
130cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 131
e84c29c9 132bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
133%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
134%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 135
df169521 136%find_lang %{name}
165ff9f8 137
0fcf33fd 138%clean
139rm -rf $RPM_BUILD_ROOT
140
43f4d1c2
JB
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
143
df169521 144%files -f %{name}.lang
be14979d 145%defattr(644,root,root,755)
e84c29c9 146%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 147%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
148%attr(755,root,root) %{_bindir}/lftp
149%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 150%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
151%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
152%dir %{_libdir}/lftp
d81e41f6 153%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 154%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
155%{_mandir}/man1/lftp.1*
156%{_mandir}/man1/lftpget.1*
157%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 158%{_mandir}/man5/lftp.conf.5*
10a3b210 159%{_desktopdir}/lftp.desktop
c37d8459 160%{_pixmapsdir}/lftp.png
This page took 0.093241 seconds and 4 git commands to generate.