]> git.pld-linux.org Git - packages/ldb.git/blobdiff - ldb.spec
- versioned Obsoletes
[packages/ldb.git] / ldb.spec
index c859d895cab950971cba527b738b1c61bea867ad..5078d4485e5cc83a64e87c1f4a8ec675d0b74524 100644 (file)
--- a/ldb.spec
+++ b/ldb.spec
@@ -1,34 +1,49 @@
-# TODO
-# - ld.bfd enforced because gold does not understand '!' in version script (binutils-3:2.21.53.0.1-1)
-%define                talloc_version  2:2.0.8
-%define                tdb_version     2:1.2.11
-%define                tevent_version  0.9.17
+#
+# Conditional build:
+%bcond_without lmdb    # LMDB module (64-bit only)
+#
+%ifnarch %{x8664} aarch64 alpha mips64 ppc64 s390x sparc64
+# lmdb support requires 64-bit size_t
+%undefine      with_lmdb
+%endif
+%define                talloc_version  2:2.3.1
+%define                tdb_version     2:1.4.3
+%define                tevent_version  0.10.2
 Summary:       LDAP-like embedded database
 Summary(pl.UTF-8):     Wbudowana baza danych podobna do LDAP
 Name:          ldb
-Version:       1.1.14
+Version:       2.2.1
 Release:       1
 License:       LGPL v3+
 Group:         Libraries
-Source0:       http://samba.org/ftp/ldb/%{name}-%{version}.tar.gz
-# Source0-md5: 7692c592ec7d8070f1d97aeb5738e05a
-URL:           http://ldb.samba.org/
-BuildRequires: autoconf
+Source0:       https://download.samba.org/pub/ldb/%{name}-%{version}.tar.gz
+# Source0-md5: 3bc1e8a13cdc80fe43997e5492e7ce40
+URL:           https://ldb.samba.org/
+BuildRequires: cmocka-devel >= 1.1.3
 BuildRequires: docbook-style-xsl
-BuildRequires: libxslt
-BuildRequires: popt-devel
-BuildRequires: python-devel >= 1:2.4.2
-BuildRequires: python-talloc-devel >= %{talloc_version}
-BuildRequires: python-tdb >= %{tdb_version}
-BuildRequires: python-tevent >= %{tevent_version}
+BuildRequires: libbsd-devel
+BuildRequires: libxslt-progs
+%{?with_lmdb:BuildRequires:    lmdb-devel >= 0.9.16}
+BuildRequires: openldap-devel
+BuildRequires: popt-devel >= 1.6
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-talloc-devel >= %{talloc_version}
+BuildRequires: python3-tdb >= %{tdb_version}
+BuildRequires: python3-tevent >= %{tevent_version}
+BuildRequires: rpmbuild(macros) >= 1.704
 BuildRequires: talloc-devel >= %{talloc_version}
 BuildRequires: tdb-devel >= %{tdb_version}
 BuildRequires: tevent-devel >= %{tevent_version}
+%{?with_lmdb:Requires: lmdb >= 0.9.16}
 Requires:      talloc >= %{talloc_version}
 Requires:      tdb >= %{tdb_version}
 Requires:      tevent >= %{tevent_version}
+Requires:      popt >= 1.6
 Provides:      libldb = %{version}-%{release}
 Obsoletes:     libldb < 1.1.0-3
+# ldb 1.6+ dropped python2 support
+Obsoletes:     python-ldb < 1.6
+Obsoletes:     python-ldb-devel < 1.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -71,32 +86,31 @@ library.
 Pliki nagłówkowe potrzebne do tworzenia programów wykorzystujących
 bibliotekę LDB.
 
-%package -n python-ldb
-Summary:       Python bindings for the LDB library
-Summary(pl.UTF-8):     Wiązania Pythona do biblioteki LDB
+%package -n python3-ldb
+Summary:       Python bindings for the LDB library
+Summary(pl.UTF-8):     Wiązania Pythona do biblioteki LDB
 Group:         Libraries/Python
 Requires:      %{name} = %{version}-%{release}
-Requires:      python-libs >= 1:2.4.2
-Requires:      python-tdb >= %{tdb_version}
-Obsoletes:     pyldb
+Requires:      python3-tdb >= %{tdb_version}
+Obsoletes:     pyldb < 1.1.0-1
 
-%description -n python-ldb
-Python bindings for the LDB library.
+%description -n python3-ldb
+Python bindings for the LDB library.
 
-%description -n python-ldb -l pl.UTF-8
-Wiązania Pythona do biblioteki LDB.
+%description -n python3-ldb -l pl.UTF-8
+Wiązania Pythona do biblioteki LDB.
 
-%package -n python-ldb-devel
-Summary:       Development files for the Python bindings for the LDB library
-Summary(pl.UTF-8):     Pliki programistyczne wiązań Pythona do biblioteki LDB
+%package -n python3-ldb-devel
+Summary:       Development files for the Python bindings for the LDB library
+Summary(pl.UTF-8):     Pliki programistyczne wiązań Pythona do biblioteki LDB
 Group:         Development/Libraries
-Requires:      python-ldb = %{version}-%{release}
+Requires:      python3-ldb = %{version}-%{release}
 
-%description -n python-ldb-devel
-Development files for the Python bindings for the LDB library.
+%description -n python3-ldb-devel
+Development files for the Python bindings for the LDB library.
 
-%description -n python-ldb-devel -l pl.UTF-8
-Pliki programistyczne wiązań Pythona do biblioteki LDB.
+%description -n python3-ldb-devel -l pl.UTF-8
+Pliki programistyczne wiązań Pythona do biblioteki LDB.
 
 %prep
 %setup -q
@@ -104,8 +118,6 @@ Pliki programistyczne wiązań Pythona do biblioteki LDB.
 %build
 CC="%{__cc}" \
 CFLAGS="%{rpmcflags}" \
-LDFLAGS="%{rpmldflags} -fuse-ld=bfd" \
-PYTHONDIR=%{py_sitedir} \
 ./configure \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
@@ -123,6 +135,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
+%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
+
 # Shared libraries need to be marked executable for
 # rpmbuild to strip them and include them in debuginfo
 find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} ';'
@@ -133,14 +148,18 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post  -n python-ldb -p /sbin/ldconfig
-%postun        -n python-ldb -p /sbin/ldconfig
+%post  -n python3-ldb -p /sbin/ldconfig
+%postun        -n python3-ldb -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libldb.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libldb.so.1
+%attr(755,root,root) %ghost %{_libdir}/libldb.so.2
 %dir %{_libdir}/ldb
+%attr(755,root,root) %{_libdir}/ldb/libldb-key-value.so
+%attr(755,root,root) %{_libdir}/ldb/libldb-tdb-err-map.so
+%attr(755,root,root) %{_libdir}/ldb/libldb-tdb-int.so
+%{?with_lmdb:%attr(755,root,root) %{_libdir}/ldb/libldb-mdb-int.so}
 %dir %{_libdir}/ldb/modules
 %dir %{_libdir}/ldb/modules/ldb
 %attr(755,root,root) %{_libdir}/ldb/modules/ldb/*.so
@@ -172,14 +191,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/ldb.pc
 %{_mandir}/man3/ldb.3*
 
-%files -n python-ldb
+%files -n python3-ldb
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libpyldb-util.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpyldb-util.so.1
-%attr(755,root,root) %{py_sitedir}/ldb.so
+%attr(755,root,root) %{_libdir}/libpyldb-util.cpython-3*.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libpyldb-util.cpython-3*.so.2
+%attr(755,root,root) %{py3_sitedir}/ldb.cpython-*.so
+%{py3_sitedir}/_ldb_text.py
+%{py3_sitedir}/__pycache__/_ldb_text.cpython-*.py[co]
 
-%files -n python-ldb-devel
+%files -n python3-ldb-devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libpyldb-util.so
+%attr(755,root,root) %{_libdir}/libpyldb-util.cpython-3*.so
 %{_includedir}/pyldb.h
-%{_pkgconfigdir}/pyldb-util.pc
+%{_pkgconfigdir}/pyldb-util.cpython-3*.pc
This page took 0.105114 seconds and 4 git commands to generate.