]> git.pld-linux.org Git - packages/kp5-kde-cli-tools.git/blobdiff - kp5-kde-cli-tools.spec
- updated to 5.26.1
[packages/kp5-kde-cli-tools.git] / kp5-kde-cli-tools.spec
index a8c6188c4b3350ea5f7680cec445cf49ccec49c2..1fc511b682111a05c72976369ca2db25e5b49836 100644 (file)
@@ -1,15 +1,18 @@
-%define                kdeplasmaver    5.11.2
-%define                qtver           5.3.2
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.26.1
+%define                qtver           5.15.2
 %define                kpname          kde-cli-tools
 Summary:       Tools based on KDE Frameworks 5 to better interact with the system
 Name:          kp5-%{kpname}
-Version:       5.11.2
+Version:       5.26.1
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: 5a001c97f5784ecb14228e35d8edf8f2
-URL:           http://www.kde.org/
+Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
+# Source0-md5: 1064be1dca7a01f6c14c926cd844f52c
+URL:           https://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
 BuildRequires: kf5-extra-cmake-modules >= 1.4.0
@@ -21,7 +24,10 @@ BuildRequires:       kf5-kemoticons-devel
 BuildRequires: kf5-ki18n-devel
 BuildRequires: kf5-kiconthemes-devel
 BuildRequires: kf5-kitemmodels-devel
+BuildRequires: kf5-kpty-devel
 BuildRequires: kf5-kwindowsystem-devel
+BuildRequires: kp5-plasma-workspace-devel >= %{version}
+BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: tar >= 1:1.22
@@ -37,24 +43,27 @@ Tools based on KDE Frameworks 5 to better interact with the system.
 %build
 install -d build
 cd build
-%cmake \
+%cmake -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+       -DHTML_INSTALL_DIR=%{_kdedocdir} \
        ..
-%{__make}
+%ninja_build
+
+%if %{with tests}
+ctest
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
+rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{sr,sr@latin}
 
 %find_lang kde-cli-tools --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
-
 %files -f kde-cli-tools.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/kbroadcastnotification
@@ -68,9 +77,34 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/kstart5
 %attr(755,root,root) %{_bindir}/ksvgtopng5
 %attr(755,root,root) %{_bindir}/ktraderclient5
-%attr(755,root,root) %{_libdir}/kf5/kdeeject
-%attr(755,root,root) %{_libdir}/kf5/kdesu
-%attr(755,root,root) %{_libdir}/libkdeinit5_kcmshell5.so
-%attr(755,root,root) %{_libdir}/qt5/plugins/kcm_filetypes.so
-%{_datadir}/kservices5/filetypes.desktop
+%attr(755,root,root) %{_bindir}/kde-open
+%attr(755,root,root) %{_bindir}/kdecp
+%attr(755,root,root) %{_bindir}/kdemv
+%attr(755,root,root) %{_bindir}/keditfiletype
+%attr(755,root,root) %{_bindir}/kioclient
+%attr(755,root,root) %{_bindir}/kmimetypefinder
+%attr(755,root,root) %{_bindir}/kstart
+%attr(755,root,root) %{_bindir}/ksvgtopng
+%attr(755,root,root) %{_libexecdir}/kf5/kdeeject
+%attr(755,root,root) %{_libexecdir}/kf5/kdesu
+%attr(755,root,root) %{_bindir}/plasma-open-settings
+%{_desktopdir}/org.kde.plasma.settings.open.desktop
 %{_mandir}/man1/kdesu.1*
+%lang(ca) %{_mandir}/ca/man1/kdesu.1*
+%lang(de) %{_mandir}/de/man1/kdesu.1*
+%lang(es) %{_mandir}/es/man1/kdesu.1*
+%lang(et) %{_mandir}/et/man1/kdesu.1*
+%lang(it) %{_mandir}/it/man1/kdesu.1*
+%lang(nb) %{_mandir}/nb/man1/kdesu.1*
+%lang(nl) %{_mandir}/nl/man1/kdesu.1*
+%lang(pt) %{_mandir}/pt/man1/kdesu.1*
+%lang(pt_BR) %{_mandir}/pt_BR/man1/kdesu.1*
+%lang(ru) %{_mandir}/ru/man1/kdesu.1*
+%lang(sr) %{_mandir}/sr/man1/kdesu.1*
+%lang(sv) %{_mandir}/sv/man1/kdesu.1*
+%lang(uk) %{_mandir}/uk/man1/kdesu.1*
+%{_desktopdir}/org.kde.keditfiletype.desktop
+%attr(755,root,root) %{_bindir}/kde-inhibit
+%lang(fr) %{_mandir}/fr/man1/kdesu.1*
+%{_libdir}/qt5/plugins/plasma/kcms/systemsettings_qwidgets/kcm_filetypes.so
+%{_desktopdir}/kcm_filetypes.desktop
This page took 0.156666 seconds and 4 git commands to generate.