]> git.pld-linux.org Git - packages/kp5-kde-cli-tools.git/blobdiff - kp5-kde-cli-tools.spec
- updated to 5.26.1
[packages/kp5-kde-cli-tools.git] / kp5-kde-cli-tools.spec
index 185485c306c4b7cf945610c91da96c810b0d62a1..1fc511b682111a05c72976369ca2db25e5b49836 100644 (file)
@@ -1,14 +1,17 @@
-%define                kdeplasmaver    5.23.3
-%define                qtver           5.9.0
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.26.1
+%define                qtver           5.15.2
 %define                kpname          kde-cli-tools
 Summary:       Tools based on KDE Frameworks 5 to better interact with the system
 Name:          kp5-%{kpname}
-Version:       5.23.3
-Release:       2
+Version:       5.26.1
+Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: ab176e138d13e7c95a1beb845df63fba
+# Source0-md5: 1064be1dca7a01f6c14c926cd844f52c
 URL:           https://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
@@ -21,6 +24,7 @@ BuildRequires:        kf5-kemoticons-devel
 BuildRequires: kf5-ki18n-devel
 BuildRequires: kf5-kiconthemes-devel
 BuildRequires: kf5-kitemmodels-devel
+BuildRequires: kf5-kpty-devel
 BuildRequires: kf5-kwindowsystem-devel
 BuildRequires: kp5-plasma-workspace-devel >= %{version}
 BuildRequires: ninja
@@ -40,11 +44,16 @@ Tools based on KDE Frameworks 5 to better interact with the system.
 install -d build
 cd build
 %cmake -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        -DHTML_INSTALL_DIR=%{_kdedocdir} \
        ..
 %ninja_build
 
+%if %{with tests}
+ctest
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
@@ -55,9 +64,6 @@ rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{sr,sr@latin}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
-
 %files -f kde-cli-tools.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/kbroadcastnotification
@@ -71,12 +77,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/kstart5
 %attr(755,root,root) %{_bindir}/ksvgtopng5
 %attr(755,root,root) %{_bindir}/ktraderclient5
+%attr(755,root,root) %{_bindir}/kde-open
+%attr(755,root,root) %{_bindir}/kdecp
+%attr(755,root,root) %{_bindir}/kdemv
+%attr(755,root,root) %{_bindir}/keditfiletype
+%attr(755,root,root) %{_bindir}/kioclient
+%attr(755,root,root) %{_bindir}/kmimetypefinder
+%attr(755,root,root) %{_bindir}/kstart
+%attr(755,root,root) %{_bindir}/ksvgtopng
 %attr(755,root,root) %{_libexecdir}/kf5/kdeeject
 %attr(755,root,root) %{_libexecdir}/kf5/kdesu
-%attr(755,root,root) %{_libdir}/qt5/plugins/kcm_filetypes.so
 %attr(755,root,root) %{_bindir}/plasma-open-settings
 %{_desktopdir}/org.kde.plasma.settings.open.desktop
-%{_datadir}/kservices5/filetypes.desktop
 %{_mandir}/man1/kdesu.1*
 %lang(ca) %{_mandir}/ca/man1/kdesu.1*
 %lang(de) %{_mandir}/de/man1/kdesu.1*
@@ -94,3 +106,5 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/org.kde.keditfiletype.desktop
 %attr(755,root,root) %{_bindir}/kde-inhibit
 %lang(fr) %{_mandir}/fr/man1/kdesu.1*
+%{_libdir}/qt5/plugins/plasma/kcms/systemsettings_qwidgets/kcm_filetypes.so
+%{_desktopdir}/kcm_filetypes.desktop
This page took 0.095714 seconds and 4 git commands to generate.