]> git.pld-linux.org Git - packages/kodi.git/commitdiff
fix system ffmpeg build, enable it
authorElan Ruusamäe <glen@delfi.ee>
Mon, 19 Jan 2015 16:46:33 +0000 (18:46 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 19 Jan 2015 16:46:33 +0000 (18:46 +0200)
patch from rpmfusion.org:
Remove call to internal ffmpeg function (misused anyway)

dvddemux-ffmpeg.patch [new file with mode: 0644]
kodi.spec

diff --git a/dvddemux-ffmpeg.patch b/dvddemux-ffmpeg.patch
new file mode 100644 (file)
index 0000000..f381899
--- /dev/null
@@ -0,0 +1,16 @@
+origin:
+http://cvs.rpmfusion.org/viewvc/rpms/kodi/devel/kodi-14.0-dvddemux-ffmpeg.patch?revision=1.1&root=free&view=markup
+
+--- xbmc/cores/dvdplayer/DVDDemuxers/DVDDemuxFFmpeg.cpp.orig   2014-08-01 11:18:24.000000000 -0500
++++ xbmc/cores/dvdplayer/DVDDemuxers/DVDDemuxFFmpeg.cpp        2014-08-24 15:36:34.844966866 -0500
+@@ -519,10 +519,6 @@
+ void CDVDDemuxFFmpeg::Flush()
+ {
+-  // naughty usage of an internal ffmpeg function
+-  if (m_pFormatContext)
+-    av_read_frame_flush(m_pFormatContext);
+-
+   m_currentPts = DVD_NOPTS_VALUE;
+   m_pkt.result = -1;
index 2b549331ec3e85c26ce5c73c2f1fe3fc62941c04..0ea7e8be089b513187d215703cdb892a2b8a8651 100644 (file)
--- a/kodi.spec
+++ b/kodi.spec
@@ -49,7 +49,7 @@
 %bcond_without x11             # x11 'Linux Only'
 %bcond_without xrandr          # XRandR support
 # System libs:
-%bcond_with    system_ffmpeg   # build with system ffmpeg
+%bcond_without system_ffmpeg   # build with system ffmpeg
 
 %define        codename Helix
 Summary:       Kodi is a free and open source media-player and entertainment hub
@@ -63,6 +63,7 @@ Source0:      http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
 Source1:       https://github.com/xbmc/FFmpeg/archive/2.4.4-%{codename}.tar.gz
 # Source1-md5: 19b5d29ef6b5a6fc202c652fe3905d9b
 Patch0:                jpeglib-boolean.patch
+Patch1:                dvddemux-ffmpeg.patch
 URL:           http://kodi.tv/
 BuildRequires: Mesa-libGLU-devel
 BuildRequires: OpenGL-devel
@@ -188,6 +189,7 @@ all common digital media files from local and network storage media.
 %prep
 %setup -q -n xbmc-%{version}-%{codename}
 %patch0 -p1
+%patch1 -p0
 
 %if %{without system_ffmpeg}
 ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
This page took 0.16033 seconds and 4 git commands to generate.