]> git.pld-linux.org Git - packages/kodi.git/blobdiff - xbmc.spec
- updated gettext BR
[packages/kodi.git] / xbmc.spec
index fe0b380171e5916d62c49c2bd8ea53a5124126e1..658bdbe94af5b8fa91c373e5fb3852a45c9ae30b 100644 (file)
--- a/xbmc.spec
+++ b/xbmc.spec
@@ -2,28 +2,28 @@
 # TODO:
 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
 #  - fix linking argument order
-#  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
-#    only libXrandr 1.1 - with no gamma support; it causes application crash
-#    on XRRSetCrtcGamma function called by SDL_SetVideoMode)
 #  - add and/or fix users/groups permissions
 #  - split to subpackages?
 #
 # Conditional build:
+%bcond_without cec     # build without cec support
 %bcond_without goom    # build without goom visualisation
-%bcond_with    hal                     # build with HAL
+%bcond_with    hal     # build with HAL
+
+%define        codename Gotham
 
 Summary:       XBMC is a free and open source media-player and entertainment hub
 Name:          xbmc
-Version:       11.0
-Release:       1
+Version:       13.2
+Release:       2
 License:       GPL v2+ and GPL v3+
 Group:         Applications/Multimedia
 Source0:       http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
-# Source0-md5: 9e8a26ee25173c7268abea7f1d82d428
+# Source0-md5: d80153b2cc78b88966458ab136e9494f
+Patch0:                jpeglib-boolean.patch
 URL:           http://xbmc.org/
 BuildRequires: Mesa-libGLU-devel
 BuildRequires: OpenGL-devel
-BuildRequires: SDL-devel
 BuildRequires: SDL_image-devel
 BuildRequires: SDL_mixer-devel
 BuildRequires: alsa-lib-devel
@@ -43,18 +43,23 @@ BuildRequires:      freetype-devel
 BuildRequires: fribidi-devel
 BuildRequires: gawk
 BuildRequires: gettext-autopoint
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 BuildRequires: glew-devel
 BuildRequires: gperf
-%if %{with hal}
-BuildRequires: hal-devel
-%endif
+%{?with_hal:BuildRequires:     hal-devel}
 BuildRequires: jasper-devel
+BuildRequires: jre
 BuildRequires: libass-devel
-BuildRequires: libbluray-devel
+BuildRequires: libbluray-devel >= 0.2.1
+BuildRequires: libcap-devel
 BuildRequires: libcdio-devel
+%{?with_cec:BuildRequires:     libcec-devel}
+%ifarch i686 pentium4 athlon %{x8664}
+BuildRequires: libcrystalhd-devel
+%endif
 BuildRequires: libgcrypt-devel
 BuildRequires: libjpeg-devel
+BuildRequires: libltdl-devel
 BuildRequires: libmad-devel
 BuildRequires: libmicrohttpd-devel
 BuildRequires: libmodplug-devel
@@ -69,6 +74,7 @@ BuildRequires:        libssh-devel
 BuildRequires: libtiff-devel
 BuildRequires: libtool
 BuildRequires: libva-devel
+BuildRequires: libva-glx-devel
 BuildRequires: libvdpau-devel
 BuildRequires: libvorbis-devel
 BuildRequires: lzo-devel
@@ -78,7 +84,6 @@ BuildRequires:        nasm
 %endif
 BuildRequires: openssl-devel
 BuildRequires: pcre-cxx-devel
-BuildRequires: pcre-devel
 BuildRequires: pkgconfig
 BuildRequires: pulseaudio-devel
 BuildRequires: python-devel >= 2.4
@@ -87,6 +92,9 @@ BuildRequires:        rpmbuild(macros) >= 1.566
 # used internally
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel
+BuildRequires: swig
+BuildRequires: taglib-devel >= 1.8
+BuildRequires: tinyxml-devel
 BuildRequires: udev-devel
 BuildRequires: unzip
 BuildRequires: xorg-lib-libX11-devel
@@ -106,10 +114,6 @@ BuildRequires:     zlib-devel
 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
 #https://github.com/albertz/shairport
 #BuildRequires: libshairport
-#http://www.broadcom.com/support/crystal_hd/
-#BuildRequires:        crystalhd-devel
-#http://libcec.pulse-eight.com/
-#BuildRequires:        libcec-devel >= 1.1.0
 Requires:      /usr/bin/glxinfo
 Requires:      SDL >= 1.2.14-5
 Requires:      lsb-release
@@ -123,23 +127,25 @@ and featuring playlist, audio visualizations, slideshow, and weather
 forecast functions, together third-party plugins.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}-%{codename}
+%patch0 -p1
 
 %build
 ./bootstrap
 %configure \
        --disable-debug \
        --enable-external-libraries \
+       --enable-pulse \
        --enable-udev \
-       --disable-libcec \
        --disable-libusb \
        --disable-nfs \
        --disable-afpclient \
        --disable-airtunes \
-       --disable-crystalhd \
        %{__enable_disable goom} \
-       %{__enable_disable hal}
+       %{__enable_disable hal} \
+       %{__enable_disable libcec}
 
+LIBS="-lpthread"
 %{__make} V=1
 
 %install
This page took 0.135862 seconds and 4 git commands to generate.