]> git.pld-linux.org Git - packages/kodi.git/blobdiff - kodi.spec
specifiy libmicrohttpd required version
[packages/kodi.git] / kodi.spec
index a429044970224fa39a75337ecc5584d98a7c3bd7..0f2bb8e19ec04615403cfd81ea768052e8461de0 100644 (file)
--- a/kodi.spec
+++ b/kodi.spec
@@ -53,7 +53,7 @@
 %bcond_with    system_dvdread  # build with system dvdread
 
 %define        codename Leia
-%define        subver  a1
+%define        subver  a2
 Summary:       Kodi is a free and open source media-player and entertainment hub
 Name:          kodi
 Version:       18.0
@@ -62,7 +62,7 @@ License:      GPL v2+ and GPL v3+
 Group:         Applications/Multimedia
 #Source0:      http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
 Source0:       https://github.com/xbmc/xbmc/archive/%{version}%{subver}-%{codename}.tar.gz
-# Source0-md5: c1ae435c2d674262cee9a06791ba94bc
+# Source0-md5: 6e2262d8b38d4ed28f0b102e51eb9a8e
 Patch0:                jpeglib-boolean.patch
 Patch1:                disable-static.patch
 Patch2:                dvdread.patch
@@ -83,6 +83,7 @@ BuildRequires:        crossguid-devel
 BuildRequires: curl-devel
 BuildRequires: dbus-devel
 BuildRequires: libfmt-devel >= 3.0.1
+BuildRequires: rapidjson-devel >= 1.1.0
 # libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
 %{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 2.4.4}
 BuildRequires: flac-devel
@@ -104,11 +105,12 @@ BuildRequires:    libcap-devel
 BuildRequires: libcdio-devel
 %{?with_libcec:BuildRequires:  libcec-devel >= 3.0.0}
 BuildRequires: libdrm-devel
+BuildRequires: libdvdcss-devel >= 1.4.1
 %{?with_system_dvdread:BuildRequires:  libdvdread-devel}
 BuildRequires: libgcrypt-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel
-BuildRequires: libmicrohttpd-devel
+BuildRequires: libmicrohttpd-devel >= 0.9.40
 BuildRequires: libogg-devel
 BuildRequires: libplist-devel
 BuildRequires: libpng-devel
@@ -173,6 +175,11 @@ Requires:  libvorbis
 Obsoletes:     xbmc < 14.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# extracting debug info from /home/users/glen/tmp/kodi-18.0-root-glen/usr/lib64/kodi/kodi-x11
+# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
+%define                _noautostrip    kodi-x11
+%define                _enable_debug_packages  0
+
 %description
 Kodi Entertainment Center (formerly XBMC) is a free and open-source
 media player software developed by the XBMC Foundation, a non-profit
@@ -189,7 +196,7 @@ all common digital media files from local and network storage media.
 %{?with_system_dvdread:%patch2 -p1}
 #%patch3 -p1
 #%patch4 -p1
-%{!?with_system_dvdread:%patch5 -p1}
+%patch5 -p1
 
 #%{__rm} -r lib/cximage-6.0/zlib
 #%{__rm} -r lib/libhdhomerun
@@ -207,7 +214,14 @@ all common digital media files from local and network storage media.
 %build
 install -d build
 cd build
-%cmake ..
+# cmake not picking up include path from pkgconfig
+# https://trac.kodi.tv/ticket/16861
+%define        specflags -I/usr/include/freetype2
+%cmake \
+       -DENABLE_INTERNAL_LIBDVD=OFF \
+       -DENABLE_INTERNAL_CROSSGUID=OFF \
+       -DENABLE_DVDCSS=%{__true_false dvdcss} \
+       ..
 %if 0
 %configure \
        ac_cv_type__Bool=yes \
@@ -222,7 +236,6 @@ cd build
        %{__enable_disable asap_codec asap-codec} \
        %{__enable_disable avahi} \
        %{__enable_disable dbus} \
-       %{__enable_disable dvdcss} \
        %{__enable_disable gles} \
        %{__enable_disable gl} \
        %{__enable_disable gtest} \
@@ -266,15 +279,13 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/{version.txt,copying.txt,README.linux,LICENSE.GPL}
+
+# not packaged
+%{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/firewalld/services/kodi-*.xml
 
 # no -devel package yet
 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
-%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
-
-# no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
-%{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -282,6 +293,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README.md docs/README.linux
+%attr(755,root,root) %{_bindir}/TexturePacker
 %attr(755,root,root) %{_bindir}/kodi
 %attr(755,root,root) %{_bindir}/kodi-standalone
 %{_datadir}/%{name}
@@ -289,8 +301,3 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/kodi.desktop
 %{_iconsdir}/hicolor/*/apps/%{name}.png
 %{_datadir}/xsessions/kodi.desktop
-
-# legacy xbmc compatibility links
-%attr(755,root,root) %{_bindir}/xbmc
-%attr(755,root,root) %{_bindir}/xbmc-standalone
-%{_datadir}/xsessions/xbmc.desktop
This page took 0.077366 seconds and 4 git commands to generate.