]> git.pld-linux.org Git - packages/kodi.git/blame - xbmc.spec
- added bcond for goom visualisation
[packages/kodi.git] / xbmc.spec
CommitLineData
18b90c81
SP
1#
2# TODO:
3a71016a 3# - fix build flags - some files are compiled with -O3 and without rpm*flags
c1b45330 4# - fix linking argument order
63ff963e 5# - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6# only libXrandr 1.1 - with no gamma support; it causes application crash
7# on XRRSetCrtcGamma function called by SDL_SetVideoMode)
92b96980 8# - add and/or fix users/groups permissions
63ff963e 9# - split to subpackages?
92b96980 10# - check how it works with external python libraries
18b90c81 11#
92b96980 12# Conditional build:
13%bcond_with external_python
9e98e23b 14%bcond_without goom
92b96980 15
18b90c81
SP
16Summary: XBMC
17Name: xbmc
92b96980 18Version: 10.0
2e649bc9
AF
19Release: 0.1
20License: GPL v3
18b90c81 21Group: Applications/Multimedia
54721144 22Source0: http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
92b96980 23# Source0-md5: 728fb514e5f43f27bb880305061b4e72
18b90c81 24URL: http://xbmc.org
01f2a87d 25Patch0: %{name}-nobash.patch
63ff963e 26Patch1: %{name}-python27.patch
92b96980 27Patch2: %{name}-libpng14.patch
18b90c81
SP
28BuildRequires: SDL_image-devel
29BuildRequires: SDL_mixer-devel
c462fd57 30BuildRequires: a52dec-libs-devel
18b90c81
SP
31BuildRequires: alsa-lib-devel
32BuildRequires: autoconf
33BuildRequires: automake
34BuildRequires: avahi-devel
5a2f2b01 35BuildRequires: boost-devel
18b90c81
SP
36BuildRequires: bzip2-devel
37BuildRequires: cmake
38BuildRequires: curl-devel
39BuildRequires: dbus-devel
ddeff5bb 40BuildRequires: enca
18b90c81
SP
41BuildRequires: enca-devel
42BuildRequires: faac-devel
5a2f2b01 43BuildRequires: faad2-devel
c462fd57 44BuildRequires: ffmpeg-devel
5a2f2b01 45BuildRequires: flac-devel
18b90c81
SP
46BuildRequires: fontconfig-devel
47BuildRequires: freetype-devel
48BuildRequires: fribidi-devel
49BuildRequires: gawk
63ff963e 50BuildRequires: gettext-autopoint
5a2f2b01 51BuildRequires: gettext-devel
18b90c81
SP
52BuildRequires: glew-devel
53BuildRequires: gperf
5a2f2b01 54BuildRequires: gtk+-devel
55BuildRequires: hal-devel
56BuildRequires: jasper-devel
57BuildRequires: libao-devel
18b90c81 58BuildRequires: libcdio-devel
c462fd57 59BuildRequires: libdts-devel
18b90c81
SP
60BuildRequires: libjpeg-devel
61BuildRequires: libmad-devel
63ff963e 62BuildRequires: libmicrohttpd-devel
18b90c81 63BuildRequires: libmms-devel
63ff963e 64BuildRequires: libmodplug-devel
c462fd57 65BuildRequires: libmpeg2-devel
18b90c81 66BuildRequires: libogg-devel
5a2f2b01 67BuildRequires: libpng-devel
18b90c81
SP
68BuildRequires: libsamplerate-devel
69BuildRequires: libsmbclient-devel
5a2f2b01 70BuildRequires: libtiff-devel
71BuildRequires: libtool
72BuildRequires: libvdpau-devel
18b90c81 73BuildRequires: libvorbis-devel
5a2f2b01 74BuildRequires: lzo-devel
75BuildRequires: mysql-devel
c1b45330 76%ifarch %{ix86}
26cae375 77BuildRequires: nasm
c1b45330 78%endif
18b90c81 79BuildRequires: openssl-devel
63ff963e 80BuildRequires: pcre-cxx-devel
5a2f2b01 81BuildRequires: pkgconfig
18b90c81 82BuildRequires: pulseaudio-devel
c462fd57 83BuildRequires: python-devel
3a71016a 84BuildRequires: rpm-pythonprov
c462fd57 85# used internally
86BuildRequires: sed >= 4.0
18b90c81 87BuildRequires: sqlite3-devel
5a2f2b01 88BuildRequires: unzip
c462fd57 89BuildRequires: wavpack-devel
5a2f2b01 90BuildRequires: xmms-devel
91BuildRequires: xorg-lib-libXinerama-devel
18b90c81 92BuildRequires: xorg-lib-libXrandr-devel
5a2f2b01 93BuildRequires: xorg-lib-libXtst-devel
18b90c81
SP
94BuildRequires: zip
95BuildRequires: zlib-devel
63ff963e 96Requires: /usr/bin/glxinfo
a58652d4
SP
97Requires: lsb-release
98Requires: xorg-app-xdpyinfo
18b90c81
SP
99BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101%description
102
103%prep
c1b45330 104%setup -q
01f2a87d 105%patch0 -p1
6d158894 106enca -L none -x ISO8859-1 xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
51b524ca 107%patch1 -p1
92b96980 108#%patch2 -p1
18b90c81
SP
109
110%build
111./bootstrap
65712ad3 112%configure \
51b524ca
KK
113 --disable-debug \
114 --enable-external-libraries \
9e98e23b 115 --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python \
116 --%{?with_goom:en}%{!?with_goom:dis}able-goom
18b90c81
SP
117%{__make}
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
122%{__make} install \
92b96980 123 DESTDIR=$RPM_BUILD_ROOT
18b90c81
SP
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
0fc95f40 128%posttrans
129%banner -e xbmc <<EOF
130WARNING!
131If you use nvidia binary drivers be sure that SDL is compiled without
132XRandR and VidMode gamma ramps support.
133This means that you need to rebuild it with command:
134builder -bb --without new_gamma_ramp SDL
135EOF
136
18b90c81
SP
137%files
138%defattr(644,root,root,755)
47308569 139#doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
18b90c81 140
47308569 141#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
18b90c81
SP
142%attr(755,root,root) %{_bindir}/*
143%{_datadir}/%{name}
92b96980 144%attr(755,root,root) %{_libdir}/%{name}
145%{_docdir}/%{name}
c1b45330 146%{_desktopdir}/%{name}.desktop
92b96980 147%{_iconsdir}/hicolor/256x256/apps/%{name}.png
148%{_iconsdir}/hicolor/48x48/apps/%{name}.png
3a71016a 149%{_datadir}/xsessions/XBMC.desktop
This page took 0.154247 seconds and 4 git commands to generate.