]> git.pld-linux.org Git - packages/kodi.git/blame - xbmc.spec
- one more
[packages/kodi.git] / xbmc.spec
CommitLineData
18b90c81
SP
1#
2# TODO:
3a71016a 3# - fix build flags - some files are compiled with -O3 and without rpm*flags
c1b45330 4# - fix linking argument order
63ff963e 5# - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6# only libXrandr 1.1 - with no gamma support; it causes application crash
7# on XRRSetCrtcGamma function called by SDL_SetVideoMode)
92b96980 8# - add and/or fix users/groups permissions
63ff963e 9# - split to subpackages?
92b96980 10# - check how it works with external python libraries
18b90c81 11#
92b96980 12# Conditional build:
13%bcond_with external_python
9e98e23b 14%bcond_without goom
92b96980 15
18b90c81
SP
16Summary: XBMC
17Name: xbmc
f4f8f308
KK
18Version: 10.1
19Release: 0.1
2e649bc9 20License: GPL v3
18b90c81 21Group: Applications/Multimedia
54721144 22Source0: http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
f4f8f308 23# Source0-md5: 391398126cb86a4f6fbd0b7037997d84
b2f93b43 24Source1: goom_icon.png
25# Source1-md5: 8c0ffe2055f2cfde1189687d12a68aa8
18b90c81 26URL: http://xbmc.org
01f2a87d 27Patch0: %{name}-nobash.patch
63ff963e 28Patch1: %{name}-python27.patch
0aae19c0 29Patch2: %{name}-subtitle_tags.patch
b2f93b43 30Patch3: %{name}-goom_enable.patch
18b90c81
SP
31BuildRequires: SDL_image-devel
32BuildRequires: SDL_mixer-devel
c462fd57 33BuildRequires: a52dec-libs-devel
18b90c81
SP
34BuildRequires: alsa-lib-devel
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: avahi-devel
5a2f2b01 38BuildRequires: boost-devel
18b90c81
SP
39BuildRequires: bzip2-devel
40BuildRequires: cmake
41BuildRequires: curl-devel
42BuildRequires: dbus-devel
43BuildRequires: enca-devel
44BuildRequires: faac-devel
5a2f2b01 45BuildRequires: faad2-devel
c462fd57 46BuildRequires: ffmpeg-devel
5a2f2b01 47BuildRequires: flac-devel
18b90c81
SP
48BuildRequires: fontconfig-devel
49BuildRequires: freetype-devel
50BuildRequires: fribidi-devel
51BuildRequires: gawk
63ff963e 52BuildRequires: gettext-autopoint
5a2f2b01 53BuildRequires: gettext-devel
18b90c81
SP
54BuildRequires: glew-devel
55BuildRequires: gperf
5a2f2b01 56BuildRequires: gtk+-devel
57BuildRequires: hal-devel
58BuildRequires: jasper-devel
59BuildRequires: libao-devel
18b90c81 60BuildRequires: libcdio-devel
c462fd57 61BuildRequires: libdts-devel
18b90c81
SP
62BuildRequires: libjpeg-devel
63BuildRequires: libmad-devel
63ff963e 64BuildRequires: libmicrohttpd-devel
18b90c81 65BuildRequires: libmms-devel
63ff963e 66BuildRequires: libmodplug-devel
c462fd57 67BuildRequires: libmpeg2-devel
18b90c81 68BuildRequires: libogg-devel
5a2f2b01 69BuildRequires: libpng-devel
18b90c81
SP
70BuildRequires: libsamplerate-devel
71BuildRequires: libsmbclient-devel
5a2f2b01 72BuildRequires: libtiff-devel
73BuildRequires: libtool
74BuildRequires: libvdpau-devel
18b90c81 75BuildRequires: libvorbis-devel
5a2f2b01 76BuildRequires: lzo-devel
77BuildRequires: mysql-devel
c1b45330 78%ifarch %{ix86}
26cae375 79BuildRequires: nasm
c1b45330 80%endif
18b90c81 81BuildRequires: openssl-devel
63ff963e 82BuildRequires: pcre-cxx-devel
5a2f2b01 83BuildRequires: pkgconfig
18b90c81 84BuildRequires: pulseaudio-devel
c462fd57 85BuildRequires: python-devel
3a71016a 86BuildRequires: rpm-pythonprov
6f41c837 87BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 88# used internally
89BuildRequires: sed >= 4.0
18b90c81 90BuildRequires: sqlite3-devel
5a2f2b01 91BuildRequires: unzip
c462fd57 92BuildRequires: wavpack-devel
5a2f2b01 93BuildRequires: xmms-devel
94BuildRequires: xorg-lib-libXinerama-devel
18b90c81 95BuildRequires: xorg-lib-libXrandr-devel
5a2f2b01 96BuildRequires: xorg-lib-libXtst-devel
18b90c81
SP
97BuildRequires: zip
98BuildRequires: zlib-devel
63ff963e 99Requires: /usr/bin/glxinfo
f4f8f308 100Requires: SDL >= 1.2.14-5
a58652d4
SP
101Requires: lsb-release
102Requires: xorg-app-xdpyinfo
18b90c81
SP
103BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105%description
106
107%prep
c1b45330 108%setup -q
01f2a87d 109%patch0 -p1
bfde9a19 110%undos xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
51b524ca 111%patch1 -p1
0aae19c0 112%patch2 -p1
b2f93b43 113%patch3 -p1
18b90c81
SP
114
115%build
116./bootstrap
65712ad3 117%configure \
51b524ca
KK
118 --disable-debug \
119 --enable-external-libraries \
9e98e23b 120 --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python \
121 --%{?with_goom:en}%{!?with_goom:dis}able-goom
18b90c81
SP
122%{__make}
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127%{__make} install \
92b96980 128 DESTDIR=$RPM_BUILD_ROOT
b2f93b43 129 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/xbmc/addons/visualization.goom/icon.png
18b90c81
SP
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%files
135%defattr(644,root,root,755)
47308569 136#doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
18b90c81 137
47308569 138#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
18b90c81
SP
139%attr(755,root,root) %{_bindir}/*
140%{_datadir}/%{name}
92b96980 141%attr(755,root,root) %{_libdir}/%{name}
142%{_docdir}/%{name}
c1b45330 143%{_desktopdir}/%{name}.desktop
92b96980 144%{_iconsdir}/hicolor/256x256/apps/%{name}.png
145%{_iconsdir}/hicolor/48x48/apps/%{name}.png
3a71016a 146%{_datadir}/xsessions/XBMC.desktop
This page took 0.118167 seconds and 4 git commands to generate.