]> git.pld-linux.org Git - packages/kodi-addon-inputstream-adaptive.git/commitdiff
new
authorJan Palus <atler@pld-linux.org>
Tue, 1 Feb 2022 19:08:36 +0000 (20:08 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 1 Feb 2022 19:08:36 +0000 (20:08 +0100)
kodi-addon-inputstream-adaptive.spec [new file with mode: 0644]

diff --git a/kodi-addon-inputstream-adaptive.spec b/kodi-addon-inputstream-adaptive.spec
new file mode 100644 (file)
index 0000000..ef47046
--- /dev/null
@@ -0,0 +1,51 @@
+%define                kodi_ver        19
+%define                next_kodi_ver   %(echo $((%{kodi_ver}+1)))
+%define                codename        Matrix
+%define                addon           inputstream.adaptive
+
+Summary:       Kodi InputStream addon for several manifest types
+Name:          kodi-addon-inputstream-adaptive
+Version:       %{kodi_ver}.0.2
+Release:       1
+License:       GPL v2+
+Group:         Applications/Multimedia
+Source0:       https://github.com/xbmc/inputstream.adaptive/archive/%{version}-%{codename}/%{version}-%{codename}.tar.gz
+# Source0-md5: 1bfb4731c249e01535c2c4054e0e4ea6
+URL:           https://github.com/xbmc/inputstream.adaptive
+BuildRequires: cmake >= 3.10
+BuildRequires: expat-devel
+BuildRequires: kodi-devel >= %{kodi_ver}
+BuildRequires: kodi-devel < %{next_kodi_ver}
+BuildRequires: libstdc++-devel >= 6:7
+BuildRequires: rpmbuild(macros) >= 1.605
+Requires:      kodi >= %{kodi_ver}
+Requires:      kodi < %{next_kodi_ver}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Kodi InputStream addon for several manifest types
+
+%prep
+%setup -q -n %{addon}-%{version}-%{codename}
+
+%build
+%cmake -B build \
+       -DBUILD_TESTING:BOOL=OFF
+%{__make} -C build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%dir %{_libdir}/kodi/addons/%{addon}
+%attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/%{addon}.so.%{version}
+%attr(755,root,root) %{_libdir}/kodi/addons/%{addon}/libssd_wv.so
+%dir %{_datadir}/kodi/addons/%{addon}
+%{_datadir}/kodi/addons/%{addon}/addon.xml
+%{_datadir}/kodi/addons/%{addon}/resources
This page took 0.391563 seconds and 4 git commands to generate.