]> git.pld-linux.org Git - packages/klibc.git/commitdiff
- klcc patch reworked (it passes `-static` flag to the linker correctly now). auto/ac/klibc-1_0-1
authorPaweł Sikora <pluto@pld-linux.org>
Mon, 13 Jun 2005 20:39:35 +0000 (20:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    klibc-klcc.patch -> 1.2
    klibc.spec -> 1.35

klibc-klcc.patch
klibc.spec

index 00acc75f69f0f8a707b5c702453b3a2e79d8f452..76916680eb2dd01dfdd95949380c8d0e827ba780 100644 (file)
@@ -1,6 +1,6 @@
 --- klibc-1.0/klcc.in.orig     2005-03-07 22:44:49.000000000 +0100
 +++ klibc-1.0/klcc.in  2005-06-13 21:05:09.000000000 +0200
-@@ -1,9 +1,9 @@
+@@ -1,22 +1,22 @@
  # -*- perl -*-
  
  # Standard includes
  
  # Default optimization options (for compiles without -g)
  @optopt =  @OPTFLAGS;
-@@ -13,10 +13,10 @@
- @stdlibpath = ("-L${prefix}/${KCROSS}lib");
+ @goptopt = ('-O');
+ # Standard library directories
+-@stdlibpath = ("-L${prefix}/${KCROSS}lib");
++@stdlibpath = ("-L${libdir}");
  
  # Options and libraries to pass to ld; shared versus static
 -@staticopt = ("${prefix}/${KCROSS}lib/crt0.o");
 -@staticlib = ("${prefix}/${KCROSS}lib/libc.a");
 -@sharedopt = (@EMAIN, "${prefix}/${KCROSS}lib/interp.o");
 -@sharedlib = ('-R', "${prefix}/${KCROSS}lib/libc.so");
-+@staticopt = ("${libdir}/crt0.o");
-+@staticlib = ("${libdir}/libc.a");
-+@sharedopt = (@EMAIN, "${libdir}/interp.o");
-+@sharedlib = ('-R', "${libdir}/libc.so");
++@staticopt = ("${libdir}/klibc/crt0.o");
++@staticlib = ("${libdir}/klibc/libc.a");
++@sharedopt = (@EMAIN, "${libdir}/klibc/interp.o");
++@sharedlib = ('-R', "${libdir}/klibc/libc.so");
  
  # Returns the language (-x option string) for a specific extension.
  sub filename2lang($) {
+@@ -164,6 +164,7 @@
+     } elsif ( $a eq '-shared' ) {
+       $shared = 1;
+     } elsif ( $a eq '-static' ) {
++      push(@ldopt, $a);
+       $shared = 0;
+     } elsif ( $a eq '-s' ) {
+       $strip = 1;
 --- klibc-1.0/Makefile.orig    2005-03-07 19:17:15.000000000 +0100
 +++ klibc-1.0/Makefile 2005-06-13 20:57:41.000000000 +0200
 @@ -27,10 +27,10 @@
index 814a803ea62400d67642cd032ede87fd6b735edd..4da2489f5c691450ff6da10033f1795dd4b6f117 100644 (file)
@@ -78,7 +78,7 @@ ln -sf %{_kernelsrcdir}/include/linux/autoconf-up.h include/linux/autoconf.h
 %endif
        bindir=%{_bindir} \
        includedir=%{_includedir}/klibc \
-       libdir=%{_libdir}/klibc \
+       libdir=%{_libdir} \
        prefix=%{_prefix} \
        OPTFLAGS="%{rpmcflags} -Os -fomit-frame-pointer -falign-functions=0 \
                -falign-jumps=0 -falign-loops=0 -ffreestanding"
This page took 0.113883 seconds and 4 git commands to generate.